From: kym blair (kymblair@hotmail.com)
Date: Sat Apr 26 2003 - 04:52:10 GMT-3
Kasturi,
You are correct ... CLNS MAP statement is not needed for point-to-point
subinterface (uses inverse-arp). Several people asked about various
combinations of interfaces. Here is a longer explanation.
POINT-TO-POINT -- you can build full-mesh or hub-and-spoke topologies using
point-to-point, but each link will require its own address space. The rest
of this discussion assumes full-mesh/hub-and-spoke using one subnet.
FULL-MESH -- works if all routers are using main interface
(requires CLNS MAP statements)
FULL-MESH -- works if all routers are using multipoint subinterface
(requires CLNS MAP statements)
FULL-MESH -- some routers using main interface, some multipoint = FAIL
HUB-AND-SPOKE using main interface doesn't work (hub forms neighbor
relationships with both spokes, but drops all routes except for one spoke)
HUB-AND-SPOKE using multipoint subinterface doesn't work (hub forms neighbor
relationships with both spokes, but drops all routes except for one spoke)
==============================================
IF YOU WANT TO SEE ALL THE CONFIGS AND DETAILS:
BASIC SETUP:
hostname R2
!
interface Loopback0
ip address 150.1.2.2 255.255.255.0
ip router isis
!
router isis
net 47.0234.2222.2222.2222.00
is-type level-1
hostname R3
!
interface Loopback0
ip address 150.1.3.3 255.255.255.0
ip router isis
!
router isis
net 47.0234.3333.3333.3333.00
is-type level-1
hostname R4
!
interface Loopback0
ip address 150.1.4.4 255.255.255.0
ip router isis
!
router isis
net 47.0234.4444.4444.4444.00
is-type level-1
==================================================
(1A) HUB-AND-SPOKE USING MULTIPOINT SUBINT (FAILS)
hostname R2
!
interface Serial0
no ip address
encapsulation frame-relay
!
interface Serial0.234 multipoint
ip address 150.1.234.2 255.255.255.0
ip router isis
frame-relay map clns 203 broadcast
frame-relay map ip 150.1.234.2 203 broadcast
frame-relay map ip 150.1.234.3 203 broadcast
frame-relay map ip 150.1.234.4 203 broadcast
no frame-relay inverse-arp
hostname R3
!
interface Serial0
no ip address
encapsulation frame-relay
!
interface Serial0.234 multipoint
ip address 150.1.234.3 255.255.255.0
ip router isis
frame-relay map clns 304 broadcast
frame-relay map clns 302 broadcast
frame-relay map ip 150.1.234.2 302 broadcast
frame-relay map ip 150.1.234.3 302 broadcast
frame-relay map ip 150.1.234.4 304 broadcast
no frame-relay inverse-arp
hostname R4
!
interface Serial0
no ip address
encapsulation frame-relay
!
interface Serial0.234 multipoint
ip address 150.1.234.4 255.255.255.0
ip router isis
frame-relay map clns 403 broadcast
frame-relay map ip 150.1.234.2 403 broadcast
frame-relay map ip 150.1.234.3 403 broadcast
frame-relay map ip 150.1.234.4 403 broadcast
no frame-relay inverse-arp
RELOAD R2 and R3, WAIT 20 SEC., RELOAD R4 -----
WATCH R3 ... AT FIRST, R2 NEIGHBOR OKAY:
R3#sh clns is-n
R2 Se0.234 Up L1 64 R3.02 Phase V
R3#sh ip route
C 150.1.234.0 is directly connected, Serial0.234
C 150.1.3.0 is directly connected, Loopback0
i L1 150.1.2.0 [115/20] via 150.1.234.2, Serial0.234
BUT AFTER R4 COMES UP (R2 NEI SHOWN, BUT NO ROUTES):
R3#sh clns is-n
R2 Se0.234 Up L1 64 R4.02 Phase V
R4 Se0.234 Up L1 64 R4.02 Phase V
R3#sh ip route
C 150.1.234.0 is directly connected, Serial0.234
i L1 150.1.4.0 [115/20] via 150.1.234.4, Serial0.234
C 150.1.3.0 is directly connected, Loopback0
=============================================
(1A) HUB-AND-SPOKE USING MAIN INT (FAILS)
hostname R2
!
interface Serial0
encapsulation frame-relay
ip address 150.1.234.2 255.255.255.0
ip router isis
frame-relay map clns 203 broadcast
frame-relay map ip 150.1.234.2 203 broadcast
frame-relay map ip 150.1.234.3 203 broadcast
frame-relay map ip 150.1.234.4 203 broadcast
no frame-relay inverse-arp
hostname R3
!
interface Serial0
encapsulation frame-relay
ip address 150.1.234.3 255.255.255.0
ip router isis
frame-relay map clns 304 broadcast
frame-relay map clns 302 broadcast
frame-relay map ip 150.1.234.2 302 broadcast
frame-relay map ip 150.1.234.3 302 broadcast
frame-relay map ip 150.1.234.4 304 broadcast
no frame-relay inverse-arp
hostname R4
!
interface Serial0
encapsulation frame-relay
ip address 150.1.234.4 255.255.255.0
ip router isis
frame-relay map clns 403 broadcast
frame-relay map ip 150.1.234.2 403 broadcast
frame-relay map ip 150.1.234.3 403 broadcast
frame-relay map ip 150.1.234.4 403 broadcast
no frame-relay inverse-arp
RESULT -- at first, R3 sees R2 routes, but once R4 neighbors up,
R3 only sees R4 routes:
R3#sh clns nei
R2 Se0 DLCI 302 Up 22 L1 IS-IS
R4 Se0 DLCI 304 Up 9 L1 IS-IS
R3#sh ip route
C 150.1.234.0 is directly connected, Serial0
i L1 150.1.4.0 [115/20] via 150.1.234.4, Serial0
C 150.1.3.0 is directly connected, Loopback0
============================================================
(2A) FULL-MESH USING MULTIPOINT SUBINT WITH MAP STMTS: (WORKS)
hostname R2
!
interface Serial0.234 multipoint
ip address 150.1.234.2 255.255.255.0
ip router isis
frame-relay map clns 204 broadcast
frame-relay map clns 203 broadcast
frame-relay map ip 150.1.234.2 203 broadcast
frame-relay map ip 150.1.234.3 203 broadcast
frame-relay map ip 150.1.234.4 204 broadcast
no frame-relay inverse-arp
hostname R3
!
interface Serial0.234 multipoint
ip address 150.1.234.3 255.255.255.0
ip router isis
frame-relay map clns 304 broadcast
frame-relay map clns 302 broadcast
frame-relay map ip 150.1.234.2 302 broadcast
frame-relay map ip 150.1.234.3 302 broadcast
frame-relay map ip 150.1.234.4 304 broadcast
no frame-relay inverse-arp
hostname R4
!
interface Serial0.234 multipoint
ip address 150.1.234.4 255.255.255.0
ip router isis
frame-relay map clns 402 broadcast
frame-relay map clns 403 broadcast
frame-relay map ip 150.1.234.2 403 broadcast
frame-relay map ip 150.1.234.3 403 broadcast
frame-relay map ip 150.1.234.4 402 broadcast
no frame-relay inverse-arp
RESULTS -- R2, R3, R4 ALL GOOD:
R3#sh clns is
R2 Se0.234 Up L1 64 R4.02 Phase V
R4 Se0.234 Up L1 64 R4.02 Phase V
R3#sh ip route
C 150.1.234.0 is directly connected, Serial0.234
i L1 150.1.4.0 [115/20] via 150.1.234.4, Serial0.234
C 150.1.3.0 is directly connected, Loopback0
i L1 150.1.2.0 [115/20] via 150.1.234.2, Serial0.234
==============================================================
(2B) -- REMOVE ANY CLNS MAP, AND THAT LINK FAILS:
(LEARNS THE NEIGHBORS, BUT NO EXCHANGE OF ROUTES):
hostname R3
!
interface Serial0.234 multipoint
ip address 150.1.234.3 255.255.255.0
ip router isis
frame-relay map ip 150.1.234.2 302 broadcast
frame-relay map ip 150.1.234.3 302 broadcast
frame-relay map ip 150.1.234.4 304 broadcast
no frame-relay inverse-arp
R3#sh clns is
R2 Se0.234 Init L1 128 R4.02 Phase V
R4 Se0.234 Init L1 128 R4.02 Phase V
R3#sh ip route
C 150.1.234.0 is directly connected, Serial0.234
C 150.1.3.0 is directly connected, Loopback0
R3#
00:28:14: ISIS-Adj: Encapsulation failed for L1 LAN IIH on Serial0.234
==================================================================
(3A) ISIS ON MAIN INTERFACES, WITH MAP STATMENTS: (WORKS)
hostname R2
!
interface Serial0
encapsulation frame-relay
ip address 150.1.234.2 255.255.255.0
ip router isis
frame-relay map clns 204 broadcast
frame-relay map clns 203 broadcast
frame-relay map ip 150.1.234.2 203 broadcast
frame-relay map ip 150.1.234.3 203 broadcast
frame-relay map ip 150.1.234.4 204 broadcast
no frame-relay inverse-arp
hostname R3
!
interface Serial0
no ip address
encapsulation frame-relay
ip address 150.1.234.3 255.255.255.0
ip router isis
frame-relay map clns 304 broadcast
frame-relay map clns 302 broadcast
frame-relay map ip 150.1.234.2 302 broadcast
frame-relay map ip 150.1.234.3 302 broadcast
frame-relay map ip 150.1.234.4 304 broadcast
no frame-relay inverse-arp
hostname R4
!
interface Serial0
no ip address
encapsulation frame-relay
ip address 150.1.234.4 255.255.255.0
ip router isis
frame-relay map clns 402 broadcast
frame-relay map clns 403 broadcast
frame-relay map ip 150.1.234.2 403 broadcast
frame-relay map ip 150.1.234.3 403 broadcast
frame-relay map ip 150.1.234.4 402 broadcast
no frame-relay inverse-arp
RESULTS (R2, R3, R4 WORK FINE):
R3#sh clns nei
R2 Se0 DLCI 302 Up 24 L1 IS-IS
R4 Se0 DLCI 304 Up 7 L1 IS-IS
R3#sh ip route
C 150.1.234.0 is directly connected, Serial0
i L1 150.1.4.0 [115/20] via 150.1.234.4, Serial0
C 150.1.3.0 is directly connected, Loopback0
i L1 150.1.2.0 [115/20] via 150.1.234.2, Serial0
===============================================================
(3A) ISIS ON MAIN INTERFACES, WITHOUT MAP STATMENTS: (ENCAP FAILS)
interface Serial0
ip address 150.1.234.3 255.255.255.0
ip router isis
encapsulation frame-relay
frame-relay map ip 150.1.234.2 302 broadcast
frame-relay map ip 150.1.234.3 302 broadcast
frame-relay map ip 150.1.234.4 304 broadcast
R3#debug isis adj
00:00:43: ISIS-Adj: Encapsulation failed for L1 LAN IIH on Serial0
===================================================================
(4) COMBINATION MAIN INT (R2,R4) AND MULTIPOINT (R3): (FAILS)
hostname R2
!
interface Serial0
ip address 150.1.234.2 255.255.255.0
ip router isis
encapsulation frame-relay
frame-relay map clns 204 broadcast
frame-relay map clns 203 broadcast
frame-relay map ip 150.1.234.2 203 broadcast
frame-relay map ip 150.1.234.3 203 broadcast
frame-relay map ip 150.1.234.4 204 broadcast
no frame-relay inverse-arp
hostname R3
!
interface Serial0
no ip address
encapsulation frame-relay
!
interface Serial0.234 multipoint
ip address 150.1.234.2 255.255.255.0
ip router isis
frame-relay map clns 203 broadcast
frame-relay map clns 204 broadcast
frame-relay map ip 150.1.234.2 203 broadcast
frame-relay map ip 150.1.234.3 203 broadcast
frame-relay map ip 150.1.234.4 204 broadcast
no frame-relay inverse-arp
hostname R4
!
interface Serial0
ip address 150.1.234.4 255.255.255.0
ip router isis
encapsulation frame-relay
frame-relay map clns 402 broadcast
frame-relay map clns 403 broadcast
frame-relay map ip 150.1.234.2 403 broadcast
frame-relay map ip 150.1.234.3 403 broadcast
frame-relay map ip 150.1.234.4 402 broadcast
no frame-relay inverse-arp
RESULTS -- R2/R4 ARE OKAY, BUT NOT R3:
R2#sh clns nei
R4 Se0 DLCI 204 Up 7 L1 IS-IS
R2#sh ip route
150.1.0.0/24 is subnetted, 3 subnets
C 150.1.234.0 is directly connected, Serial0
i L1 150.1.4.0 [115/20] via 150.1.234.4, Serial0
C 150.1.2.0 is directly connected, Loopback0
=================================================================
(5) POINT-TO-POINT:
hostname R2
!
interface Serial0
no ip address
encapsulation frame-relay
!
interface Serial0.23 point-to-point
ip address 150.1.23.2 255.255.255.0
ip router isis
frame-relay interface-dlci 203
!
interface Serial0.24 point-to-point
ip address 150.1.24.2 255.255.255.0
ip router isis
frame-relay interface-dlci 204
hostname R3
!
interface Serial0
no ip address
encapsulation frame-relay
!
interface Serial0.23 point-to-point
ip address 150.1.23.3 255.255.255.0
ip router isis
frame-relay interface-dlci 302
!
interface Serial0.34 point-to-point
ip address 150.1.34.3 255.255.255.0
ip router isis
frame-relay interface-dlci 304
hostname R4
!
interface Serial0
no ip address
encapsulation frame-relay
!
interface Serial0.24 point-to-point
ip address 150.1.24.4 255.255.255.0
ip router isis
frame-relay interface-dlci 402
!
interface Serial0.34 point-to-point
ip address 150.1.34.4 255.255.255.0
ip router isis
frame-relay interface-dlci 403
RESULTS: (all good)
R3#sh clns nei
R2 Se0.23 DLCI 302 Up 23 L1 IS-IS
R4 Se0.34 DLCI 304 Up 28 L1 IS-IS
R3#sh ip route
C 150.1.23.0 is directly connected, Serial0.23
i L1 150.1.24.0 [115/20] via 150.1.23.2, Serial0.23
[115/20] via 150.1.34.4, Serial0.34
i L1 150.1.4.0 [115/20] via 150.1.34.4, Serial0.34
C 150.1.3.0 is directly connected, Loopback0
i L1 150.1.2.0 [115/20] via 150.1.23.2, Serial0.23
C 150.1.34.0 is directly connected, Serial0.34
HTH, Kym
=============================================================
>From: "kasturi cisco" <kasturi_cisco@hotmail.com>
>Reply-To: "kasturi cisco" <kasturi_cisco@hotmail.com>
>To: clarson52@comcast.net, efisher@optonline.net, ccielab@groupstudy.com
>Subject: Re: Router ISIS
>Date: Sat, 26 Apr 2003 03:30:10 +0000
>
>Correct me if i am wrong, but i think the "frame-relay map clns" is only
>needed for multipoint type links and for p2p "Frame-rlay map clns" is NOT
>needed and only Fr map ip is needed.
>
>Good Luck,[IMAGE]
>Kasturi.
This archive was generated by hypermail 2.1.4 : Thu May 01 2003 - 13:36:07 GMT-3