Can anyone help me to debug this configuration ?

From: C.Sammarcellino@sirtisistemi.it
Date: Sun Apr 20 2003 - 23:31:35 GMT-3


Can anyone help me to debug this configuration ?

Why i can't ping from r4 and r5 trought MPLS ?

Tanls

Ciro

R1#
R1#
R1#sh run
Building configuration...

Current configuration : 2934 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
boot system flash c3725-jk9o3s-mz.122-15.T.bin
logging queue-limit 100
!
memory-size iomem 15
ip subnet-zero
!
!
no ip domain lookup
!
ip vrf Ipexpert
 rd 100:1
 route-target export 100:1
 route-target export 100:4
 route-target import 100:1
 route-target import 100:4
!
ip cef
ip audit notify log
ip audit po max-events 100
mpls ldp logging neighbor-changes
no tag-switching ip propagate-ttl
!
!

interface Loopback0
 ip address 192.168.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip vrf forwarding Ipexpert
 ip address 150.50.200.1 255.255.255.0
 no ip split-horizon
 duplex auto
 speed auto
!

router rip
 version 2
 !
 address-family ipv4 vrf Ipexpert
 version 2
 network 150.50.0.0
 no auto-summary
 exit-address-family
!
router bgp 8888
 no synchronization
 bgp log-neighbor-changes
 neighbor 192.168.2.2 remote-as 8888
 neighbor 192.168.2.2 update-source Loopback0
 neighbor 192.168.4.4 remote-as 8888
 neighbor 192.168.4.4 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
 neighbor 192.168.4.4 activate
 neighbor 192.168.4.4 send-community extended
 no auto-summary
 exit-address-family
 !
 address-family ipv4 vrf Ipexpert
 redistribute connected route-map conet2mpbgp
 redistribute rip
 neighbor 192.168.4.4 remote-as 8888
 neighbor 192.168.4.4 activate
 no auto-summary
 no synchronization
 exit-address-family
!

R1#
R1#
R1#sh bg vpn all
         ^
% Invalid input detected at '^' marker.

R1#sh bg v
R1#sh ip bg
R1#sh ip bgp v
R1#sh ip bgp vpnv4 all
BGP table version is 7, local router ID is 192.168.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 100:1 (default for vrf Ipexpert)
*>i192.168.170.0 192.168.4.4 0 100 0 ?
*>i192.168.171.0 192.168.4.4 0 100 0 ?
*> 193.193.193.0 150.50.200.2 1 32768 ?
Route Distinguisher: 100:4
*>i192.168.170.0 192.168.4.4 0 100 0 ?
*>i192.168.171.0 192.168.4.4 0 100 0 ?
R1#
R1#
R1#
R1#sh ip rou
R1#sh ip route v
R1#sh ip route vrf Ipexpert

Routing Table: Ipexpert
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

R 193.193.193.0/24 [120/1] via 150.50.200.2, 00:00:02, FastEthernet0/0
B 192.168.170.0/24 [200/0] via 192.168.4.4, 00:18:47
B 192.168.171.0/24 [200/0] via 192.168.4.4, 00:18:47
     150.50.0.0/24 is subnetted, 1 subnets
C 150.50.200.0 is directly connected, FastEthernet0/0
R1#
R1#
R1#
R1#ping vrf Ipexpert 192.168.170.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.170.4, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R1#
R1#
R1#
R1#

R4#
R4#sh run
!
!
ip vrf ccie
 rd 100:4
 route-target export 100:4
 route-target export 100:1
 route-target import 100:4
 route-target import 100:1
ip cef
!
interface Loopback0
 ip address 192.168.4.4 255.255.255.255
!
interface Loopback170
 ip vrf forwarding ccie
 ip address 192.168.170.4 255.255.255.0
!
interface Loopback171
 ip vrf forwarding ccie
 ip address 192.168.171.4 255.255.255.0
!

!
router bgp 8888
 no synchronization
 bgp log-neighbor-changes
 neighbor 192.168.1.1 remote-as 8888
 neighbor 192.168.1.1 update-source Loopback0
 neighbor 192.168.2.2 remote-as 8888
 neighbor 192.168.2.2 update-source Loopback0
 no auto-summary
 !
 address-family ipv4 vrf ccie
 redistribute connected route-map conet2mpbgp
 neighbor 192.168.1.1 remote-as 8888
 neighbor 192.168.1.1 activate
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 192.168.1.1 activate
 neighbor 192.168.1.1 send-community extended
 no auto-summary
 exit-address-family
!

R4#
R4#
R4#sh ip bg
R4#sh ip bgp v
R4#sh ip bgp vpnv4 ?
  all Display information about all VPNv4 NLRIs
  rd Display information for a route distinguisher
  vrf Display information for a VPN Routing/Forwarding instance

R4#sh ip bgp vpnv4 all
BGP table version is 7, local router ID is 192.168.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 100:1
*>i193.193.193.0 192.168.1.1 1 100 0 ?
Route Distinguisher: 100:4 (default for vrf ccie)
*> 192.168.170.0 0.0.0.0 0 32768 ?
*> 192.168.171.0 0.0.0.0 0 32768 ?
*>i193.193.193.0 192.168.1.1 1 100 0 ?
R4#
R4#
R4#

R4#ping vrf ccie 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R4#sh ip bgp vpnv4 all
BGP table version is 7, local router ID is 192.168.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 100:1
*>i193.193.193.0 192.168.1.1 1 100 0 ?
Route Distinguisher: 100:4 (default for vrf ccie)
*> 192.168.170.0 0.0.0.0 0 32768 ?
*> 192.168.171.0 0.0.0.0 0 32768 ?
*>i193.193.193.0 192.168.1.1 1 100 0 ?
R4#
R4#
R4#
R4#s ip route vrf ccie
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

B 193.193.193.0/24 [200/1] via 192.168.1.1, 00:17:15
C 192.168.170.0/24 is directly connected, Loopback170
C 192.168.171.0/24 is directly connected, Loopback171
R4#
R4#
R4#
R4#



This archive was generated by hypermail 2.1.4 : Thu May 01 2003 - 13:35:59 GMT-3