From: OhioHondo (ohiohondo@columbus.rr.com)
Date: Sat Apr 12 2003 - 13:41:08 GMT-3
RSVP has to be configured on all routers between the 2 communicating devices
that need RSVP.
device --- R1 --- R2 --- R3 --- R4 --- device
all of the routers above have to have RSVP defined
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
wsqccie@hotnail.com
Sent: Saturday, April 12, 2003 9:41 AM
To: cannonr; pita40; ccielab@groupstudy.com
Subject: Re: ip rsvp bandwidth
i still cannot undersatand how revp work. If it onle work in interface? and
if I want to reserver 20K between r1 and r2, just need to configure in r1 or
both?
below is from CCO and R1/E1 connect r2E1with dififirent value, pls check and
explain how they work.thanks al lot
Router A
On Router A, RSVP is enabled on interface Ethernet1 with 10 kbps to be
reserved for the data transmission. A weighted fair queue is reserved on
this interface to ensure RSVP QoS. (On Router A, RSVP is also enabled on
interface Hssi0 with 1 kbps reserved, but this bandwidth is used simply for
passing messages.)
!
version 12.0
service config
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname routerA
!
ip subnet-zero
no ip domain-lookup
ip multicast-routing
ip dvmrp route-limit 20000
!
!
interface Ethernet0
ip address 2.0.0.193 255.0.0.0
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
media-type 10BaseT
!
interface Ethernet1
ip address 11.1.1.2 255.0.0.0
no ip directed-broadcast
ip pim dense-mode
ip rsvp bandwidth 10 10
fair-queue 64 256 1000
media-type 10BaseT
!
interface Hssi0
ip address 12.1.1.1 255.0.0.0
no ip directed-broadcast
ip pim dense-mode
ip rsvp bandwidth 1 1
!
interface ATM0
no ip address
no ip directed-broadcast
shutdown
!
router ospf 100
network 11.0.0.0 0.255.255.255 area 10
network 12.0.0.0 0.255.255.255 area 10
!
ip classless
ip rsvp sender 225.1.1.1 12.1.2.1 UDP 7001 7000 12.1.2.1 Hs0 20 1
!
line con 0
exec-timeout 0 0
length 0
transport input none
line aux 0
line vty 0 4
login
!
end
Router B
On Router B, RSVP is enabled on interface Hssi0 with 20 kbps to be reserved
for the data transmission. A weighted fair queue is reserved on this
interface to ensure RSVP QoS. (On Router B, RSVP is also enabled on
interface Ethernet1 with 1 kbps reserved, but this bandwidth is used simply
for passing messages.)
!
version 12.0
service config
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname routerB
!
ip subnet-zero
no ip domain-lookup
ip multicast-routing
ip dvmrp route-limit 20000
clock calendar-valid
!
interface Ethernet0
ip address 2.0.0.194 255.0.0.0
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
media-type 10BaseT
!
interface Ethernet1
ip address 11.1.1.1 255.0.0.0
no ip directed-broadcast
ip pim dense-mode
ip rsvp bandwidth 1 1
media-type 10BaseT
!
interface Hssi0
ip address 10.1.1.2 255.0.0.0
no ip directed-broadcast
ip pim dense-mode
ip rsvp bandwidth 20 20
fair-queue 64 256 1000
hssi internal-clock
!
interface ATM0
no ip address
no ip directed-broadcast
shutdown
!
router ospf 100
network 10.0.0.0 0.255.255.255 area 10
network 11.0.0.0 0.255.255.255 area 10
!
ip classless
!
line con 0
exec-timeout 0 0
length 0
transport input none
line aux 0
line vty 0 4
login
!
end
Router C
On Router C, RSVP is enabled on interface Ethernet2 with 20 kbps to be
reserved for the data transmission. A weighted fair queue is reserved on
this interface to ensure RSVP QoS. (On Router C, RSVP is also enabled on
interface Hssi0 with 1 kbps reserved, but this bandwidth is used simply for
passing messages.)
!
version 12.0
service config
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname routerC
!
ip subnet-zero
no ip domain-lookup
ip multicast-routing
ip dvmrp route-limit 20000
!
interface Ethernet0
ip address 2.0.0.195 255.0.0.0
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
media-type 10BaseT
!
interface Ethernet1
no ip address
no ip directed-broadcast
shutdown
media-type 10BaseT
!
interface Ethernet2
ip address 9.1.1.2 255.0.0.0
no ip directed-broadcast
ip pim dense-mode
ip rsvp bandwidth 20 20
fair-queue 64 256 1000
media-type 10BaseT
!
interface Ethernet3
no ip address
no ip directed-broadcast
shutdown
media-type 10BaseT
!
interface Ethernet4
no ip address
no ip directed-broadcast
shutdown
media-type 10BaseT
!
interface Ethernet5
no ip address
no ip directed-broadcast
shutdown
media-type 10BaseT
!
interface Hssi0
ip address 10.1.1.1 255.0.0.0
no ip directed-broadcast
ip pim dense-mode
ip rsvp bandwidth 1 1
hssi internal-clock
!
interface ATM0
no ip address
no ip directed-broadcast
shutdown
!
router ospf 100
network 9.0.0.0 0.255.255.255 area 10
network 10.0.0.0 0.255.255.255 area 10
network 11.0.0.0 0.255.255.255 area 10
!
ip classless
ip rsvp reservation 225.1.1.1 12.1.2.1 UDP 7001 7000 9.1.2.1 Et2 FF LOAD 8 1
!
line con 0
exec-timeout 0 0
length 0
transport input none
line aux 0
line vty 0 4
login
!
end ----- Original Message -----
From: "cannonr" <cannonr@attbi.com>
To: "pita40" <pita40@hotmail.com>; <ccielab@groupstudy.com>
Sent: Saturday, April 12, 2003 8:04 PM
Subject: Re: ip rsvp bandwidth
> Yes, WFQ is required for RSVP to work properly.
> ----- Original Message -----
> From: "pita40" <pita40@hotmail.com>
> To: <ccielab@groupstudy.com>
> Sent: Friday, April 11, 2003 7:11 PM
> Subject: ip rsvp bandwidth
>
>
> > Hello,
> >
> > When you configure ip rsvp bandwidth on an interface is it necessary to
> also
> > configure say fair queue for QOS. In cco this is what they did.
> >
> > Help,
This archive was generated by hypermail 2.1.4 : Thu May 01 2003 - 13:35:51 GMT-3