From: cebuano (cebu2ccie@cox.net)
Date: Wed Apr 09 2003 - 00:49:57 GMT-3
Basically, the only way for BGP to install an aggregate is if at least
ONE more-specific route that is aggregated is in the routing table.
Check this.
// BGP Aggregate-address...
// Configs...
FrSwitch#s
!
interface Loopback100
ip address 100.0.0.1 255.255.0.0
!
interface Loopback101
ip address 100.1.0.1 255.255.0.0
!
interface Loopback102
ip address 100.2.0.1 255.255.0.0
!
interface Loopback103
ip address 100.3.0.1 255.255.0.0
!
router bgp 100
aggregate-address 100.0.0.0 255.252.0.0
neighbor 170.1.1.1 remote-as 34
no auto-summary
!
// notice that the aggregate and specific routes are not in the BGP
table...
FrSwitch#sh ip bgp
BGP table version is 11, local router ID is 200.7.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 110.110.110.0/24 0.0.0.0 0 32768 i
*> 111.111.111.0/24 0.0.0.0 0 32768 i
*> 112.112.112.0/24 0.0.0.0 0 32768 i
*> 113.113.113.0/24 0.0.0.0 0 32768 i
*> 195.1.1.0 170.1.1.1 0 34 256 1 i
*> 195.1.2.0 170.1.1.1 0 34 256 i
*> 195.1.3.0 170.1.1.1 0 34 i
*> 195.1.4.0 170.1.1.1 0 0 34 i
*> 195.1.5.0 170.1.1.1 0 34 256 i
*> 195.1.6.0 170.1.1.1 0 34 256 i
// we add AT LEAST ONE specific route and the aggregate shows up in the
BGP table...
FrSwitch(config)#router bgp 100
FrSwitch(config-router)#net 100.0.0.0 mask 255.255.0.0
FrSwitch(config-router)#^Z
FrSwitch#
FrSwitch#sh ip bgp
BGP table version is 13, local router ID is 200.7.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 100.0.0.0/16 0.0.0.0 0 32768 i
*> 100.0.0.0/14 0.0.0.0 32768 i
*> 110.110.110.0/24 0.0.0.0 0 32768 i
*> 111.111.111.0/24 0.0.0.0 0 32768 i
[snip]
// we remove the more-specific route...
FrSwitch(config)#int lo100
FrSwitch(config-if)#sh
FrSwitch(config-if)#^Z
FrSwitch#
00:53:35: %LINK-5-CHANGED: Interface Loopback100, changed state to
administratively down
// the entry disappears from the Routing Table...
FrSwitch#ir
Gateway of last resort is 0.0.0.0 to network 0.0.0.0
170.1.0.0/24 is subnetted, 1 subnets
C 170.1.1.0 is directly connected, Ethernet0
100.0.0.0/16 is subnetted, 3 subnets
C 100.1.0.0 is directly connected, Loopback101
C 100.2.0.0 is directly connected, Loopback102
C 100.3.0.0 is directly connected, Loopback103
// both the specific and aggregate entries disappear from the BGP
table...
FrSwitch#sh ip bgp
BGP table version is 15, local router ID is 200.7.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 110.110.110.0/24 0.0.0.0 0 32768 i
*> 111.111.111.0/24 0.0.0.0 0 32768 i
*> 112.112.112.0/24 0.0.0.0 0 32768 i
*> 113.113.113.0/24 0.0.0.0 0 32768 i
[snip]
// we bring the route back up...
FrSwitch(config)#int lo100
FrSwitch(config-if)#ns
FrSwitch(config-if)#^Z
FrSwitch#
00:54:50: %LINK-3-UPDOWN: Interface Loopback100, changed state to up
00:54:51: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback100,
changed state to up
FrSwitch#sh ip bgp
BGP table version is 17, local router ID is 200.7.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 100.0.0.0/16 0.0.0.0 0 32768 i
*> 100.0.0.0/14 0.0.0.0 32768 i
*> 110.110.110.0/24 0.0.0.0 0 32768 i
*> 111.111.111.0/24 0.0.0.0 0 32768 i
*> 112.112.112.0/24 0.0.0.0 0 32768 i
[snip]
// we observe what the neighbor router gets in the BGP update...
R4#sh ip bgp
BGP table version is 37, local router ID is 150.1.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 100.0.0.0/16 170.1.1.254 0 0 100 200 300
1000 400 500 i
*> 100.0.0.0/14 170.1.1.254 0 100 200 300
1000 400 500 i
*> 110.110.110.0/24 170.1.1.254 0 0 100 200 300
400 500 i
*> 111.111.111.0/24 170.1.1.254 0 0 100 200 300
400 500 i
*> 112.112.112.0/24 170.1.1.254 0 0 100 200 300
400 500 i
[snip]
// and we can ping Frameswitch's other loopback interfaces based on the
aggregate info...
R4#ping 100.1.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.1.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
HTH.
Elmer
-----Original Message-----
From: Jason Wydra [mailto:jasonwydra@yahoo.com]
Sent: Tuesday, April 08, 2003 1:11 PM
To: Yadav, Arvind K (CAP, GECIS); 'cebuano'; ccielab@groupstudy.com
Subject: RE: Can't get loopbacks into BGP table
So then it is safe to say that you cannot include a group of networks
for advertisement through BGP with a mask that covers them all. The mask
has to match for each network? If I had 125.15.12.0/24, 125.15.13.0/30
and 125.15.45.0/29 I could not do a "network 125.15.0.0 mask
255.255.63.0" like I could with other protocols?
"Yadav, Arvind K (CAP, GECIS)" <Arvind.Yadav@gecis.ge.com> wrote:
Because lo0,lo1,lo2 and l03 are on /24 boundry but in the network
statement you have defined mask 255.255.0.0 it's /16. That's why this
loopback are not there in BGP tables. If you
wanted to advertise any route via Network statement in BGP, route has to
be there in routing table with same Mask.
Change the mask in Network statement. It will work.
Cheers
-----Original Message-----
From: cebuano [mailto:cebu2ccie@cox.net]
Sent: Tuesday, April 08, 2003 10:57 AM
To: ccielab@groupstudy.com
Subject: Can't get loopbacks into BGP table
Hi group.
I can't figure out why the loopbacks that are configured in BGP with
"network" statement are not showing up in the LOCAL router's BGP table.
Actually, half are installed and the other half are not. And yes, I've
done what Bill Gates told me (reboot). Any comments are welcome. Thanks.
FrSwitch#s
!
interface Loopback100
ip address 100.0.0.1 255.255.255.0
!
interface Loopback101
ip address 100.1.0.1 255.255.255.0
!
interface Loopback102
ip address 100.2.0.1 255.255.255.0
!
interface Loopback103
ip address 100.3.0.1 255.255.255.0
!
interface Loopback110
ip address 110.110.110.110 255.255.255.0
!
interface Loopback111
ip address 111.111.111.111 255.255.255.0
!
interface Loopback112
ip address 112.112.112.112 255.255.255.0
!
interface Loopback113
ip address 113.113.113.113 255.255.255.0
!
interface Ethernet0
ip address 170.1.1.254 255.255.255.0
!
router bgp 100
bgp log-neighbor-changes
network 100.0.0.0 mask 255.255.0.0
network 100.1.0.0 mask 255.255.0.0
network 100.2.0.0 mask 255.255.0.0
network 100.3.0.0 mask 255.255.0.0
network 110.110.110.0 mask 255.255.255.0
network 111.111.111.0 mask 255.255.255.0
network 112.112.112.0 mask 255.255.255.0
network 113.113.113.0 mask 255.255.255.0
neighbor 170.1.1.1 remote-as 34
neighbor 170.1.1.1 route-map BGP out
!
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0
no ip http server
!
access-list 1 permit 100.0.0.0 0.254.0.0
route-map BGP permit 10
match ip address 1
set as-path prepend 200 300 1000 400 500
!
route-map BGP permit 20
set as-path prepend 200 300 400 500
!
FrSwitch#sh ip bgp
BGP table version is 15, local router ID is 200.7.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 110.110.110.0/24 0.0.0.0 0 32768 i
*> 111.111.111.0/24 0.0.0.0 0 32768 i
*> 112.112.112.0/24 0.0.0.0 0 32768 i
*> 113.113.113.0/24 0.0.0.0 0 32768 i
*> 195.1.1.0 170.1.1.1 0 34 256 1 i
*> 195.1.2.0 170.1.1.1 0 34 256 i
*> 195.1.3.0 170.1.1.1 0 34 i
*> 195.1.4.0 170.1.1.1 0 0 34 i
*> 195.1.5.0 170.1.1.1 0 34 256 i
*> 195.1.6.0 170.1.1.1 0 34 256 i
FrSwitch#ir
Gateway of last resort is 0.0.0.0 to network 0.0.0.0
170.1.0.0/24 is subnetted, 1 subnets
C 170.1.1.0 is directly connected, Ethernet0
100.0.0.0/24 is subnetted, 4 subnets
C 100.0.0.0 is directly connected, Loopback100
C 100.1.0.0 is directly connected, Loopback101
C 100.2.0.0 is directly connected, Loopback102
C 100.3.0.0 is directly connected, Loopback103
C 200.0.0.0/24 is directly connected, Loopback0
C 200.1.0.0/24 is directly connected, Loopback1
C 200.2.0.0/24 is directly connected, Loopback2
C 200.3.0.0/24 is directly connected, Loopback3
C 200.4.0.0/24 is directly connected, Loopback4
C 200.5.0.0/24 is directly connected, Loopback5
C 200.6.0.0/24 is directly connected, Loopback6
C 200.7.0.0/24 is directly connected, Loopback7
113.0.0.0/24 is subnetted, 1 subnets
C 113.113.113.0 is directly connected, Loopback113
112.0.0.0/24 is subnetted, 1 subnets
C 112.112.112.0 is directly connected, Loopback112
110.0.0.0/24 is subnetted, 1 subnets
C 110.110.110.0 is directly connected, Loopback110
B 195.1.6.0/24 [20/0] via 170.1.1.1, 00:25:33
111.0.0.0/24 is subnetted, 1 subnets
C 111.111.111.0 is directly connected, Loopback111
B 195.1.5.0/24 [20/0] via 170.1.1.1, 00:25:33
B 195.1.4.0/24 [20/0] via 170.1.1.1, 01:09:55
B 195.1.3.0/24 [20/0] via 170.1.1.1, 00:07:29
B 195.1.2.0/24 [20/0] via 170.1.1.1, 00:25:33
B 195.1.1.0/24 [20/0] via 170.1.1.1, 00:26:02
S* 0.0.0.0/0 is directly connected, Ethernet0
FrSwitch#sh ip int brief
Interface IP-Address OK? Method Status
Protocol
Ethernet0 170.1.1.254 YES NVRAM up
up
Loopback0 200.0.0.1 YES NVRAM up
up
Loopback1 200.1.0.1 YES NVRAM up
up
Loopback2 200.2.0.1 YES NVRAM up
up
Loopback3 200.3.0.1 YES NVRAM up
up
Loopback4 200.4.0.1 YES NVRAM up
up
Loopback5 200.5.0.1 YES NVRAM up
up
Loopback6 200.6.0.1 YES NVRAM up
up
Loopback7 200.7.0.1 YES NVRAM up
up
Loopback100 100.0.0.1 YES NVRAM up
up
Loopback101 100.1.0.1 YES NVRAM up
up
Loopback102 100.2.0.1 YES NVRAM up
up
Loopback103 100.3.0.1 YES NVRAM up
up
Loopback110 110.110.110.110 YES NVRAM up
up
Loopback111 111.111.111.111 YES NVRAM up
up
Loopback112 112.112.112.112 YES NVRAM up
up
Loopback113 113.113.113.113 YES NVRAM up
up
_____
Do you Yahoo!?
Yahoo! <http://us.rd.yahoo.com/finance/mailsig/*http:/tax.yahoo.com>
Tax Center - File online, calculators, forms, and more
This archive was generated by hypermail 2.1.4 : Thu May 01 2003 - 13:35:50 GMT-3