BGP inbound route map based on IP

From: Porta (pearllee@t-online.de)
Date: Tue Apr 01 2003 - 19:51:10 GMT-3


Hi, Group

Can BGP neighbor command with route maps be applied on the inbound when
matching based on an IP address ?

From BGP Case studies page 10:
http://www.cisco.com/warp/public/459/bgp-toc.pdf

Quote........Since route maps cannot be applied on the inbound when matching
based on an IP address, we have to use an outbound route map on RTC:......End

I followed the example provided,

RTA-(s1: 3.3.3.3)--------RIP-----(s1:3.3.3.4) RTB
(s0:2.2.2.2)
    |
    |
   EBGP
    |
(s0:2.2.2.3)
RTC
(lo0: 170.10.0.0)

To block the route 170.10.0.0 from RTC, I added an inbound route-map with
matching based on IP at RTA's s0
the route 170.10.0.0 was blocked and did not redistribute into RTB running
RIP

It seems to me that BGP neighbor command with route maps can be applied on the
inbound / outbound when matching based on an IP address
then the document provided at cisco web site is wrong?

Please confirm.

RTA's IOS: (C2500-JS-L), Version 12.2(12a)

Thanks.

Below is my config:

RTA#sh run
Building configuration...

Current configuration : 875 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RTA
!
!
ip subnet-zero
!
!
!
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 ip address 2.2.2.2 255.255.255.0
 clockrate 64000
!
interface Serial1
 ip address 3.3.3.3 255.255.255.0
 clockrate 148000
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!
router rip
 redistribute bgp 100
 passive-interface Serial0
 network 2.0.0.0
 network 3.0.0.0
 network 150.10.0.0
 default-metric 10
!
router bgp 100
 bgp log-neighbor-changes
 network 150.10.0.0
 neighbor 2.2.2.3 remote-as 300
 neighbor 2.2.2.3 route-map STOP2 in
!
ip classless
no ip http server
!
access-list 10 deny 170.10.0.0 0.0.255.255
access-list 10 permit any
route-map STOP2 permit 10
 match ip address 10
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

RTC#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RTC
!
!
ip subnet-zero
!
!
!
interface Loopback0
 ip address 170.10.1.1 255.255.0.0
 no ip directed-broadcast
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial0
 ip address 2.2.2.3 255.255.255.0
 no ip directed-broadcast
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0
 no ip address
 no ip directed-broadcast
 shutdown
!
router bgp 300
 network 170.10.0.0
 neighbor 2.2.2.2 remote-as 100
!
ip classless
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

RTB#sh ru
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RTB
!
!
ip subnet-zero
partition flash 2 8 8
!
!
!
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial1
 ip address 3.3.3.4 255.255.255.0
 no ip directed-broadcast
!
router rip
 network 3.0.0.0
!
ip classless
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

Porta Fan



This archive was generated by hypermail 2.1.4 : Thu May 01 2003 - 13:35:45 GMT-3