Re: Change the AS number ? *ugly example included*

From: Paul Lalonde (plalonde2@cogeco.ca)
Date: Tue Apr 01 2003 - 01:42:14 GMT-3


Hi guys,

Here's an ugly example of how I made Christian's scenario work. Christian,
does it meet the requirements?

Note that this example produces double AS paths (200 200) on R5 and R6, but
is functional.

The topology is the same as Christian's scenario:

(R2<-->R3)<-->(R5<-->R6)
(AS65000) (AS65001)
            (AS 200)

In order to get this to work, R2 needs to talk to R3 as an AS200 peer, not
an AS65000. R3 and R5 need to allow AS200 in (using the allowas-in neighbor
statement) because it is seen as coming from outside the local AS.

Let me know what you think.

Paul

[R2]

----
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname R2
!
!
clock timezone EST -5
ip subnet-zero
!
!
!
!
interface Loopback0
 ip address 200.0.0.2 255.255.255.255
!
interface Loopback2
 ip address 192.128.2.2 255.255.255.255
!
interface Ethernet0/0
 ip address 192.168.23.2 255.255.255.0
!
router rip
 version 2
 network 192.168.23.0
 network 200.0.0.0
 no auto-summary
!
router bgp 65000
 no synchronization
 bgp router-id 200.0.0.2
 bgp log-neighbor-changes
 bgp confederation identifier 200
 bgp confederation peers 65001
 network 192.128.2.2 mask 255.255.255.255
 neighbor 192.168.23.3 remote-as 200
 no auto-summary
!
ip classless
no ip http server
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
end

R2#sh ip bgp BGP table version is 6, local router ID is 200.0.0.2 Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, r RIB-failure Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path *> 192.128.2.2/32 0.0.0.0 0 32768 i R2#

-----------------------------

[R3] ----- ! version 12.2 service timestamps debug datetime msec service timestamps log datetime msec no service password-encryption service compress-config ! hostname R3 ! ! clock timezone EST -5 ip subnet-zero ! ! ! ! interface Loopback0 ip address 200.0.0.3 255.255.255.255 ! interface Ethernet0/0 ip address 192.168.23.3 255.255.255.0 ! interface Ethernet1/0 ip address 192.168.35.3 255.255.255.0 ! router rip version 2 network 192.168.23.0 network 192.168.35.0 network 200.0.0.0 no auto-summary ! router bgp 65000 no synchronization bgp router-id 200.0.0.3 bgp log-neighbor-changes bgp confederation identifier 200 bgp confederation peers 65001 neighbor 192.168.23.2 remote-as 200 neighbor 192.168.23.2 allowas-in neighbor 192.168.35.5 remote-as 200 no auto-summary ! ip classless no ip http server ! ! ! ! ! line con 0 exec-timeout 0 0 logging synchronous line aux 0 line vty 0 4 login ! end

R3#sh ip bgp BGP table version is 16, local router ID is 200.0.0.3 Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, r RIB-failure Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path *> 192.128.2.2/32 192.168.23.2 0 0 200 i R3#

-----------------------------------------------------------------------

[R5] ----- ! version 12.2 service timestamps debug datetime msec service timestamps log datetime msec no service password-encryption service compress-config ! hostname R5 ! ! clock timezone EST -5 ip subnet-zero ! ! ! ! interface Loopback0 ip address 200.0.0.5 255.255.255.255 ! interface Ethernet0/0 ip address 192.168.35.5 255.255.255.0 ! interface Ethernet1/0 ip address 192.168.56.5 255.255.255.0 ! router rip version 2 network 192.168.35.0 network 192.168.56.0 network 200.0.0.0 no auto-summary ! router bgp 65001 no synchronization bgp router-id 200.0.0.5 bgp log-neighbor-changes bgp confederation identifier 200 bgp confederation peers 65000 neighbor 192.168.35.3 remote-as 200 neighbor 192.168.35.3 allowas-in neighbor 192.168.56.6 remote-as 65001 no auto-summary ! ip classless no ip http server ! ! ! ! ! line con 0 exec-timeout 0 0 logging synchronous line aux 0 line vty 0 4 login ! end

R5#sh ip bgp BGP table version is 20, local router ID is 200.0.0.5 Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, r RIB-failure Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path *> 192.128.2.2/32 192.168.35.3 0 200 200 i R5#

-------------------------------------------------------------------------

[R6] -----

! version 12.2 service timestamps debug datetime msec service timestamps log datetime msec no service password-encryption service compress-config ! hostname R6 ! ! clock timezone EST -5 ip subnet-zero ! ! ! ! interface Loopback0 ip address 200.0.0.6 255.255.255.255 ! interface Ethernet0/0 ip address 192.168.56.6 255.255.255.0 ! router rip version 2 network 192.168.56.0 network 200.0.0.0 no auto-summary ! router bgp 65001 no synchronization bgp router-id 200.0.0.6 bgp log-neighbor-changes bgp confederation identifier 200 bgp confederation peers 65000 neighbor 192.168.56.5 remote-as 65001 no auto-summary ! ip classless no ip http server ! ! ! ! ! line con 0 exec-timeout 0 0 logging synchronous line aux 0 line vty 0 4 login ! end

R6#sh ip bgp BGP table version is 20, local router ID is 200.0.0.6 Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, r RIB-failure Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path *>i192.128.2.2/32 192.168.35.3 100 0 200 200 i R6#



This archive was generated by hypermail 2.1.4 : Thu May 01 2003 - 13:35:44 GMT-3