From: boby2kusa (boby2kusa@hotmail.com)
Date: Tue Mar 18 2003 - 14:23:44 GMT-3
EIGRP neighbor won't exchange routes unless they become adjacent. EIGRP
routers initiate and maintain adjacencies through the use of hello packets.
Hello packets have always been sent to multicast address 224.0.0.10.
Although you can configure the neighbor command under EIGRP, which one
expect would allow EIGRP to form an explicit adjacencyy based on unicast.
In current code, when the EIGRP is running on a NBMA media, the eigrp
multicast packets have to be mapped to broadcast DLCI. This increase the
traffic in NBMA interface, as all other multicast/broadcast traffic may also
be forwarded to that DLCI. Static neighbor can now be used to send only
unicast hello/query/update to the specific neighbor, hence, avoid extra
broadcast traffic on the already slow remote NBMA media.
With all that information, run a debug and see why with the neigh statement
is not forming and adjacency. Maybe the hellos are not gettting through the
F/R cloud but as the second paragraph states the neighbor statement to
conserve bandwidth over the NBMA link is an enhancement beginning 12.0T code
which menas it shoudl be present on 12.1 mainline as well.
r5#show ip eigrp neighbors
IP-EIGRP neighbors for process 2
H Address Interface Hold Uptime SRTT RTO Q Seq
Type
(sec) (ms) Cnt Num
2 10.1.6.3 Se0 161 00:01:16 20 200 0 13
1 10.1.5.4 Et1 13 01:56:44 34 204 0 17
0 10.1.4.2 Et0 13 02:12:11 28 200 0 18
r5#
Hold The current hold timer based on the hold timer we given for that
neighbor. Doing show ip eigrp neighbor a few times allows you to infer what
the holdtime is.
Q Cnt Counter of messages pending in our queue for the neighbor. These are
anything we send including hellos, updates, and queries. If we either have
trouble sending a packet or the neighbor hasn't ack'ed the packet yet, it's
counted in the queue until we know the neighbor got the packet. This should
always be zero in normal operation, although you may catch a couple pending
if the link is congested, especially on low bandwidth p2multi circuits. They
should drain out quickly though.
Seq Num Counter of total messages we have received from the neighbor.
Hellos, updates, everything. This should always be non-zero in normal
operation. You should also see a slow, periodic increment due to hellos and
the occasional update. Rapidly incrementing could be a sign of reconvergence
and/or general network instability.
----- Original Message -----
From: "Hunt Lee" <ciscoforme3@yahoo.com.au>
To: <ccielab@groupstudy.com>
Sent: Tuesday, March 18, 2003 5:24 AM
Subject: EIGRP mystery
> Hi Group,
>
> Does EIGRP has anything similar to OSPF / ISIS network types when
communicating over
> Frame-Relay?
>
> R2 --- FR Switch --- R13
>
> When do we need the "neighbor" command for EIGRP? Below is one example I
found:-
>
> On R2:
>
> r2#sh run
> Building configuration...
>
> Current configuration : 140 bytes
> !
> interface Serial0
> no ip address
> encapsulation frame-relay
> no fair-queue
> frame-relay traffic-shaping
> ip rsvp bandwidth 1158 1158
>
> interface Serial0.2 point-to-point
> ip address 150.200.16.2 255.255.255.240
> frame-relay interface-dlci 101
> ip rsvp bandwidth 10 10
>
> router eigrp 1
> redistribute ospf 1 route-map backtoEIGRP
> network 150.200.0.0
> default-metric 10000 1000 255 1 1000
> no auto-summary
> no eigrp log-neighbor-changes
>
> And on R13:
>
> interface Serial0
> ip address 150.200.16.1 255.255.240.0
> encapsulation frame-relay
> frame-relay map ip 150.200.16.2 110 broadcast
>
> router eigrp 1
> network 150.150.0.0
> network 150.200.0.0
> distribute-list 1 in Tunnel0
> no auto-summary
>
>
> And even though that's the config for the e.g., I couldn't get EIGRP to
establish
> adjacency until I added the "neighbor" command pointing to each other.
Hence, my
> question is, did I missed something simple on the config, or do I need
"neighbor"
> statement whenever I configured EIGRP over FR?
>
> Regards,
> Hunt
>
> http://mobile.yahoo.com.au - Yahoo! Mobile
> - Check & compose your email via SMS on your Telstra or Vodafone mobile.
This archive was generated by hypermail 2.1.4 : Sat Apr 05 2003 - 08:51:41 GMT-3