Re: ISDN simulator with ppp authentication

From: kym blair (kymblair@hotmail.com)
Date: Wed Mar 05 2003 - 17:17:48 GMT-3


Luke,

I have a vconsole simulator and do ppp auth (and all other commands) on the
lines. It works when I have it set to basic-ni1, basic-net3, etc. By the
way, to upgrade software for basic-net3, you can download for free; easy to
install.

Here is a working Dialer Profiles config:

hostname R2
username R5 password 0 CCIE
isdn switch-type basic-ni
!
interface BRI0/0
no ip address
encapsulation ppp
isdn switch-type basic-ni
dialer pool-member 2
isdn spid1 0835866101 8358661
isdn spid2 0835866301 8358663
no shut
!
interface dialer 0
ip address 10.10.10.2 255.255.255.0
encapsulation ppp
dialer pool 2
dialer string 8358662
dialer load-threshold 3 either
dialer-group 1
ppp authentication chap
ppp multilink
no shut
!
dialer-list 1 protocol ip permit

hostname R5
username R2 password 0 CCIE
isdn switch-type basic-ni
!
interface BRI0
no ip address
encapsulation ppp
isdn switch-type basic-ni
isdn spid1 0835866201 8358662
isdn spid2 0835866401 8358664
dialer pool-member 5
no shut
!
interface Dialer 0
ip address 10.10.10.5 255.255.255.0
encapsulation ppp
dialer pool 5
dialer string 8358661
dialer load-threshold 3 either
dialer-group 1
ppp authentication chap
ppp multilink
no shut
!
dialer-list 1 protocol ip permit

HERE IS A WORKING LEGACY CONFIG:

hostname R1
username R2 password 0 cisco
isdn switch-type basic-ni
!
interface BRI0
ip address 172.1.35.1 255.255.255.0
encapsulation ppp
ip ospf cost 2000
dialer idle-timeout 40
dialer map ip 172.1.35.2 name R2 broadcast
dialer load-threshold 64 either
dialer-group 1
isdn switch-type basic-ni
isdn spid1 0835866201 8358662
isdn spid2 0835866401 8358664
no peer neighbor-route
no cdp enable
ppp authentication chap
ppp multilink
!
dialer-list 1 protocol ip permit

hostname R2
username R1 password 0 cisco
isdn switch-type basic-ni
!
interface BRI0/0
ip address 172.1.35.2 255.255.255.0
encapsulation ppp
ip ospf cost 2000
ip ospf demand-circuit
dialer idle-timeout 40
dialer map ip 172.1.35.1 name R1 broadcast 8358662
dialer load-threshold 64 either
dialer-group 1
isdn switch-type basic-ni
isdn spid1 0835866101 83586621
isdn spid2 0835866301 83586623
no peer neighbor-route
no cdp enable
ppp multilink
!
dialer-list 1 protocol ip permit

Good luck with it. Kym

>From: Tim Fletcher <tim@fletchmail.net>
>Reply-To: Tim Fletcher <tim@fletchmail.net>
>To: LUKE YI <UGGIE@hotmail.com>, ccielab@groupstudy.com
>Subject: Re: ISDN simulator with ppp authentication
>Date: Wed, 05 Mar 2003 11:09:29 -0500
>
>PPP is negotiated between the 2 end points, and is not a function of the
>ISDN switch or simulator.
>
>-Tim Fletcher
>
>At 05:27 PM 3/5/2003 +1100, LUKE YI wrote:
>>Hi, all
>>I purchased two ISDN sims from vconsole. However it doesn't seem to
>>support ppp authentication. I emailed vconsole but no response was
>>received. Can anyone verify this whether vconsole isdn sim support ppp
>>authentication?
>>
>>Any other recommendation for the right isdn sim for our lab?
>>
>>Luke



This archive was generated by hypermail 2.1.4 : Sat Apr 05 2003 - 08:51:36 GMT-3