From: syv (syv@911networks.com)
Date: Sun Jan 05 2003 - 19:05:50 GMT-3
On Saturday, January 04, 2003, Mahmud, Yasser wrote:
-----Original Message-----
MY> Hi,
MY> Your solution 2 won't work as the ospf network type is NBMA and so OSPF
MY> assumes it can't send broadcasts.
No it does work without setting the ip ospf network on the
spoke or the hub:
Here is the complete listings and the sho ip ospf interface
and neighbors. It's a bit long but proof positive that it
works.
Hub
=-=-=-=
c1751#s
Building configuration...
Current configuration : 1673 bytes
!
! Last configuration change at 13:43:02 PST Sun Jan 5 2003
! NVRAM config last updated at 14:46:01 PST Sat Jan 4 2003
!
version 12.2
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
no service password-encryption
!
hostname c1751
!
!
clock timezone PST -8
clock summer-time PDT recurring
ip subnet-zero
!
!
ip tcp synwait-time 5
no ip domain lookup
!
!
!
!
!
interface FastEthernet0/0
description To the backbone top switch 2901
ip address 192.168.1.202 255.255.255.0
speed auto
!
interface Serial0/0
no ip address
shutdown
!
interface Serial0/1
no ip address
encapsulation frame-relay
frame-relay lmi-type ansi
!
interface Serial0/1.10 multipoint
ip address 172.16.2.2 255.255.255.0
ip ospf priority 255
frame-relay map ip 172.16.2.5 205
frame-relay map ip 172.16.2.7 207
no frame-relay inverse-arp
!
interface Serial1/0
ip address 192.168.10.2 255.255.255.252
!
router ospf 10
router-id 10.254.2.2
log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 1
neighbor 172.16.2.5
neighbor 172.16.2.7
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
no ip http server
!
!
!
alias exec b sh ip bgp
alias exec c conf t
alias exec co clea ip ospf proc
alias exec cr clea ip rout *
alias exec i sho ip interf brief
alias exec o sho ip ospf
alias exec pr sh ip prot
alias exec r show ip rout
alias exec s show run
alias exec sb show run | begin
alias exec w write mem
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
line vty 0 4
exec-timeout 0 0
password 123456
logging synchronous
login
!
no scheduler allocate
sntp server 136.159.2.1
end
c1751#sh ip ospf interface
Serial0/1.10 is up, line protocol is up
Internet Address 172.16.2.2/24, Area 1
Process ID 10, Router ID 10.254.2.2, Network Type NON_BROADCAST, Cost: 64
Transmit Delay is 1 sec, State DR, Priority 255
Designated Router (ID) 10.254.2.2, Interface address 172.16.2.2
No backup designated router on this network
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
Hello due in 00:00:18
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 2, maximum is 2
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 2, Adjacent neighbor count is 2
Adjacent with neighbor 10.5.5.5
Adjacent with neighbor 10.7.7.7
Suppress hello for 0 neighbor(s)
c1751#
c1751#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
10.5.5.5 0 FULL/DROTHER 00:01:52 172.16.2.5 Serial0/1.10
10.7.7.7 0 FULL/DROTHER 00:01:53 172.16.2.7 Serial0/1.10
c1751#
Spoke 1
=-=-=-=-=
c1602r#sh run
Building configuration...
Current configuration : 1523 bytes
!
! Last configuration change at 15:45:25 PST Sat Jan 4 2003
! NVRAM config last updated at 15:15:48 PST Sat Jan 4 2003
!
version 12.1
no service single-slot-reload-enable
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
no service password-encryption
!
hostname c1602r
!
boot system tftp c1600-sy-mz.121-17-IP+.bin 192.168.1.100
!
!
!
!
!
clock timezone PST -8
clock summer-time PDT recurring
ip subnet-zero
!
!
!
!
interface Loopback10
ip address 7.7.7.7 255.255.255.0
!
interface Loopback11
ip address 7.77.7.7 255.255.255.0
!
interface Ethernet0
ip address 192.168.1.207 255.255.255.0
!
interface Serial0
ip address 172.16.2.7 255.255.255.0
encapsulation frame-relay
ip ospf priority 0
no fair-queue
service-module 56k clock source line
service-module 56k network-type dds
frame-relay map ip 172.16.2.2 702
frame-relay map ip 172.16.5.5 702
no frame-relay inverse-arp
!
router ospf 10
router-id 10.7.7.7
log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 1
!
no ip classless
no ip http server
!
alias exec b sh ip bgp
alias exec c conf t
alias exec co cle ip ospf proc
alias exec cr cle ip rout *
alias exec i sh ip int brief
alias exec pr sh ip protocols
alias exec o sh ip ospf
alias exec r sh ip rout
alias exec s sh run
alias exec sb sh run | begin
alias exec w wr mem
!
line con 0
exec-timeout 0 0
logging synchronous
line vty 0 4
exec-timeout 0 0
password 123456
logging synchronous
login
!
sntp server 136.159.2.1
end
c1602
c1602r#
c1602r#
c1602r#sho ip ospf interface
Serial0 is up, line protocol is up
Internet Address 172.16.2.7/24, Area 1
Process ID 10, Router ID 10.7.7.7, Network Type NON_BROADCAST, Cost: 64
Transmit Delay is 1 sec, State DROTHER, Priority 0
Designated Router (ID) 10.254.2.2, Interface address 172.16.2.2
No backup designated router on this network
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
Hello due in 00:00:13
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 10.254.2.2 (Designated Router)
Suppress hello for 0 neighbor(s)
c1602r#
c1602r#
c1602r#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
10.254.2.2 255 FULL/DR 00:01:52 172.16.2.2 Serial0
c1602r#
c1602r#
c1602r#
Spoke 2
=-=-=-=-
c2505#sh run
Building configuration...
Current configuration : 1778 bytes
!
! Last configuration change at 13:54:25 PST Sun Jan 5 2003
!
version 12.1
no service single-slot-reload-enable
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
no service password-encryption
!
hostname c2505
!
!
!
!
!
!
clock timezone PST -8
clock summer-time PDT recurring
ip subnet-zero
ip tcp synwait-time 5
no ip domain-lookup
!
!
!
!
hub ether 0 1
link-test
auto-polarity
!
hub ether 0 2
link-test
auto-polarity
!
hub ether 0 3
link-test
auto-polarity
!
hub ether 0 4
link-test
auto-polarity
!
hub ether 0 5
link-test
auto-polarity
!
hub ether 0 6
link-test
auto-polarity
!
hub ether 0 7
link-test
auto-polarity
!
hub ether 0 8
link-test
auto-polarity
!
interface Ethernet0
description To the backbone top switch 2901
ip address 192.168.1.205 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
ip address 172.16.2.5 255.255.255.0
encapsulation frame-relay
ip ospf priority 0
frame-relay map ip 172.16.2.2 502
frame-relay map ip 172.16.7.7 502
no frame-relay inverse-arp
!
router ospf 10
router-id 10.5.5.5
log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 1
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip http server
!
!
alias exec b sh ip bgp
alias exec c conf t
alias exec co clea ip ospf proc
alias exec cr clea ip rout *
alias exec i sho ip interf brief
alias exec o sho ip ospf
alias exec pr sh ip prot
alias exec r show ip rout
alias exec s show run
alias exec sb show run | begin
alias exec w write mem
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
line vty 0 4
exec-timeout 0 0
password 123456
logging synchronous
login
!
ntp clock-period 17180086
ntp server 136.159.2.1
end
c2505#sh ip ospf interface
Serial1 is up, line protocol is up
Internet Address 172.16.2.5/24, Area 1
Process ID 10, Router ID 10.5.5.5, Network Type NON_BROADCAST, Cost: 64
Transmit Delay is 1 sec, State DROTHER, Priority 0
Designated Router (ID) 10.254.2.2, Interface address 172.16.2.2
No backup designated router on this network
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
Hello due in 00:00:08
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 10.254.2.2 (Designated Router)
Suppress hello for 0 neighbor(s)
c2505#
c2505#
c2505#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
10.254.2.2 255 FULL/DR 00:01:48 172.16.2.2 Serial1
c2505#
MY> However Solution 2 will work if you change the ospf network type
MY> point-to-multipoint and specify the keyword broadcast on spokes as well.
MY> Out of sol. 1 and the ammended sol. 2 I would use use sol. 1 if extra frame
MY> maps are permitted on spokes .Reason being is that with sol. additional
MY> host routes are generated as well which need to be controlled.
MY> (The below might not be exact but I remember that a host route was keeping
MY> the ISDN link up)
MY> I saw an issue in Lab 17 ccbootcamp where the hub was redistributing OSPF
MY> into ISIS and the main network got redistributed as well as host routes for
MY> spoke so the ISIS router with ISDN backup did not have the host route for
MY> the hub itself and the other end of the ISDN link had OSPF learnt routes so
MY> was learning the hosts routes for hub and spokes and this additional host
MY> route for hub was keeping the ISDN link up.
MY> HTH
MY> Yasser
>> -----Original Message-----
>> From: syv [SMTP:syv@911networks.com]
>> Sent: Saturday, January 04, 2003 11:42 PM
>> To: ccielab@groupstudy.com
>> Subject: Frame-relay & OSPF: 1/2 dozen or 6
>>
>> I have the basic frame-relay / OPSF
>>
>> R1
>> / \
>> R2 R3
>>
>> R1: Hub, DR, point-to-multipoint subinterface
>> R2 & R3: Spokes, physical interfaces
>>
>> Which is the "better-way" configure for the frame-relay and
>> the DR?
>>
>> No broadcast with neighbors or Broadcast without neighbors
>>
>> Alternative 1:
>> =-=-=-=-=-=-=-
>> Hub:
>> interface Serial0/1
>> no ip address
>> encapsulation frame-relay
>> frame-relay lmi-type ansi
>> !
>> interface Serial0/1.10 multipoint
>> ip address 172.16.2.2 255.255.0.0
>> ip ospf priority 255
>> frame-relay map ip 172.16.5.5 205 ! no broadcasts, use neighbors
>> frame-relay map ip 172.16.7.7 207
>> no frame-relay inverse-arp
>> !
>> router ospf 10
>> router-id 10.254.2.2
>> network 172.16.0.0 0.0.255.255 area 1
>> neighbor 172.16.5.5
>> neighbor 172.16.7.7
>> !
>> !
>> Spoke:
>> !
>> interface Serial1
>> ip address 172.16.5.5 255.255.0.0
>> encapsulation frame-relay
>> ip ospf priority 0
>> frame-relay map ip 172.16.2.2 502
>> frame-relay map ip 172.16.7.7 502
>> no frame-relay inverse-arp
>> !
>> router ospf 10
>> router-id 10.5.5.5
>> log-adjacency-changes
>> network 172.16.0.0 0.0.255.255 area 1
>> !
>> =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
>> Alternative 2:
>> =-=-=-=-=-=-=-
>>
>> Hub:
>> interface Serial0/1
>> no ip address
>> encapsulation frame-relay
>> frame-relay lmi-type ansi
>> !
>> interface Serial0/1.10 multipoint
>> ip address 172.16.2.2 255.255.0.0
>> ip ospf priority 255
>> frame-relay map ip 172.16.5.5 205 broadcast
>> frame-relay map ip 172.16.7.7 207 broadcast
>> no frame-relay inverse-arp
>> !
>> router ospf 10
>> router-id 10.254.2.2
>> network 172.16.0.0 0.0.255.255 area 1
>> !
>>
>> Spokes stay the same
-- Thanks syv@911networks.com .
This archive was generated by hypermail 2.1.4 : Sat Feb 01 2003 - 07:33:43 GMT-3