Re: RE: ISDN Backup With Dialer Watch

From: kym blair (kymblair@hotmail.com)
Date: Sun Jan 05 2003 - 08:36:56 GMT-3


Evgeny,

Your main problem is that access-list 170 is denying OSPF, so the routers
can never form an adjacency. Demand-circuit will allow them to form an
adjacency after converging on the same topology, then mark the routes as
Do-Not-Age, and the line will go quiet. So remove access-list 170 and just
let dialer-list 1 permit any ip.

Also, add "no peer neighbor-route" to both dialer interfaces.

If you have ip addresses on BRI0 or Dialer0 that might be bringing up the
link, remove them and just use Dialer1 until you get it working.

Next, run "debug ppp auth" and "debug dialer packet" to get an idea of what
is bringing up the link, whether ppp auth is working, and what is taking the
link down. Other useful debugs might be "debug ip ospf hello", "debug ip
ospf monitor", and possibly "debug ip packet", though that will likely
generate too much information.

Are you doing redistribution on one of the routers? If so, don't let OPSF
accept a route from the other routing protocol for a "better" path to the
ISDN link:

router ospf 64
  redistribute igrp 100 metric-type 1 subnets route-map i2o

route-map i2o deny 10
  match ip address 12
route-map i2o permit 20

access-list 12 permit 1.1.1.0 0.0.0.255

If the isdn link is in ospf area 0, you may want to give the link a high
cost so it is never better than the primary link ("ip ospf cost 2000").

Unrelated: if you use multilink on one side, you should have it on the other
side; also, set both load-thresholds the same ("127" if you want the second
channel to come up at 50 percent load).

HTH, Kym

>From: "Carlos" <cchorao@xtra.co.nz>
>Reply-To: "Carlos" <cchorao@xtra.co.nz>
>To: "Tim Fletcher" <tim@fletchmail.net>, "stefan vogt"
><stefan-uwe_vogt@web.de>, <ccielab@groupstudy.com>
>Subject: Re: RE: ISDN Backup With Dialer Watch
>Date: Sun, 5 Jan 2003 21:55:35 +1300
>
>Agree. To ensure this is set the dialer idle-timeout to 0 on the non dialer
>watch side.
>
>
>Carlos
>Telecom New Zealand - Advanced Solutions Group : Network Design and
>Security
>----- Original Message -----
>From: "Tim Fletcher" <tim@fletchmail.net>
>To: "stefan vogt" <stefan-uwe_vogt@web.de>; <ccielab@groupstudy.com>
>Sent: Friday, January 03, 2003 10:37 AM
>Subject: Re: RE: ISDN Backup With Dialer Watch
>
>
> > Stefan,
> >
> > You're absolutely correct. The problem is that only one side is
>configured
> > for dialer watch. Since the other side is not configured for dialer
>watch
> > it will time out and disconnect. The dialer watch side will then dialup
>the
> > connection again, leading to the bouncing scenario described in the
> > original post.
> >
> > -Tim Fletcher
> >
> > At 09:51 PM 1/2/2003 +0100, stefan vogt wrote:
> > >Hi all,
> > >
> > >I would say that it's not normal with dialer watch that the expiration
>of
> > >the dialer idle-timeout timer brings down the circuit (if the primary
>is
> > >down). For my understanding with dialer watch every time the dialer
> > >idle-timeout timer expires it is checked whether the primary link is
>up.
> > >
> > >See at
> >
> >http://www.cisco.com/en/US/tech/tk801/tk133/technologies_tech_note09186a008
>009457d.shtml#dw_operation
> > >in section Dialer Watch Operation:
> > >---snip---
> > >Since the router uses the interesting traffic definition ONLY to check
> > >whether the primary link is active, consider making all IP traffic
> > >uninteresting using the command dialer-list number protocol ip deny.
>With
> > >this interesting traffic definition, the idle timeout will never be
>reset,
> > >and the router will check the status of the primary link at the
>specified
> > >interval.
> > >---snap---
> > >
> > >Other behavior I think is a bug.
> > >In the same document:
> > >---snip---
> > >Note: It is recommenced that you use Cisco IOS Software Release12.1(7)
>or
> > >higher, which includes fixes for IOS bugs that affect dialer watch.
> > >---snap---
> > >
> > >Best regards,
> > >Stefan
> > >
> > >"Brian T. Albert" <brian.albert@worldnet.att.net> schrieb am 02.01.03
> > >18:27:19:
> > > > The dialer idle-timeout will bring down the circuit, this is normal.
>You
> > > > have to crank it way up to prevent this from happening and let the
> > > > re-appearance of the route bring it down.
> > > >
> > > > Brian T. Albert
> > > > CCIE #9682
> > > > brian.albert@worldnet.att.net
> > > >
> > > > -----Original Message-----
> > > > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf
>Of
> > > > Evgeny Tantsura
> > > > Sent: Thursday, January 02, 2003 9:04 AM
> > > > To: ccielab@groupstudy.com
> > > > Subject: ISDN Backup With Dialer Watch
> > > >
> > > >
> > > > Hi,
> > > >
> > > > My ISDN interface with Dialer Watch on it
> > > > is going down every idle-timeout and then dialing again.
> > > >
> > > > interface Dialer1
> > > > ip address 1.1.1.2 255.255.255.0
> > > > encapsulation ppp
> > > > ip ospf demand-circuit
> > > > dialer pool 1
> > > > dialer idle-timeout 180
> > > > dialer string 0496406937
> > > > dialer load-threshold 127 either
> > > > dialer watch-group 1
> > > > dialer-group 1
> > > > pulse-time 0
> > > > no cdp enable
> > > > ppp authentication chap
> > > > ppp multilink
> > > > end
> > > >
> > > > access-list 170 deny ospf any any
> > > > access-list 170 permit ip any any
> > > > dialer watch-list 1 ip 192.168.5.1 255.255.255.255
> > > > dialer-list 1 protocol ip list 170
> > > > ----------------------------------------------------
> > > >
> > > > interface Dialer1
> > > > ip address 1.1.1.1 255.255.255.0
> > > > encapsulation ppp
> > > > dialer pool 1
> > > > dialer idle-timeout 180
> > > > dialer load-threshold 50 either
> > > > dialer-group 1
> > > > no cdp enable
> > > > ppp authentication chap
> > > >
> > > > dialer-list 1 protocol ip permit
> > > >
> > > >
> > > > According to CCO it should stay connected until the router gets the
> > > > route via primery interface.
> > > >
> > > > Any idea's ?
> > > >
> > > > With kind regards/ met vriendelijke groeten,
> > > > ------------------------------------------------
> > > > E. Tantsura
> > > > Network Developer
> > > > Essent Kabelcom N.V.
> > > > Dr.van Deenweg 84
> > > > 8025BN Zwolle, The Netherlands
> > > > Tel: +31-(0)38-850-7642
> > > > Fax: +31-(0)38-850-7410
> > > > Mob: +31-(0)6-290-80458
> > > > ------------------------------------------------
> > > > .
> > > > .
> >
> >___________________________________________________________________________
>___
> > >PREMIERE: Der Countdown laeuft! 3 Monate gratis + d-box 1 ab 1 Euro
> > >nur noch wenige Tage zu haben! http://premiere.web.de/?mc=999927&lp=2
> > >.
> > .
>.



This archive was generated by hypermail 2.1.4 : Sat Feb 01 2003 - 07:33:42 GMT-3