From: Lysyuk Andrew (lysyuk@ics.ua)
Date: Mon Dec 23 2002 - 13:09:24 GMT-3
Hello all!
I have faced with the problem of As-prepending in confederations. Are
there any restrictions on this issue?
My topology is following:
R2 --- R4
|
R5
...
I want to make 100.100.100.0/24 appeared on R2 as it traversed AS's 1000
and 1001. But it is not working. Can you help me where is my mistake?
Thanks in advance.
Andrew Lysyuk.
On R2:
interface Loopback0
ip address 150.50.2.2 255.255.255.255
router bgp 65522
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 8888
bgp confederation peers 65511 65533
neighbor 150.50.17.1 remote-as 65511
neighbor 150.50.100.4 remote-as 65522
neighbor 150.50.100.4 route-reflector-client
neighbor 150.50.100.5 remote-as 65522
neighbor 150.50.100.5 route-reflector-client
neighbor 150.50.100.6 remote-as 65522
no auto-summary
On R4:
interface Loopback0
ip address 150.50.4.4 255.255.255.255
!
interface Loopback1
ip address 100.100.100.1 255.255.255.0
!
interface Loopback2
ip address 100.100.101.1 255.255.255.0
!
router bgp 65522
no synchronization
bgp log-neighbor-changes
bgp confederation identifier 8888
bgp confederation peers 65511 65533
network 100.100.100.0 mask 255.255.255.0
network 100.100.101.0 mask 255.255.255.0
neighbor 150.50.100.2 remote-as 65522
neighbor 150.50.100.2 send-community
neighbor 150.50.100.2 route-map R2 out
no auto-summary
!
!
access-list 1 permit 100.100.100.0 0.0.0.255
access-list 2 permit 100.100.101.0 0.0.0.255
!
route-map R2 permit 10
match ip address 1
set as-path prepend 1000 1001
!
route-map R2 permit 20
match ip address 2
set community local-AS
But it is not working. Prefix 100.100.100.0/24 doesn't have
R2#show ip bgp
BGP table version is 15, local router ID is 150.50.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i100.100.100.0/24 150.50.100.4 0 100 0 i
*>i100.100.101.0/24 150.50.100.4 0 100 0 i
*> 172.16.0.0/24 150.50.17.1 0 100 0 (65511) 500
i
*> 172.16.1.0/24 150.50.17.1 0 100 0 (65511) 500
i
*> 172.16.2.0/24 150.50.17.1 0 100 0 (65511) 500
i
*> 172.16.3.0/24 150.50.17.1 0 100 0 (65511) 500
i
*> 192.168.0.0 150.50.17.1 0 100 0 (65511) i
*> 192.168.0.0/22 150.50.17.1 100 0 (65511) i
*> 192.168.1.0 150.50.17.1 0 100 0 (65511) i
*> 192.168.2.0 150.50.17.1 0 100 0 (65511) i
R2#show ip bgp 100.100.100.0
BGP routing table entry for 100.100.100.0/24, version 15
Paths: (1 available, best #1, table Default-IP-Routing-Table)
Flag: 0x208
Advertised to non peer-group peers:
150.50.17.1 150.50.100.5
Local, (Received from a RR-client)
150.50.100.4 (metric 64) from 150.50.100.4 (150.50.4.4)
Origin IGP, metric 0, localpref 100, valid, confed-internal, best
R2#
.
This archive was generated by hypermail 2.1.4 : Fri Jan 17 2003 - 17:21:51 GMT-3