RE: ISIS over GRE tunnel

From: Adam Crisp (adam.crisp@totalise.co.uk)
Date: Thu Dec 12 2002 - 07:09:42 GMT-3


Hi Jason,

I'm not sure why you can't get this two work, but these are my thoughts.

1. A CTUNNEL is used to tunnel IP over CLNS, not IP over IP, so this won't
work.
This isn't what you are trying to do but:
This functionality requires propers OSI routing and OSI-CLNS support.
ie. enable clns routing on every router, (global 'clns-routing' and
interface 'clns router isis'
you can then create tunnel endpoints.
IP is encapsulated with an OSI header and then de-encapsulated the other
end.
This CTUNNEL technology was created to help telco's with large OSI network
management networks.

2. Instead of using GRE. you may wish to try EON - (Experimental OSI
Network) encapsulation on your IP tunnel.
This mode of operation is especially good at encapsulating isis lsp's

3. If you're trying to form a tunnel between R6.R5, then these routers are
the only places where you need top create tunnel interfaces.
These routers are the ones that need to run isis.
Assuming that you have eigrp routeing between loopback on R5 & R6,
eg on router 5,
!router5
router isis
net 49.0001.5555.5555.5555.00
!
interface tunnel 1
ip router isis
ip address ???/32
tunnel source loop0
tunnel destination 'ip_address_of_router6'
tunnel mode eon
!!!!

and r6,
!router6
router isis
net 49.0001.6666.6666.6666.00
!
interface tunnel 1
ip router isis
ip address ???/32
tunnel source loop0
tunnel destination 'ip_address_of_router5'
tunnel mode eon
!!!!

GOOD LUCK!
Adam

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Jason Cash
Sent: 12 December 2002 08:01
To: ccielab@groupstudy.com
Subject: ISIS over GRE tunnel

Ok, for one reason or the other, I stumbled on this scenario and now I
am lookg for an answer. I am trying to establish ISIS neighbors across
a GRE tunnel or similar. I am trying to establish via this topology:

                  R5
                   |
                  | \
     R2 (S0) R3 (S1)
       \ \ /
        \ /
         \ /
         / \
   R6 / \
    \ / \
     R1 R4

I have R2 and Router configured for ISIS. Here is their NET:
R6 49.0001.6666.6666.6666.00
R5 49.0001.5555.5555.5555.00

In reading on the Cisco site, I read about creating a Ctunnel and what
not, but found that I could only bring up a tunnel interface.

R2/R3/R5/R6 are also all configured with eigrp to propagate the route to
each router. The following is the configs for 2 3 5 6.

R1
r1#sh run
hostname r1
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Loopback0
 ip address 153.1.101.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback1
 ip address 1.1.1.1 255.255.255.0
!
interface Loopback2
 ip address 1.2.2.2 255.255.255.0
!
interface Loopback3
 ip address 1.3.3.3 255.255.255.0
!
interface Loopback4
 ip address 1.4.4.4 255.255.255.0
!
interface CTunnel0
 no ip address
 ctunnel destination 15.3153.cc
!
interface Ethernet0
 ip address 186.1.1.1 255.255.255.0
 no cdp enable
!
interface Serial0
 ip address 153.1.200.1 255.255.255.0
 encapsulation frame-relay
 no fair-queue
!
interface Serial1
 ip address 153.1.61.6 255.255.255.0
 clockrate 500000
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!
router eigrp 1
 network 153.1.61.0 0.0.0.15
 network 153.1.200.0 0.0.0.255
 no auto-summary

R3
hostname r3
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Loopback0
 ip address 153.1.103.1 255.255.255.0
!
interface CTunnel0
 no ip address
!
interface Tunnel0
 no ip address
 tunnel source Serial1
 tunnel destination 153.1.61.6
!
interface Ethernet0
 ip address 153.1.43.33 255.255.255.128
 no ip route-cache
 no ip mroute-cache
 no keepalive
!
interface Serial0
 ip address 153.1.200.3 255.255.255.0
 encapsulation frame-relay
 no ip route-cache
 no ip mroute-cache
!
interface Serial1
 ip address 153.1.53.67 255.255.255.224
 no ip route-cache
 no ip mroute-cache
!
router eigrp 1
 network 153.1.53.64 0.0.0.31
 network 153.1.200.0 0.0.0.255
 no auto-summary

R5
hostname r5
!
!
ip subnet-zero
no ip domain-lookup
!
clns routing
!
!
!
interface Loopback0
 ip address 153.1.105.1 255.255.255.0
!
interface CTunnel0
 no ip address
 ctunnel destination 49.0001.6666.6666.6666.cc
!
interface Tunnel0
 no ip address
 tunnel source Serial1
 tunnel destination 153.1.53.67
!
interface Ethernet0
 ip address 162.1.1.1 255.255.255.0
 ip router isis
 no ip route-cache
 no ip mroute-cache
 no keepalive
 clns router isis
!
interface Serial0
 no ip address
 no ip route-cache
 no ip mroute-cache
 shutdown
!
interface Serial1
 ip address 153.1.53.68 255.255.255.224
 ip router isis
 no ip route-cache
 no ip mroute-cache
 clockrate 500000
 clns router isis
!
router eigrp 1
 network 10.0.0.0 0.0.0.255
 network 153.1.53.64 0.0.0.31
 auto-summary
!
router isis
 net 49.0001.5555.5555.5555.00

R6
hostname ts
!
!
username jason password 7 15180A1F0B24
username admin
ip subnet-zero
no ip domain-lookup
ip host r2 2002 10.0.0.1
ip host r1 2001 10.0.0.1
ip host r4 2004 10.0.0.1
ip host r3 2003 10.0.0.1
ip host r5 2005 10.0.0.1
ip host fs 2006 10.0.0.1
!
clns routing
!
!
!
interface Loopback0
 ip address 153.1.106.1 255.255.255.0
!
interface Loopback1
 no ip address
!
interface Loopback2
 no ip address
!
interface Loopback3
 no ip address
!
interface Loopback4
 no ip address
!
interface Loopback5
 no ip address
!
interface Loopback6
 no ip address
!
interface Loopback7
 no ip address
!
interface Loopback8
 ip address 10.0.0.1 255.255.255.0
!
interface CTunnel0
 no ip address
 ctunnel destination 15.3153.cc
!
interface Ethernet0
 ip address 153.1.66.6 255.255.255.0
 ip router isis
 no ip route-cache
 no ip mroute-cache
 no keepalive
 clns router isis
!
interface Serial0
 no ip address
 no ip route-cache
 no ip mroute-cache
 clns router isis
!
interface Serial1
 ip address 153.1.61.5 255.255.255.0
 no ip route-cache
 no ip mroute-cache
!
router eigrp 1
 network 10.0.0.0 0.0.0.255
 network 153.1.61.0 0.0.0.15
 auto-summary
!
router isis
 net 49.0001.6666.6666.6666.00
 is-type level-1
.
.



This archive was generated by hypermail 2.1.4 : Fri Jan 17 2003 - 17:21:44 GMT-3