Re: Eigrp routes is not in routing table

From: Tasuka Amano Hsu (tasuka@mac.com)
Date: Wed Dec 04 2002 - 00:43:28 GMT-3


Here is my configuration, and it can work and see the routing from
EIGRP!

!
hostname r9
!
interface Loopback0
  ip address 172.16.9.1 255.255.255.0
!
interface Loopback1
  ip address 10.10.1.1 255.255.255.0
!
interface Loopback2
  ip address 10.10.2.1 255.255.255.0
!
interface Loopback3
  ip address 10.10.3.1 255.255.255.0
!
interface Loopback4
  ip address 10.10.4.1 255.255.255.0
!
interface Loopback5
  ip address 10.20.1.1 255.255.255.0
!
interface Loopback6
  ip address 10.20.2.1 255.255.255.0
!
interface Loopback7
  ip address 10.20.4.1 255.255.255.0
!
interface Loopback8
  ip address 10.20.3.1 255.255.255.0
!
interface Tunnel0
  ip address 10.4.1.9 255.255.255.0
  tunnel source 172.16.9.1
  tunnel destination 172.16.13.1
!
interface TokenRing0
  ip address 172.16.80.254 255.255.255.128
  ring-speed 16
!
router eigrp 10
  passive-interface Loopback0
  passive-interface Loopback1
  passive-interface Loopback2
  passive-interface Loopback3
  passive-interface Loopback4
  passive-interface Loopback5
  passive-interface Loopback6
  passive-interface Loopback7
  passive-interface Loopback8
  passive-interface TokenRing0
  network 10.0.0.0
  no auto-summary
  no eigrp log-neighbor-changes
!

!
hostname r13
!
interface Loopback0
  ip address 172.16.13.1 255.255.255.0
!
interface Tunnel0
  ip address 10.4.1.13 255.255.255.0
  tunnel source 172.16.13.1
  tunnel destination 172.16.9.1
!
interface Ethernet0/0
  ip address 172.16.134.13 255.255.255.0
!

router eigrp 10
  passive-interface Ethernet0/0
  passive-interface Loopback0
  network 10.0.0.0
  no auto-summary
  no eigrp log-neighbor-changes
!

r9#sh ip eigrp topo
IP-EIGRP Topology Table for AS(10)/ID(172.16.9.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
        r - reply Status, s - sia Status

P 10.10.1.0/24, 1 successors, FD is 128256
          via Connected, Loopback1
P 10.10.2.0/24, 1 successors, FD is 128256
          via Connected, Loopback2
P 10.10.3.0/24, 1 successors, FD is 128256
          via Connected, Loopback3
P 10.10.4.0/24, 1 successors, FD is 128256
          via Connected, Loopback4
P 10.4.1.0/24, 1 successors, FD is 297244416
          via Connected, Tunnel0
P 10.20.4.0/24, 1 successors, FD is 128256
          via Connected, Loopback7
P 10.20.2.0/24, 1 successors, FD is 128256
          via Connected, Loopback6
P 10.20.3.0/24, 1 successors, FD is 128256
          via Connected, Loopback8
P 10.20.1.0/24, 1 successors, FD is 128256
          via Connected, Loopback5
r9#

r13#sh ip eigrp topo
IP-EIGRP Topology Table for AS(10)/ID(200.200.200.129)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
        r - reply Status, s - sia Status

P 10.10.1.0/24, 1 successors, FD is 297372416
          via 10.4.1.9 (297372416/128256), Tunnel0
P 10.10.2.0/24, 1 successors, FD is 297372416
          via 10.4.1.9 (297372416/128256), Tunnel0
P 10.10.3.0/24, 1 successors, FD is 297372416
          via 10.4.1.9 (297372416/128256), Tunnel0
P 10.10.4.0/24, 1 successors, FD is 297372416
          via 10.4.1.9 (297372416/128256), Tunnel0
P 10.4.1.0/24, 1 successors, FD is 297244416
          via Connected, Tunnel0
P 10.20.4.0/24, 1 successors, FD is 297372416
          via 10.4.1.9 (297372416/128256), Tunnel0
P 10.20.2.0/24, 1 successors, FD is 297372416
          via 10.4.1.9 (297372416/128256), Tunnel0
P 10.20.3.0/24, 1 successors, FD is 297372416
          via 10.4.1.9 (297372416/128256), Tunnel0
P 10.20.1.0/24, 1 successors, FD is 297372416
          via 10.4.1.9 (297372416/128256), Tunnel0
r13#

On Saturday, Nov 30, 2002, at 04:41 Asia/Taipei, Peng Zheng wrote:

> Yes. 192.168.4.0 in the routing table for R13 and the
> network 192.168.1.0 in the routing table for R3.
>
> I found the tunnel on R3 is up, line protocol is up.
> But the tunnel on R13 is up, but line protocol is
> down. I can not figure out what cause this result.
>
>
> --- mnmbaker@cfl.rr.com wrote:
>> My apologies, you are correct (I need to learn to
>> read better!). Is the network
>> 192.168.4.0 in the routing table for R13 and the
>> network 192.168.1.0 in the
>> routing table for R3?
>>
>> Mark
>>
>>> Sorry. But I can not find which one I violate.
>>> Because source and destination are interface IPs.
>> THe
>>> IPs on tunnel interfaces are unique.
>>>
>>> --- mnmbaker@cfl.rr.com wrote:
>>>> Your tunnel source and destinations need to
>> point to
>>>> actual IPs on the routers.
>>>> The "source" should be an interface IP on the
>> local
>>>> router, the "dest" should
>>>> be an interface IP on the remote router.
>>>> For R3, your source could be 10.3.1.3 and dest
>> could
>>>> be 10.2.1.13, then reverse
>>>> for source and dest on R13.
>>>> The IP address on the tunnel interface is part
>> of
>>>> the tunnel's network, which
>>>> needs to be unique from the other interfaces.
>>>>
>>>> Mark
>>>>
>>>>> (lo0)R3(e0)----(e0)R5(s0.1)----(s0)R13(e0)
>>>>>
>>>>> IP for E3:
>>>>> lo0: 10.3.1.3/24
>>>>> e0: 192.168.4.3/24
>>>>>
>>>>> IP for R13:
>>>>> s0: 192.168.1.13/28
>>>>> e0: 10.2.1.13/24
>>>>>
>>>>> There is a tunnel is configured between R3 and
>>>> R13.
>>>>>
>>>>> OSPF is runing between R3 and R5, R5 and R13
>>>>> EIGRP is running on tunnel and lo0 of R3 and
>> e0 of
>>>>> R13.
>>>>> But OSPF works well, but I cann not see tunnel
>> in
>>>>> routing table and R13 can not see lo0 of R3,
>> R3
>>>> can
>>>>> not see e0 of R13.
>>>>>
>>>>> Below is their configuation:
>>>>> ---------------------------------------------
>>>>> !
>>>>> version 12.1
>>>>> service timestamps debug uptime
>>>>> service timestamps log uptime
>>>>> no service password-encryption
>>>>> !
>>>>> hostname r3
>>>>> !
>>>>> enable secret 5 $1$MZ4K$RZXlOUh3c8a5HB.ImaVRl0
>>>>> !
>>>>> !
>>>>> !
>>>>> !
>>>>> !
>>>>> ip subnet-zero
>>>>> no ip domain-lookup
>>>>> !
>>>>> cns event-service server
>>>>> !
>>>>> !
>>>>> !
>>>>> !
>>>>> interface Loopback0
>>>>> ip address 129.3.3.3 255.255.255.0
>>>>> !
>>>>> interface Loopback1
>>>>> ip address 10.3.1.3 255.255.255.0
>>>>> !
>>>>> interface Tunnel0
>>>>> ip address 10.4.1.3 255.255.255.0
>>>>> tunnel source 192.168.4.3
>>>>> tunnel destination 192.168.1.13
>>>>> !
>>>>> interface Ethernet0
>>>>> ip address 192.168.4.3 255.255.255.0
>>>>> ip ospf message-digest-key 1 md5 cisco
>>>>> !
>>>>> interface Serial0
>>>>> no ip address
>>>>> shutdown
>>>>> no fair-queue
>>>>> !
>>>>> interface Serial1
>>>>> no ip address
>>>>> shutdown
>>>>> !
>>>>> router eigrp 10
>>>>> network 10.0.0.0
>>>>> no auto-summary
>>>>> no eigrp log-neighbor-changes
>>>>> !
>>>>> router ospf 1
>>>>> log-adjacency-changes
>>>>> area 3 authentication message-digest
>>>>> network 129.3.3.3 0.0.0.0 area 3
>>>>> network 192.168.4.3 0.0.0.0 area 3
>>>>> !
>>>>> ip classless
>>>>> no ip http server
>>>>> !
>>>>> !
>>>>> !
>>>>> line con 0
>>>>> exec-timeout 0 0
>>>>> transport input none
>>>>> line aux 0
>>>>> line vty 0 4
>>>>> login
>>>>> !
>>>>> end
>>>>>
>>>>> ________________________________________-
>>>>> version 12.1
>>>>> service timestamps debug uptime
>>>>> service timestamps log uptime
>>>>> no service password-encryption
>>>>> !
>>>>> hostname r13
>>>>> !
>>>>> enable secret 5 $1$5fx9$JtLJ8cAJWgL2V9o1/MvOQ1
>>>>> !
>>>>> !
>>>>> !
>>>>> !
>>>>> !
>>>>> ip subnet-zero
>>>>> no ip domain-lookup
>>>>> !
>>>>> cns event-service server
>>>>> !
>>>>> interface Loopback0
>>>>> ip address 129.13.13.13 255.255.255.0
>>>>> !
>>>>> interface Tunnel0
>>>>> ip address 10.4.1.13 255.255.255.0
>>>>> tunnel source 192.168.1.13
>>>>> tunnel destination 193.168.4.3
>>>>> !
>>>>> interface Ethernet0
>>>>> ip address 10.2.1.13 255.255.255.0
>>>>> no keepalive
>>>>> !
>>>>> interface Serial0
>>>>> ip address 192.168.1.13 255.255.255.240
>>>>> encapsulation frame-relay
>>>>> ip ospf message-digest-key 1 md5 cisco
>>>>> ip ospf network broadcast
>>>>> frame-relay map ip 192.168.1.5 301 broadcast
>>>>> no frame-relay inverse-arp
>>>>> !
>>>>> interface Serial1
>>>>> no ip address
>>>>> shutdown
>>>>> !
>>>>> router eigrp 10
>>>>> network 10.0.0.0
>>>>> no auto-summary
>>>>> no eigrp log-neighbor-changes
>>>>> !
>>>>> router ospf 1
>>>>> log-adjacency-changes
>>>>> area 0 authentication message-digest
>>>>> network 129.13.13.13 0.0.0.0 area 0
>>>>> network 192.168.1.13 0.0.0.0 area 0
>>>>> !
>>>>> ip classless
>>>>> no ip http server
>>>>> !
>>>>> !
>>>>> line con 0
>>>>> exec-timeout 0 0
>>>>> transport input none
>>>>> line aux 0
>>>>> line vty 0 4
>>>>> login
>>>>> !
>>>>> end
>>>>> _______________________________________
>>>>>
>>>>>
>>>>> Does anyone know why?
>>>>>
>>>>>
>>
> === message truncated ===
>
>
> __________________________________________________
> Do you Yahoo!?
> Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
> http://mailplus.yahoo.com



This archive was generated by hypermail 2.1.4 : Fri Jan 17 2003 - 17:21:38 GMT-3