RE: NAT problem

From: dunne.brian@adlittle.com
Date: Thu Nov 14 2002 - 04:09:07 GMT-3


Per some previous comments, You can use "LSNAT" - load sharing using IP
network address translation.

Different servers/same servers?: I assume you mean for example, 5 HTTP
servers with same content? If so, they will respond as if they were the
only functioning unit, as each 'session' will be initiated on each one (not
one session across 2 servers---which is another issue.....)
If content is different, see other comments....

For eg, from "little black book/Rudenko" pgs 390-393 (outside Serial on R1
would be a 'real' address, unlike the below example)

S1 S2 (serv1/2)
           --------------------ethernet--------R1 ---------------R2
(ISP--(priavate addresses in example--))

R1 has one outside address--

R1: (using all private addresses....)

interface E0
ip address 10.0.1.1 255.255.255.0
ip nat inside

interface Serial0
ip address 10.255.0.5 255.255.255.252
ip nat outside >>>>>>>>>>>>>1 outside address (should be legit,
local global address, but not in this example)

router EIGRP 10
network 10.0.0.0

ip nat pool Servers prefix-length 24 type rotary
address 10.0.1.111 10.0.1.111
adress 10.0.1.222 10.0.1.222 >>>>>>>2 server addresses

ip nat inside destination list 1 pool Servers

access-list 1 permit 10.0.1.100 >>>>>>>> "virtual address" used for
the outside.....

Regards--

If you telnet to the 2 servers, you'll get to server 1 on telnet 1, server
2 on telnet session 2 etc....

                                                                                                                                     
                      Joe A
                      <groupstudy@comc To: "'Alex Hsieh'" <ccie21@hotmail.com>
                      ast.net> cc: "'Paul Browning'" <pabrowni@cisco.com>, ccielab@groupstudy.com
                      Sent by: bcc:
                      nobody@groupstud Subject: RE: NAT problem
                      y.com
                                                                                                                                     
                                                                                                                                     
                      11/13/2002 10:29
                      PM
                      Please respond
                      to Joe A
                                                                                                                                     
                                                                                                                                     

Alex,

Since you have only one outside address, and since your servers run the
same app (http/80) with different content, I don't think you can use NAT
to solve your problem.

Here's a suggestion:

1. NAT the outside address to one of the 5 hosts.
2. Have all 5 hostnames resolve to the outside address in DNS.
3. At the host that receives the inbound traffic, have it look at the
hostname in the URL host header and redirect to a directory on itself or
one of the other 4 servers based on the name the user entered in the
URL.

Let me know if this works, because it sounds like it would, but I
haven't actually done it.

Joe

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Paul Browning
Sent: Wednesday, November 13, 2002 8:26 AM
To: 'Alex Hsieh'; ccielab@groupstudy.com
Subject: RE: NAT problem

Hi Alex,

do you want to overload the outside interface and have static port
translations for the servers (web, email etc)?

http://www.cisco.com/warp/public/794/827spat.html

For load balancing you will need to use route maps but not sure if this
will fit your scenario.

http://www.cisco.com/warp/public/105/nat_routemap.html

Hope it helps

Kind Regards

Paul

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Alex Hsieh
Sent: 13 November 2002 11:06
To: ccielab@groupstudy.com
Subject: NAT problem

hi group:

            Please help me on this.Currently we have 5 different web
servers connected to

a router with only one valid outside address.I know we could do NAT load
balancing

if servers are of same kind.But how about different servers?Is NAT still
possible?

Thanks a lot.

Alex



This archive was generated by hypermail 2.1.4 : Tue Dec 03 2002 - 07:22:59 GMT-3