Re: 3550 layer 3 etherchannel

From: MADMAN (dave@interprise.com)
Date: Wed Nov 13 2002 - 18:49:09 GMT-3


  Thanks for the clarification. Most etherchannels I have done have
been layer two. This looks similiar the the etherchannel setup on a
cat4000 with the L3 card.

  Dave

Brian McGahan wrote:
>
> Dave,
>
> No, I mean layer 3 ports. Observe the following:
>
> Cat3550(config)#interface range fa0/21 - 24
> Cat3550(config-if-range)#channel-group 1 mode on
> Creating a port-channel interface Port-channel1
> Cat3550(config-if-range)#int po1
> Cat3550(config-if)#no switchport
> Command rejected: Not a convertable port.
> Cat3550(config-if)#interface range fa0/21 - 24
> Cat3550(config-if-range)#no switchport
> Cat3550(config-if-range)#channel-group 1 mode on
> Cat3550(config-if-range)#int po1
> Cat3550(config-if)#no switchport
> Cat3550(config-if)#ip address 1.2.3.4 255.0.0.0
> Cat3550(config-if)#end
> Cat3550#
>
> The channel can not be a L3 interface while its member ports are
> L2 links. For the majority of configurations, members of the channel
> group inherit configuration done on the channel interface, but not in
> this case.
>
> The easiest way to do this is just to create the port-channel
> interface first, then define an interface-range macro for the physical
> ports and the logical port together:
>
> Cat3550(config)#int port-channel 10
> Cat3550(config-if)#exit
> Cat3550(config)#define interface-range FEC10 fa0/21 - 24, port 10
> Cat3550(config)#int range macro FEC10
> Cat3550(config-if-range)#no switchport
> Cat3550(config-if-range)#channel-group 10 mode on
> Cat3550(config-if-range)#end
>
> Cat3550#sh int status | in routed
> Fa0/21 connected routed a-full a-100 10/100BaseTX
> Fa0/22 connected routed a-full a-100 10/100BaseTX
> Fa0/23 connected routed a-full a-100 10/100BaseTX
> Fa0/24 connected routed a-full a-100 10/100BaseTX
> Po10 connected routed a-full a-100
>
> Cat3550#show etherchannel summary
> Flags: D - down P - in port-channel
> I - stand-alone s - suspended
> R - Layer3 S - Layer2
> u - unsuitable for bundling
> U - port-channel in use
> d - default port
> Group Port-channel Ports
> -----+------------+-----------------------------------------
> 10 Po10(RU) Fa0/21(P) Fa0/22(P) Fa0/23(P) Fa0/24(P)
>
> Now apply the L3 configuration to the port-channel interface:
>
> Cat3550#conf t
> Enter configuration commands, one per line. End with CNTL/Z.
> Cat3550(config)#int po10
> Cat3550(config-if)#ip ad 1.1.1.2 255.0.0.0
> Cat3550(config-if)#end
> Cat3550#sh ip route
> <snip>
> C 1.0.0.0/8 is directly connected, Port-channel10
> Cat3550#ping 1.1.1.1
>
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
> !!!!!
> Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
> Cat3550#
>
> Tada! 400Mbps p2p routed link.
>
> HTH
>
> Brian McGahan, CCIE #8593
> Director of Design and Implementation
> brian@cyscoexpert.com
>
> CyscoExpert Corporation
> Internetwork Consulting & Training
> Voice: 847.674.3392
> Fax: 847.674.2625
>
> > -----Original Message-----
> > From: MADMAN [mailto:dave@interprise.com]
> > Sent: Wednesday, November 13, 2002 2:51 PM
> > To: Brian McGahan
> > Cc: 'Weidong Xiao'; ccielab@groupstudy.com
> > Subject: Re: 3550 layer 3 etherchannel
> >
> >
> > Do you mean L2 ports first???
> >
> > dave
> >
> > Brian McGahan wrote:
> > >
> > > Weidong,
> > >
> > > All member ports must be L3 ports first. Try this:
> > >
> > > Interface range fa0/1 - 2, po1
> > > No switchport
> > >
> > > HTH
> > >
> > > Brian McGahan, CCIE #8593
> > > Director of Design and Implementation
> > > brian@cyscoexpert.com
> > >
> > > CyscoExpert Corporation
> > > Internetwork Consulting & Training
> > > Voice: 847.674.3392
> > > Fax: 847.674.2625
> > >
> > > > -----Original Message-----
> > > > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On
> Behalf
> > > Of
> > > > Weidong Xiao
> > > > Sent: Wednesday, November 13, 2002 1:53 PM
> > > > To: ccielab@groupstudy.com
> > > > Subject: 3550 layer 3 etherchannel
> > > >
> > > > Hi group,
> > > >
> > > > I was running EMI on a 3550 and 'ip routing' enabled, but couldn't
> set
> > > up
> > > > a layer 3 etherchannel.
> > > > Can somebody tell me what I missed?
> > > >
> > > > Thanks in advance,
> > > >
> > > > Weidong
> > > >
> > > > --------------------------------
> > > > interface FastEthernet0/1
> > > > description LINK-TO-RSW1
> > > > no ip address
> > > > duplex full
> > > > speed 100
> > > > channel-group 1 mode desirable non-silent
> > > > !
> > > > interface FastEthernet0/2
> > > > description LINK-TO-RSW1
> > > > no ip address
> > > > duplex full
> > > > speed 100
> > > > channel-group 1 mode desirable non-silent
> > > >
> > > > and then:
> > > >
> > > > SW3(config)#interface Port-channel1
> > > > SW3(config-if)#no sw
> > > > SW3(config-if)#no switchport
> > > > Command rejected: Not a convertable port. <-------WHY?
> > > > SW3(config-if)#ip address 2.2.2.2 255.0.0.0
> > > >
> > > > % IP addresses may not be configured on L2 links.
> >
> > --
> > David Madland
> > CCIE# 2016
> > Sr. Network Engineer
> > Qwest Communications
> > 612-664-3367
> >
> > "You don't make the poor richer by making the rich poorer." --Winston
> > Churchill

-- 
David Madland
CCIE# 2016
Sr. Network Engineer
Qwest Communications
612-664-3367

"You don't make the poor richer by making the rich poorer." --Winston Churchill



This archive was generated by hypermail 2.1.4 : Tue Dec 03 2002 - 07:22:59 GMT-3