From: Adam Crisp (adam.crisp@totalise.co.uk)
Date: Thu Oct 24 2002 - 14:31:46 GMT-3
Hi
the command is:
distance <distance> <ip address (or range) of advertising router> <mask of
advertising router> <ip access list of routes to match>
here's an example:
BEFORE:
router eigrp 8200
redistribute ospf 4000 metric 1500 10 255 10 1500 route-map ospf_2_eigrp
network 139.10.103.0 0.0.0.255
network 180.1.1.1 0.0.0.0
no auto-summary
!
Router2#show ip route eigrp
139.10.0.0/16 is variably subnetted, 20 subnets, 3 masks
D 139.10.5.0/24 [90/409600] via 139.10.103.5, 00:00:05, Ethernet0
D 139.10.6.0/24 [90/409600] via 139.10.103.6, 00:00:00, Ethernet0
D 139.10.10.0/24 [90/435200] via 139.10.103.6, 00:00:00, Ethernet0
D 139.10.90.0/25 [90/307200] via 139.10.103.6, 00:00:00, Ethernet0
160.160.0.0/24 is subnetted, 1 subnets
D 160.160.160.0 [90/307200] via 139.10.103.6, 00:00:01, Ethernet0
D 180.0.0.0/8 is a summary, 03:02:13, Null0
Router2#
!
Router2#show ip eigrp n
IP-EIGRP neighbors for process 8200
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 139.10.103.6 Et0 13 00:00:01 0 2000 1 0
0 139.10.103.5 Et0 13 00:00:06 0 4500 2 110
Router2#
note that the route 160.160.0.0 /16 is advertised by 139.10.103.6
Let's make it have an AD of 2!!!!!
AFTER:
show run | begin router eigrp 8200
router eigrp 8200
redistribute ospf 4000 metric 1500 10 255 10 1500 route-map ospf_2_eigrp
network 139.10.103.0 0.0.0.255
network 180.1.1.1 0.0.0.0
distance 2 0.0.0.0 255.255.255.255 99
no auto-summary
!
access-list 99 permit 160.160.0.0 0.0.255.255
access-list 99 deny any
!
end
Router2#show ip route eigrp
139.10.0.0/16 is variably subnetted, 20 subnets, 3 masks
D 139.10.5.0/24 [90/409600] via 139.10.103.5, 00:03:28, Ethernet0
D 139.10.6.0/24 [90/409600] via 139.10.103.6, 00:03:31, Ethernet0
D 139.10.90.0/25 [90/307200] via 139.10.103.6, 00:03:31, Ethernet0
160.160.0.0/24 is subnetted, 1 subnets
D 160.160.160.0 [2/307200] via 139.10.103.6, 00:03:31, Ethernet0
D 180.0.0.0/8 is a summary, 00:04:00, Null0
Router2#
If you want to change the Distance for this router only then:
conf t
router eigrp 8200
distance eigrp 80 110
end
clear ip eigrp n
show ip route eigrp
Router2#show ip route eigrp
139.10.0.0/16 is variably subnetted, 20 subnets, 3 masks
D 139.10.5.0/24 [80/409600] via 139.10.103.5, 00:00:00, Ethernet0
D 139.10.6.0/24 [80/409600] via 139.10.103.6, 00:00:05, Ethernet0
D 139.10.90.0/25 [80/307200] via 139.10.103.6, 00:00:05, Ethernet0
160.160.0.0/24 is subnetted, 1 subnets
D 160.160.160.0 [2/307200] via 139.10.103.6, 00:00:05, Ethernet0
D 180.0.0.0/8 is a summary, 00:05:35, Null0
Good luck
Adam
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Hung, Sing-Yu
Sent: 24 October 2002 17:13
To: ccielab@groupstudy.com
Cc: ccielab@groupstudy.com; nobody@groupstudy.com
Subject: EIGRP Distance
Dear,
How can I set distance in EIGRP, because I can't get success by
below command
r6#sh run | beg router ei
router eigrp 146
redistribute ospf 100 metric 1544 600 125 125 1500
redistribute igrp 68 metric 1544 600 125 125 1500
passive-interface default
no passive-interface Serial0.1
network 172.16.146.0 0.0.0.15
distance 99 172.16.14.0 0.0.0.255
distance 255 0.0.0.0 0.0.0.0
no auto-summary
eigrp log-neighbor-changes
r6#r ei
172.16.0.0/16 is variably subnetted, 24 subnets, 6 masks
D 172.16.14.0/24 [90/2297856] via 172.16.146.14, 00:03:53, Serial0.1
Bradford Hung
Pacific Century CyberWorks
Tel: 288 33125
This archive was generated by hypermail 2.1.4 : Tue Nov 05 2002 - 08:35:56 GMT-3