From: CCIE5591 (ccie@optonline.net)
Date: Mon Oct 21 2002 - 21:25:13 GMT-3
Here is what I tried and works. Configs are included below.
To test the BGP stuff I created loopback-1 on both the extreme end routers
(r7 and r3) and made sure that it propogated to the other end.
HTH
Manjeet Chawla
mchawla@optonline.net
CCIE #5591
************************************************************
r7#sh running-config
Building configuration...
Current configuration : 1316 bytes
!
version 12.1
!
hostname r7
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
ip address 11.0.0.1 255.0.0.0
!
interface Serial0
ip address 192.168.12.2 255.255.255.0
no fair-queue
!
router rip
version 2
network 1.0.0.0
network 192.168.12.0
!
router bgp 2010
bgp log-neighbor-changes
network 1.1.1.1 mask 255.255.255.255
network 1.1.1.1
network 11.0.0.0
neighbor 192.168.12.1 remote-as 2001
!
end
r7#
r7#
r7#sh ip bgp
BGP table version is 51, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 1.1.1.1/32 0.0.0.0 0 32768 i
*> 4.4.4.4/32 192.168.12.1 0 2001 i
*> 11.0.0.0 0.0.0.0 0 32768 i
*> 44.0.0.0 192.168.12.1 0 2001 i
r7#
r7#
r7#sh ip bgp summ
BGP router identifier 1.1.1.1, local AS number 2010
BGP table version is 51, main routing table version 51
5 network entries and 4 paths using 629 bytes of memory
2 BGP path attribute entries using 120 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP activity 13/26 prefixes, 66/62 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down
State/PfxRcd
192.168.12.1 4 2001 70 66 51 0 0 00:16:52 2
r7#
r7#
r7#
r7#sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.12.0/24 is directly connected, Serial0
1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
4.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 4.4.4.4/32 [20/0] via 192.168.12.1, 00:02:38
R 4.0.0.0/8 [120/6] via 192.168.12.1, 00:00:01, Serial0
R 192.168.23.0/24 [120/6] via 192.168.12.1, 00:00:01, Serial0
C 11.0.0.0/8 is directly connected, Loopback1
R 192.168.34.0/24 [120/6] via 192.168.12.1, 00:00:01, Serial0
12.0.0.0/24 is subnetted, 1 subnets
C 12.12.12.0 is directly connected, Serial0:0
B 44.0.0.0/8 [20/0] via 192.168.12.1, 00:02:39
r7#
****************************************************************************
***
R2#sh running-config
Building configuration...
!
hostname R2
!
interface Serial0
ip address 192.168.23.2 255.255.255.0
!
interface Serial1
ip address 192.168.12.1 255.255.255.0
clockrate 2000000
!
router ospf 1
log-adjacency-changes
redistribute rip metric 120000 metric-type 1
network 192.168.23.0 0.0.0.255 area 0.0.0.0
!
router rip
version 2
redistribute ospf 1 metric 6
network 192.168.12.0
!
router bgp 2001
no synchronization
bgp log-neighbor-changes
neighbor 192.168.12.2 remote-as 2010
neighbor 192.168.23.1 remote-as 2001
!
end
R2#
R2#
R2#
R2#sh ip bgp
BGP table version is 21, local router ID is 192.168.255.2
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 1.1.1.1/32 192.168.12.2 0 0 2010 i
*>i4.4.4.4/32 192.168.34.1 0 100 0 i
*> 11.0.0.0 192.168.12.2 0 0 2010 i
*>i44.0.0.0 192.168.34.1 0 100 0 i
R2#sh ip bgp summ
BGP router identifier 192.168.255.2, local AS number 2001
BGP table version is 21, main routing table version 21
4 network entries and 4 paths using 532 bytes of memory
2 BGP path attribute entries using 120 bytes of memory
1 BGP rrinfo entries using 24 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP activity 8/12 prefixes, 10/6 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down
State/PfxRcd
192.168.12.2 4 2010 69 73 21 0 0 00:19:16 2
192.168.23.1 4 2001 39 39 21 0 0 00:24:08 2
R2#
R2#
R2#
R2#sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.12.0/24 is directly connected, Serial1
1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 1.1.1.1/32 [20/0] via 192.168.12.2, 00:19:19
R 1.0.0.0/8 [120/1] via 192.168.12.2, 00:00:04, Serial1
4.0.0.0/32 is subnetted, 1 subnets
O 4.4.4.4 [110/129] via 192.168.23.1, 00:38:12, Serial0
C 192.168.23.0/24 is directly connected, Serial0
B 11.0.0.0/8 [20/0] via 192.168.12.2, 00:13:41
C 192.168.255.0/24 is directly connected, Ethernet0
O 192.168.34.0/24 [110/128] via 192.168.23.1, 00:38:14, Serial0
12.0.0.0/24 is subnetted, 1 subnets
C 12.12.12.0 is directly connected, Serial0:0
B 44.0.0.0/8 [200/0] via 192.168.34.1, 00:05:02
R2#
****************************************************************************
***
R1#
R1#sh runn
R1#sh running-config
Building configuration...
hostname R1
!
interface Ethernet0
ip address 192.168.255.3 255.255.255.0
!
interface Serial0
ip address 192.168.34.2 255.255.255.0
!
interface Serial1
ip address 192.168.23.1 255.255.255.0
clockrate 2000000
!
router ospf 1
log-adjacency-changes
network 192.168.23.0 0.0.0.255 area 0.0.0.0
network 192.168.34.0 0.0.0.255 area 0.0.0.0
!
router bgp 2001
no synchronization
bgp log-neighbor-changes
neighbor 192.168.23.2 remote-as 2001
neighbor 192.168.23.2 route-reflector-client
neighbor 192.168.34.1 remote-as 2001
neighbor 192.168.34.1 route-reflector-client
!
R1#
R1#
R1#sh ip bgp
BGP table version is 21, local router ID is 192.168.255.3
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i1.1.1.1/32 192.168.12.2 0 100 0 2010 i
*>i4.4.4.4/32 192.168.34.1 0 100 0 i
*>i11.0.0.0 192.168.12.2 0 100 0 2010 i
*>i44.0.0.0 192.168.34.1 0 100 0 i
R1#
R1#
R1#
R1#sh ip bgp summ
BGP router identifier 192.168.255.3, local AS number 2001
BGP table version is 21, main routing table version 21
4 network entries and 4 paths using 532 bytes of memory
2 BGP path attribute entries using 120 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP activity 7/29 prefixes, 9/5 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down
State/PfxRcd
192.168.23.2 4 2001 40 40 21 0 0 00:25:33 2
192.168.34.1 4 2001 53 60 21 0 0 00:06:50 2
R1#
R1#
R1#
R1#sh ip ro
R1#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
O E1 192.168.12.0/24 [110/120064] via 192.168.23.2, 00:09:41, Serial1
1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 1.1.1.1/32 [200/0] via 192.168.12.2, 00:09:20
O E1 1.0.0.0/8 [110/120064] via 192.168.23.2, 00:09:41, Serial1
4.0.0.0/32 is subnetted, 1 subnets
O 4.4.4.4 [110/65] via 192.168.34.1, 00:09:41, Serial0
C 192.168.23.0/24 is directly connected, Serial1
B 11.0.0.0/8 [200/0] via 192.168.12.2, 00:09:20
C 192.168.255.0/24 is directly connected, Ethernet0
C 192.168.34.0/24 is directly connected, Serial0
B 44.0.0.0/8 [200/0] via 192.168.34.1, 00:06:28
R1#
R1#
R1#
****************************************************************************
***
R3#
R3#sh runn
R3#sh running-config
!
hostname R3
!
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface Loopback1
ip address 44.0.0.1 255.0.0.0
!
interface Ethernet0
ip address 192.168.255.4 255.255.255.0
!
interface Serial0
ip address 192.168.45.2 255.255.255.0
!
interface Serial1
ip address 192.168.34.1 255.255.255.0
clockrate 2000000
!
router ospf 1
log-adjacency-changes
network 4.4.4.0 0.0.0.255 area 0.0.0.0
network 192.168.34.0 0.0.0.255 area 0.0.0.0
!
router bgp 2001
no synchronization
bgp log-neighbor-changes
network 4.4.4.4 mask 255.255.255.255
network 44.0.0.0
neighbor 192.168.34.2 remote-as 2001
!
R3#
R3#
R3#sh ip bgp
BGP table version is 5, local router ID is 44.0.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i1.1.1.1/32 192.168.12.2 0 100 0 2010 i
*> 4.4.4.4/32 0.0.0.0 0 32768 i
*>i11.0.0.0 192.168.12.2 0 100 0 2010 i
*> 44.0.0.0 0.0.0.0 0 32768 i
R3#sh ip bgp summ
BGP router identifier 44.0.0.1, local AS number 2001
BGP table version is 5, main routing table version 5
4 network entries and 4 paths using 532 bytes of memory
2 BGP path attribute entries using 120 bytes of memory
1 BGP rrinfo entries using 24 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP activity 13/47 prefixes, 13/9 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down
State/PfxRcd
192.168.34.2 4 2001 62 56 5 0 0 00:08:09 2
R3#
R3#
R3#sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
O E1 192.168.12.0/24 [110/120128] via 192.168.34.2, 00:40:56, Serial1
1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 1.1.1.1/32 [200/0] via 192.168.12.2, 00:08:13
O E1 1.0.0.0/8 [110/120128] via 192.168.34.2, 00:21:09, Serial1
C 192.168.45.0/24 is directly connected, Serial0
4.0.0.0/32 is subnetted, 1 subnets
C 4.4.4.4 is directly connected, Loopback0
O 192.168.23.0/24 [110/128] via 192.168.34.2, 00:40:56, Serial1
B 11.0.0.0/8 [200/0] via 192.168.12.2, 00:08:13
C 192.168.255.0/24 is directly connected, Ethernet0
C 192.168.34.0/24 is directly connected, Serial1
C 44.0.0.0/8 is directly connected, Loopback1
R3#
****************************************************************************
***
Manjeet Chawla
mchawla@optonline.net
CCIE #5591
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Azhar Mehmood
Sent: Monday, October 21, 2002 6:16 PM
To: ccielab@groupstudy.com
Subject: BGP Synch Problem !!!!!!
Hi,
scenario:
\ /
AS2010 \ / AS2001
R7-----------------------R2-----------------R1-----------------R3
/ \
/ \
IGP:
- between R7 and R2 IGP is RIP v2
- R2,R1 & R3 running OSPF
- routes fron RIP redistributed in OSPF and v/v
- full connectivity is established (every router can reach each network in
bot ASs via its IGP)
BGP:
- EBGP between R7 & R2, IBGP R2,R1 & R3 (partial mesh: R2-->R1--->R3)
- R1 is Route-Reflector for R2 & R3
Problem:
- routes learned via bgp on R1 are marked as valid and best (*>) but same
routes when reflected to R3 are although marked as valid but not best.
Detailed view of a prefix learned via R1 shows that prefixes are not synched
for some reason (enabling "no synch" command proves that). IGP Routes in
both router's routing table are same.
So now the 1 Mio. $ Question: What is causing BGP prefixes on R3 no to be
synchronized, despite having routes in routing table toward nexthop and same
prefixes learned via IGP.
As far I understood the "Synch rule" was that it states that, prfixes
learned via IBGP should be present in routing table learned via an IGP to
avoid blackholing traffic and mark prefixes as best to propogate them
further. is that right?
regards
Azhar M.
PS: configs are available OD.
This archive was generated by hypermail 2.1.4 : Tue Nov 05 2002 - 08:35:53 GMT-3