From: ying c (bf5tgh1@yahoo.com)
Date: Sat Oct 05 2002 - 18:34:58 GMT-3
Hi Scott,
Tried it, but it did not work. I also checked Cds42715
that Chris mentioned, but the bug is for dot1q native
mode problem, which is not applied to the isl I'm
doing here.
Below is my topology, config and sample output,
hopefully someone can point out what's wrong:
R4 R5
| |
|----------|
vlan4 | vlan 5
|
|-----vlan100--cat 3550
|
R10 (router-on-the-stick, vlan 4, 5, 100)
ip addresses:
r4 e0: 148.24.5.4/24 in vlan 4
r5 e0: 148.24.5.5/24 in vlan 5
r10 BVI 1: 148.24.5.10/24
Cat3550 vlan 100: 148.24.5.100/24 in vlan 100
The goal is to bridge vlan 4, vlan 5 and vlan 100.
Cat3550 (no ip routing was applied, but not shown in
sh run):
version 12.1
!
hostname Cat3550
!
!
!
interface FastEthernet0/4
switchport access vlan 4
switchport mode access
no ip address
spanning-tree portfast
!
interface FastEthernet0/5
switchport access vlan 5
switchport mode access
no ip address
spanning-tree portfast
!
interface FastEthernet0/10
switchport trunk encapsulation isl
switchport trunk allowed vlan 1,4,5,100,1002-1005
switchport mode trunk
no ip address
!
interface Vlan1
no ip address
shutdown
!
interface Vlan100
ip address 148.24.5.100 255.255.255.0
!
ip default-gateway 148.24.5.10
--------------------------------------
R4:
interface Ethernet0
ip address 148.24.5.4 255.255.255.0
R5:
interface Ethernet0
ip address 148.24.5.5 255.255.255.0
R10:
!
version 12.2
!
hostname r10
!
!
bridge irb
!
!
interface FastEthernet0/0
mac-address 0010.0010.0010
no ip address
no ip route-cache
no ip mroute-cache
duplex auto
speed auto
!
interface FastEthernet0/0.4
encapsulation isl 4
no ip redirects
no ip route-cache
no ip mroute-cache
bridge-group 1
!
interface FastEthernet0/0.5
encapsulation isl 5
no ip redirects
no ip route-cache
no ip mroute-cache
bridge-group 1
!
interface FastEthernet0/0.100
encapsulation isl 100
no ip redirects
no ip route-cache
no ip mroute-cache
bridge-group 1
!
interface BVI1
ip address 148.24.5.10 255.255.255.0
!
bridge 1 protocol ieee
bridge 1 route ip
!
------------------------------------
ping from r4, failed to 3550's mgmt interface:
r4#ping 148.24.5.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 148.24.5.5, timeout
is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip
min/avg/max = 16/18/20 ms
r4#ping 148.24.5.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 148.24.5.10, timeout
is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip
min/avg/max = 1/3/4 ms
r4#ping 148.24.5.100
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 148.24.5.100,
timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
r4#
-------------------------------------
ping from r5, failed to 3550's mgmt interface:
r5#ping 148.24.5.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 148.24.5.4, timeout
is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip
min/avg/max = 4/4/8 ms
r5#ping 148.24.5.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 148.24.5.10, timeout
is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip
min/avg/max = 4/4/8 ms
r5#ping 148.24.5.100
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 148.24.5.100,
timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
r5#
---------------------------------------
ping from r10 - OK:
r10#ping 148.24.5.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 148.24.5.4, timeout
is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip
min/avg/max = 1/2/4 ms
r10#ping 148.24.5.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 148.24.5.5, timeout
is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip
min/avg/max = 4/4/4 ms
r10#ping 148.24.5.100
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 148.24.5.100,
timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip
min/avg/max = 1/2/4 ms
r10#
-----------------------------------------
ping from 3550, only can reach r10's BVI:
Cat3550#ping 148.24.5.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 148.24.5.4, timeout
is 2 seconds:
.....
Success rate is 0 percent (0/5)
Cat3550#ping 148.24.5.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 148.24.5.5, timeout
is 2 seconds:
.....
Success rate is 0 percent (0/5)
Cat3550#ping 148.24.5.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 148.24.5.10, timeout
is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip
min/avg/max = 1/2/4 ms
Cat3550#
--- Scott Morris <swm@emanon.com> wrote:
> Try "no ip routing". Your cat5 was a L2 switch
> only. Your 3550 is an
> L3 switch out of the box.
>
> Scott
>
> -----Original Message-----
> From: nobody@groupstudy.com
> [mailto:nobody@groupstudy.com] On Behalf Of
> ying c
> Sent: Saturday, October 05, 2002 1:44 PM
> To: ccielab@groupstudy.com
> Subject: RE: Mgmt Interface 3550 in separate vlan
> REVISITED +
> clarification on Native VLAN
>
>
> Hi,
>
> Sorry about the old thread. Did anyone get the
> consistent result when 3550 mgmt interface is in
> different vlan? The 3550 I'm renting uses version
> 121-9.EA1c.bin code, I
> could ping BVI at the router-on-the-stick, routers
> can ping each other
> across different vlans but the 3550's mgmt vlan.
>
> I've turned off ip route-cache, no native vlan on
> 3550, also tried both isl and dot1q but pretty much
> got the samething - 3550 ping to different vlans
> always fails. I haven't checked bug id that Chris
> mentioned yet and not sure if upgrading IOS is the
> only way to resolve this problem. If upgrade IOS is
> not necessary, can someone tell me what I should do
> differently than the regular steps? I have used
> 29xxXL
> and cat5K before for the same thing and never had
> any
> problems.
>
> Thanks,
> Chang
This archive was generated by hypermail 2.1.4 : Tue Nov 05 2002 - 08:35:40 GMT-3