Help please, isdn flapping

From: jeff szeto (jytszeto@hotmail.com)
Date: Fri Sep 13 2002 - 10:37:31 GMT-3


Hi Group,

Help please. Isdn is flopping and I cannot solve it.

R3 goes up and down. The debug shows that the dial reason is R3 tries to reach
172.16.4.4, which is not the two ends of the isdn..
This is the RID of R3's bgp peer. However, I have deny bgp in the
dialer-list.
No routing protocol is used. I just use floating static routes.

The following is the related config, could someone help me to solve it?

Thank you in advance.

Jeff

R3
!
logging rate-limit console 10 except errors
!
username R5 password 0 cisco
!
interface Loopback0
 ip address 172.16.3.3 255.255.255.0
!
interface BRI0
 ip address 172.16.35.6 255.255.255.252
 encapsulation ppp
 dialer map ip 172.16.35.5 name R5 broadcast 1111
 dialer map ip 172.16.35.5 name R5 broadcast 1113
 dialer-group 1
 isdn switch-type basic-5ess
 isdn spid1 221112
 isdn spid2 221114
 ppp authentication chap
!
router bgp 1
 bgp router-id 172.16.3.3
 neighbor 172.16.4.4 remote-as 1
 neighbor 172.16.4.4 update-source Loopback0
!
ip route 0.0.0.0 0.0.0.0 172.16.35.5 200

access-list 100 deny ip any host 224.0.0.10
access-list 100 deny tcp any any eq bgp
access-list 100 deny eigrp any any
access-list 100 permit ip any any
dialer-list 1 protocol ip list 100

R5

username R3 password 0 cisco
!
interface Loopback0
 ip address 172.16.5.5 255.255.255.0

interface BRI0
 ip address 172.16.35.5 255.255.255.252
 encapsulation ppp
 dialer map ip 172.16.35.6 name R3 broadcast 1112
 dialer map ip 172.16.35.6 name R3 broadcast 1114
 dialer-group 1
 ppp authentication chap
!
router bgp 101
 bgp router-id 172.16.5.5
 neighbor 172.16.3.3 remote-as 1
 neighbor 172.16.3.3 ebgp-multihop 255
 neighbor 172.16.3.3 update-source Loopback0
 neighbor 172.16.3.3 route-map as-comm in
!
ip route 172.16.30.0 255.255.255.0 172.16.35.6 200
!
access-list 100 deny ip any host 224.0.0.10
access-list 100 deny tcp any any eq bgp
access-list 100 deny eigrp any any
access-list 100 permit ip any any
dialer-list 1 protocol ip list 100

R3#
*Mar 2 07:34:56: BR0 DDR: ip (s=172.16.3.3, d=172.16.4.4), 40 bytes, outgoing
int
eresting (list 100)
*Mar 2 07:34:56: BR0 DDR: Dialing cause ip (s=172.16.3.3, d=172.16.4.4)
*Mar 2 07:34:56: BR0 DDR: Attempting to dial 1111
*Mar 2 07:34:57: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
R3#
*Mar 2 07:34:57: BR0:1 DDR: dialer protocol up
R3#
*Mar 2 07:34:58: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
change
d state to up
R3#
*Mar 2 07:35:03: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 1111
R5
R3#
*Mar 2 07:35:06: BR0 DDR: ip (s=172.16.3.3, d=172.16.4.4), 40 bytes, outgoing
int
eresting (list 100)
R3#
*Mar 2 07:35:16: BR0 DDR: ip (s=172.16.3.3, d=172.16.4.4), 40 bytes, outgoing
int
eresting (list 100)
R3#
*Mar 2 07:36:57: %ISDN-6-DISCONNECT: Interface BRI0:1 disconnected from 111
1 R5, call lasted 119 seconds
*Mar 2 07:36:57: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down
R3#
*Mar 2 07:36:57: BR0:1 DDR: disconnecting call
R3#
*Mar 2 07:36:58: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
change
d state to down
R3#
*Mar 2 07:37:13: BR0 DDR: ip (s=172.16.3.3, d=172.16.4.4), 44 bytes, outgoing
int
eresting (list 100)
*Mar 2 07:37:13: BR0 DDR: Dialing cause ip (s=172.16.3.3, d=172.16.4.4)
*Mar 2 07:37:13: BR0 DDR: Attempting to dial 1111
R3#
*Mar 2 07:37:13: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
R3#
*Mar 2 07:37:15: BR0 DDR: ip (s=172.16.3.3, d=172.16.4.4), 40 bytes, outgoing
int
eresting (list 100)
*Mar 2 07:37:15: BR0 DDR: ip (s=172.16.3.3, d=172.16.4.4), 44 bytes, outgoing
int
eresting (list 100)
*Mar 2 07:37:15: BR0:1 DDR: dialer protocol up
R3#
*Mar 2 07:37:16: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
change
d state to up
R3#

R3#sh dialer

BRI0 - dialer type = ISDN

Dial String Successes Failures Last DNIS Last status
1113 0 0 never -
1111 4 0 00:00:39 successful
0 incoming call(s) have been screened.
0 incoming call(s) rejected for callback.

BRI0:1 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: ip (s=172.16.3.3, d=172.16.4.4)
Time until disconnect 94 secs
Connected to 1111 (R5)

BRI0:2 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle
R3#
R3#
R3#



This archive was generated by hypermail 2.1.4 : Mon Oct 07 2002 - 07:43:50 GMT-3