RE: Tunnel Interface Help

From: Warner, Thomas S (thomas.s.warner@lmco.com)
Date: Fri Sep 06 2002 - 19:22:40 GMT-3


Hi
 
Try making your tunnel destination under each tunnel interface be the
loopback1000 IP address of the opposite router. That way your tunnel source
and destination will match up. At least that's always the way I configure
it.

(Router A)
!
interface Loopback1000
 ip address 190.190.190.1 255.255.255.0
!
interface Tunnel0
 tunnel source Loopback1000
 tunnel destination 170.170.12.1
!
(Router D)
!
interface Loopback1000
 ip address 170.170.12.1 255.255.255.0
!
interface Tunnel0
 tunnel source Loopback1000
 tunnel destination 190.190.190.1

Tom Warner
Lockheed Martin Enterprise Information Systems
Computing and Network Services
email: mailto:thomas.s.warner@lmco.com

-----Original Message-----
From: ccie2002@bellsouth.net [mailto:ccie2002@bellsouth.net]
Sent: Friday, September 06, 2002 2:01 PM
To: ccielab@groupstudy.com
Subject: Tunnel Interface Help

Hello:

All I need a little help on my home lab. I am trying to get rip routes
to come thru on my tunnel while running another routing protocol outside
my tunnel. The problem I am having is that my tunnel comes up and
I can ping from my loopback with no problems. I am using my loopbacks on
each router as my tunnel source and tunnel destinations. However,
I do not see any rip routes going thru my tunnel. Also I can not
ping from Tunnel to Tunnel. However, I can ping from Tunnel
source and destination with no problems. My goal is to run
rip thru my tunnel while running another protocol outside of my tunnel.
Does anyone know what might be the problem. I have tried to change
the admin distance on rip to have router A and D use RIP but this did not
work. Any help ? I am a rookie.

Below is a basic diagram of what I am doing.

                            RIP

Tunnel Router A ------------------------------- Tunnel Router D

         (eigrp) (ospf) ( ospf)

Router A-------- Router B-------Router C-----Router D

  (Router A Below)

hostname cisco2504
!
enable password cisco
!
username cisco05 password 0 cisco
ip subnet-zero
no ip domain-lookup
ipx routing 0004.0004.0004
ipx internal-network 4444
isdn switch-type basic-dms100
!
key chain cisco
 key 1
  key-string cisco
!
!
 !
 !
 !
 interface Loopback0
 ip address 150.3.7.7 255.255.255.0
 no ip directed-broadcast
!
interface Loopback1
 ip address 200.200.40.7 255.255.255.0
 no ip directed-broadcast
!
interface Loopback3
 ip address 10.10.9.1 255.255.255.252
 no ip directed-broadcast
!
interface Loopback4
 ip address 10.10.10.1 255.255.255.252
 no ip directed-broadcast
!
interface Loopback5
 ip address 10.10.11.1 255.255.255.252
 no ip directed-broadcast
!
interface Loopback6
 ip address 10.10.12.1 255.255.255.252
 no ip directed-broadcast
!
interface Loopback7
 ip address 10.10.13.1 255.255.255.252
 no ip directed-broadcast
!
interface Loopback8
 ip address 10.10.14.1 255.255.255.252
 no ip directed-broadcast
!
interface Loopback40
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Loopback800
 ip address 159.159.159.159 255.255.255.0
 no ip directed-broadcast
!
interface Loopback1000
 ip address 190.190.190.1 255.255.255.0
 ip rip send version 1 2
 ip rip receive version 1 2

  
no ip directed-broadcast
!
interface Loopback2054
 ip address 204.204.204.4 255.255.255.0
 no ip directed-broadcast
!
interface Tunnel0
 ip address 150.10.90.2 255.255.255.252
 no ip directed-broadcast
 ip rip send version 1 2
 ip rip receive version 1 2
 ipx network 2504
 tunnel source Loopback1000
 tunnel destination 140.168.3.3
!
interface Serial0
 ip address 150.10.24.7 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 no ip mroute-cache
 no fair-queue
!
interface Serial1
 ip address 166.37.160.2 255.255.255.252
 no ip directed-broadcast
 encapsulation ppp
!
interface TokenRing0
 ip address 79.79.79.1 255.255.255.0
 no ip directed-broadcast
 ipx network 16
interface BRI0
 ip address 150.10.40.1 255.255.255.252
 no ip directed-broadcast
 encapsulation ppp
 ip ospf message-digest-key 10 md5 cisco
 ip ospf network point-to-point
 shutdown
 dialer-group 1
 isdn switch-type basic-dms100
 isdn spid1 3840200001 384020
 ppp chap hostname cisco06
 ppp chap password 7 14141B180F0B
 hold-queue 75 in
!
router eigrp 1
 redistribute bgp 1000
 network 79.0.0.0
 network 150.3.0.0
 network 150.10.0.0
 network 166.37.0.0
 network 204.204.204.0
 network 0.0.0.0
 no auto-summary
router rip
 version 2
 network 150.10.0.0
 network 166.37.0.0
 network 190.190.0.0
 distance 80
!
router bgp 1000
 no synchronization
 network 10.10.9.0 mask 255.255.255.252
 network 10.10.10.0 mask 255.255.255.252
 network 10.10.11.0 mask 255.255.255.252
 network 10.10.12.0 mask 255.255.255.252
 network 10.10.13.0 mask 255.255.255.252
 network 10.10.14.0 mask 255.255.255.252
 network 159.159.159.0 mask 255.255.255.0
 network 200.200.40.0
 aggregate-address 10.10.0.0 255.255.0.0 suppress-map NET10
 neighbor 150.10.2.2 remote-as 22
 neighbor 150.10.2.2 ebgp-multihop 2
 neighbor 150.10.2.2 update-source Loopback1
 neighbor 166.37.160.1 remote-as 22
 neighbor 166.37.160.1 send-community
 neighbor 166.37.160.1 route-map CISCO out
 no auto-summary
!
ip classless
ip as-path access-list 1 permit AS1000 _1000_
!
!
ip prefix-list CISCO seq 5 permit 200.200.40.0/24
!
ip prefix-list NET10 seq 5 permit 10.10.9.0/30
ip prefix-list NET10 seq 10 deny 10.10.10.0/30
ip prefix-list NET10 seq 15 deny 10.10.11.0/30
ip prefix-list NET10 seq 20 deny 10.10.12.0/30
ip prefix-list NET10 seq 25 deny 10.10.13.0/30
ip prefix-list NET10 seq 30 deny 10.10.14.0/30
route-map AS1000 permit 10
 match as-path 1
 set as-path prepend 1000 1000 1000 1000
!
route-map CISCO permit 10
 match ip address prefix-list CISCO
 set community no-export
!
route-map NET10 permit 10
 match ip address prefix-list NET10
!
!
!
!

                            Router D below

!
cisco3620#sh run
Building configuration...

Current configuration : 2564 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cisco3620
!
enable password cisco
!
ip subnet-zero
!
!
no ip domain-lookup
!
ipx routing 0006.0006.0006
!
key chain cisco
 key 1
  key-string cisco
!
!
!
!
                   
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
!
!
!
interface Loopback0
 ip address 155.10.62.62 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback1
 ip address 140.168.3.3 255.255.255.248
 ip ospf network point-to-point
!
interface Loopback620
 ip address 62.62.62.62 255.255.255.0
!
interface Loopback1000
 ip address 170.170.12.1 255.255.255.0
!ip rip send version 1 2
 ip rip receive version 1 2

interface Loopback3000
 no ip address
 ipx network 3000
!
interface Tunnel0
 ip address 150.10.90.1 255.255.255.252
 ip rip send version 1 2
 ip rip receive version 1 2
 ipx network 2504
 tunnel source Loopback1000
 tunnel destination 150.3.7.7
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.100
 encapsulation isl 1
 ip address 140.168.1.1 255.255.255.192
interface Serial0/0
 ip address 150.10.10.9 255.255.255.240
 encapsulation frame-relay
 ip ospf message-digest-key 10 md5 cisco
 ip ospf network point-to-multipoint
 load-interval 30
 no fair-queue
 clockrate 2000000
 frame-relay map ip 150.10.10.3 620 broadcast
 no frame-relay inverse-arp
!
interface Serial0/1
 no ip address
 shutdown
 clockrate 2000000
router ospf 1
 router-id 6.6.6.6
 log-adjacency-changes
 area 5 authentication message-digest
 area 5 virtual-link 155.10.5.5 authentication message-digest
authentication-key
 10
 network 140.168.1.1 0.0.0.0 area 6
 network 140.168.3.3 0.0.0.0 area 6
 network 150.10.10.9 0.0.0.0 area 5
 network 155.10.62.62 0.0.0.0 area 6
!
router rip
 network 150.10.0.0
 network 170.170.0.0
 distance 80
!
router bgp 250
 no synchronization
 bgp log-neighbor-changes
 bgp confederation identifier 22
 network 62.62.62.0 mask 255.255.255.0
 neighbor 150.10.10.3 remote-as 250
 no auto-summary

cisco3620#show ip int brief
Interface IP-Address OK? Method Status
Prot
ocol
FastEthernet0/0 unassigned YES NVRAM up
up

FastEthernet0/0.100 140.168.1.1 YES NVRAM up
up

Serial0/0 150.10.10.9 YES NVRAM up
up

Serial0/1 unassigned YES NVRAM administratively down
down

Loopback0 155.10.62.62 YES NVRAM up
up

Loopback1 140.168.3.3 YES NVRAM up
up

Loopback620 62.62.62.62 YES manual up
up

Loopback1000 170.170.12.1 YES manual up
up

Loopback3000 unassigned YES unset up
up

Tunnel0 150.10.90.1 YES manual up
up

cisco3620#sh ver
Cisco Internetwork Operating System Software
IOS (tm) 3600 Software (C3620-J1S3-M), Version 12.2(8)T, RELEASE SOFTWARE
(fc2)
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Wed 13-Feb-02 22:13 by ccai
Image text-base: 0x60008930, data-base: 0x616F0000

ROM: System Bootstrap, Version 11.1(19)AA, EARLY DEPLOYMENT RELEASE SOFTWARE
(fc
1)

cisco3620 uptime is 1 week, 53 minutes
System returned to ROM by reload
System image file is "flash:c3620-j1s3-mz.122-8.T.bin"

cisco 3620 (R4700) processor (revision 0x81) with 60416K/5120K bytes of
memory.
Processor board ID 09917987
R4700 CPU at 80Mhz, Implementation 33, Rev 1.0
Bridging software.
X.25 software, Version 3.0.0.
TN3270 Emulation software.
1 FastEthernet/IEEE 802.3 interface(s)
2 Serial network interface(s)
2 Voice FXS interface(s)
DRAM configuration is 32 bits wide with parity disabled.
29K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read/Write)

cisco2504#show ip int brief
Interface IP-Address OK? Method Status
Protocol
BRI0 150.10.40.1 YES manual administratively down down
BRI0:1 unassigned YES unset administratively down down
BRI0:2 unassigned YES unset administratively down down
Loopback0 150.3.7.7 YES manual up up
Loopback1 200.200.40.7 YES manual up up
Loopback3 10.10.9.1 YES manual up up
Loopback4 10.10.10.1 YES manual up up
Loopback5 10.10.11.1 YES manual up up
Loopback6 10.10.12.1 YES manual up up
Loopback7 10.10.13.1 YES manual up up
Loopback8 10.10.14.1 YES manual up up
Loopback40 unassigned YES unset administratively down down
Loopback800 159.159.159.159 YES manual up up
Loopback1000 190.190.190.1 YES manual up up
Loopback2054 204.204.204.4 YES manual up up
Serial0 150.10.24.7 YES manual up up
Serial1 166.37.160.2 YES manual up up
TokenRing0 79.79.79.1 YES manual up up
Tunnel0 150.10.90.2 YES manual up up
cisco250

cisco2504#sh ver
Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-JOS56I-L), Version 12.0(4), RELEASE SOFTWARE
(fc1)
Copyright (c) 1986-1999 by cisco Systems, Inc.
Compiled Thu 15-Apr-99 01:26 by ccai
Image text-base: 0x0305719C, data-base: 0x00001000

ROM: System Bootstrap, Version 11.0(10c), SOFTWARE
BOOTFLASH: 3000 Bootstrap Software (IGS-BOOT-R), Version 11.0(10c), RELEASE
SOFT
WARE (fc1)

cisco2504 uptime is 1 week, 4 days, 13 hours, 40 minutes
System restarted by power-on
System image file is "flash:/2500entipsec.bin"

cisco 2500 (68030) processor (revision D) with 16384K/2048K bytes of memory.
Processor board ID 04899709, with hardware revision 00000000
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software copyright 1990 by Meridian Technology Corp).
TN3270 Emulation software.
Basic Rate ISDN software, Version 1.1.
1 Token Ring/IEEE 802.5 interface(s)
2 Serial network interface(s)
1 ISDN Basic Rate interface(s)
32K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read ONLY)

Configuration register is 0x2102

cisco250



This archive was generated by hypermail 2.1.4 : Mon Oct 07 2002 - 07:43:45 GMT-3