From: Matt Mullins (dahlene@xxxxxxxx)
Date: Sat Aug 31 2002 - 20:48:46 GMT-3
I am trying to get bgp to redistribute into eigrp but can't seem to make it
work. What am I missing here?
The topology is fairly simple
R7------R5---------R3
| |
| |
R6----------R2
R7 runs BGP and is in BGP autonomous System 100
R2,3,5,6 are running eigrp and are in autonomous System 200 with R5 running
BGP to connect to R1. R5 learns the 10. network from R7 via bgp and I am
trying to get the 10. network into routers 2,3, and 6. However, when I
redistribute bgp 200 into eigrp it does not pass the route. What am I missing
here?
Thanks,
Matt
hostname R7
!
interface Ethernet0
no ip address
no ip directed-broadcast
shutdown
!
interface Serial0
description conn to r5
bandwidth 1544
ip address 192.19.15.1 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
no fair-queue
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
router bgp 100
network 10.1.1.1 mask 255.255.255.0
network 192.19.15.0
neighbor 192.19.15.4 remote-as 200
!
ip classless
r7#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
U - per-user static route, o - ODR
Gateway of last resort is not set
B 195.19.15.0/24 [20/0] via 192.19.15.4, 00:08:39
C 192.19.15.0/24 is directly connected, Serial0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Loopback0
r7#
r7#sh ip bgp sum
BGP router identifier 10.1.1.1, local AS number 100
BGP table version is 4, main routing table version 4
3 network entries and 3 paths using 363 bytes of memory
3 BGP path attribute entries using 292 bytes of memory
BGP activity 3/0 prefixes, 3/0 paths
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down
State/PfxRcd
192.19.15.4 4 200 20 21 4 0 0 00:16:23 1
r7#
hostname r5
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
no ip dhcp-client network-discovery
!
!
!
!
interface Loopback0
ip address 195.19.15.145 255.255.255.240
!
interface Ethernet0
description connection to r2
ip address 195.19.15.2 255.255.255.192
!
interface Serial0
description conn to r3
bandwidth 16000
ip address 195.19.15.66 255.255.255.192
no fair-queue
!
interface Serial1
description conn to term_Serv
bandwidth 1544
ip address 192.19.15.4 255.255.255.0
clockrate 64000
!
router eigrp 1
redistribute bgp 200
network 195.19.15.0
auto-summary
no eigrp log-neighbor-changes
!
router bgp 200
no synchronization
bgp log-neighbor-changes
redistribute eigrp 1
neighbor 192.19.15.1 remote-as 100
ip classless
r5#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
195.19.15.0/24 is variably subnetted, 7 subnets, 3 masks
C 195.19.15.144/28 is directly connected, Loopback0
D 195.19.15.128/28 [90/40665600] via 195.19.15.1, 00:08:12, Ethernet0
D 195.19.15.180/30 [90/40537600] via 195.19.15.1, 00:08:12, Ethernet0
D 195.19.15.176/30 [90/41024000] via 195.19.15.65, 00:08:12, Serial0
D 195.19.15.160/28 [90/409600] via 195.19.15.1, 00:09:47, Ethernet0
C 195.19.15.64/26 is directly connected, Serial0
C 195.19.15.0/26 is directly connected, Ethernet0
C 192.19.15.0/24 is directly connected, Serial1
B 10.0.0.0/8 [20/0] via 192.19.15.1, 00:07:43
r5#sh ip bgp summ
BGP router identifier 195.19.15.145, local AS number 200
BGP table version is 4, main routing table version 4
3 network entries and 3 paths using 399 bytes of memory
3 BGP path attribute entries using 180 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP activity 3/0 prefixes, 3/0 paths, scan interval 15 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down
State/PfxRcd
192.19.15.1 4 100 20 19 4 0 0 00:15:22 2
hostname r3
!
logging rate-limit console 10 except errors
enable password asdf
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
no ip dhcp-client network-discovery
!
!
!
!
interface Serial0
description conn to r6
bandwidth 64
ip address 195.19.15.178 255.255.255.252
no fair-queue
!
interface Serial1
description conn to r4
bandwidth 1600
ip address 195.19.15.65 255.255.255.192
clockrate 64000
!
interface TokenRing0
no ip address
shutdown
!
interface BRI0
no ip address
shutdown
isdn x25 static-tei 0
cdapi buffers regular 0
cdapi buffers raw 0
cdapi buffers large 0
!
router eigrp 1
network 195.19.15.0
auto-summary
no eigrp log-neighbor-changes
!
ip kerberos source-interface any
ip classless
r3#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
195.19.15.0/24 is variably subnetted, 7 subnets, 3 masks
D 195.19.15.144/28 [90/2240000] via 195.19.15.66, 00:10:17, Serial1
D 195.19.15.128/28 [90/40640000] via 195.19.15.177, 00:10:19, Serial0
D 195.19.15.180/30 [90/41024000] via 195.19.15.177, 00:10:19, Serial0
C 195.19.15.176/30 is directly connected, Serial0
D 195.19.15.160/28 [90/2265600] via 195.19.15.66, 00:10:17, Serial1
C 195.19.15.64/26 is directly connected, Serial1
D 195.19.15.0/26 [90/2137600] via 195.19.15.66, 00:10:18, Serial1
r3#
hostname r6
!
logging rate-limit console 10 except errors
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
cns event-service server
!
!
interface Loopback0
ip address 195.19.15.129 255.255.255.240
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
description conn to r3
bandwidth 64
ip address 195.19.15.177 255.255.255.252
no fair-queue
clockrate 64000
!
interface Serial1
description conn to r2
bandwidth 64
ip address 195.19.15.181 255.255.255.252
!
router eigrp 1
network 195.19.15.0
auto-summary
no eigrp log-neighbor-changes
!
ip kerberos source-interface any
ip classless
no ip http server
r6#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
195.19.15.0/24 is variably subnetted, 7 subnets, 3 masks
D 195.19.15.144/28 [90/40665600] via 195.19.15.182, 00:01:29, Serial1
C 195.19.15.128/28 is directly connected, Loopback0
C 195.19.15.180/30 is directly connected, Serial1
C 195.19.15.176/30 is directly connected, Serial0
D 195.19.15.160/28 [90/40640000] via 195.19.15.182, 00:01:29, Serial1
D 195.19.15.64/26 [90/41024000] via 195.19.15.178, 00:01:29, Serial0
D 195.19.15.0/26 [90/40537600] via 195.19.15.182, 00:01:30, Serial1
r6#
hostname r2
!
logging rate-limit console 10 except errors
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
cns event-service server
!
!
!
!
!
interface Loopback0
ip address 195.19.15.161 255.255.255.240
!
interface Ethernet0
description conn to r4
ip address 195.19.15.1 255.255.255.192
!
interface Serial0
bandwidth 64
ip address 195.19.15.182 255.255.255.252
shutdown
no fair-queue
!
interface Serial1
description conn to r6
bandwidth 64
ip address 195.19.15.182 255.255.255.252
clockrate 64000
!
interface BRI0
no ip address
shutdown
!
router eigrp 1
network 195.19.15.0
auto-summary
no eigrp log-neighbor-changes
!
ip kerberos source-interface any
ip classless
no ip http server
r2#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
195.19.15.0/24 is variably subnetted, 7 subnets, 3 masks
D 195.19.15.144/28 [90/409600] via 195.19.15.2, 00:15:36, Ethernet0
D 195.19.15.128/28 [90/40640000] via 195.19.15.181, 00:14:03, Serial1
C 195.19.15.180/30 is directly connected, Serial1
D 195.19.15.176/30 [90/41024000] via 195.19.15.181, 00:14:03, Serial1
C 195.19.15.160/28 is directly connected, Loopback0
D 195.19.15.64/26 [90/793600] via 195.19.15.2, 00:14:01, Ethernet0
C 195.19.15.0/26 is directly connected, Ethernet0
This archive was generated by hypermail 2.1.4 : Sat Sep 07 2002 - 19:48:43 GMT-3