RE: BGP Problems

From: Darryl Munro (Darryl.Munro@xxxxxxxxxxxxxxxxxx)
Date: Sat Aug 10 2002 - 02:29:14 GMT-3


   
It appears to me that this BGP peer is being formed over a P2P connection
and the neighbor statements are to IP address's on directly connected
networks, hence there is no need for update-source command or ebgp-multihop
commands. There would seem to be something else wrong here and I can't see
what is wrong with the config.

Here is a really good link that may help you with some more troubleshooting
techniques.

http://www.cisco.com/networkers/nw01/pres/preso/RoutingandSwitchingTechnolog
ies/RST-310.pdf

Cheers

-----Original Message-----
From: Jim Brown [mailto:Jim.Brown@caselogic.com]
Sent: Saturday, 10 August 2002 2:51 p.m.
To: 'Jason Cash'; ccielab@groupstudy.com
Subject: RE: BGP Problems

Jason,

BGP by default doesn't use the loopback like OSPF. You must specify the
source address for your BGP advertisement with the 'update source' command
on the neighbor statement.

When advertising between EBGP peers you must also include the 'EBGP
multihop' statement on the neighbor to account for the additional hops to
the loopback address.

This statement is not necessary for advertisements between IBGP peers,
obviously this is why it is called EBGP multihop and not BGP multihop.

-----Original Message-----
From: Jason Cash [mailto:cash2001@swbell.net]
Sent: Friday, August 09, 2002 8:37 PM
To: ccielab@groupstudy.com
Subject: BGP Problems

Error msg recv'd on R1:
02:19:03: %BGP-3-NOTIFICATION: sent to neighbor 192.1.1.2 2/3 (BGP
identifier wrong)
4 bytes 02020202

Error msg recv'd on R2:
02:17:55: %BGP-3-NOTIFICATION: sent to neighbor 192.1.1.1 2/3 (BGP
identifier wrong)
4 bytes 02020202

Also, the 'sh ip bgp nei' from each router. For whatever reason, it is
not obtaining the loopback address(es)

r1#sh ip bgp nei
BGP neighbor is 192.1.1.2, remote AS 200, external link
  BGP version 4, remote router ID 0.0.0.0
  BGP state = Idle
  Last read 00:00:08, hold time is 180, keepalive interval is 60 seconds
  Received 8 messages, 3 notifications, 0 in queue
  Sent 8 messages, 5 notifications, 0 in queue
  Route refresh request: received 0, sent 0
  Default minimum time between advertisement runs is 30 seconds

 For address family: IPv4 Unicast
  BGP table version 1, neighbor version 0
  Index 1, Offset 0, Mask 0x2
  0 accepted prefixes consume 0 bytes
  Prefix advertised 0, suppressed 0, withdrawn 0
  Number of NLRIs in the update sent: max 0, min 0

  Connections established 0; dropped 0
  Last reset never
  No active TCP connection

r2#sh ip bgp nei
BGP neighbor is 192.1.1.1, remote AS 100, external link
  BGP version 4, remote router ID 0.0.0.0
  BGP state = Active
  Last read 00:00:08, hold time is 180, keepalive interval is 60 seconds
  Received 6 messages, 4 notifications, 0 in queue
  Sent 6 messages, 2 notifications, 0 in queue
  Route refresh request: received 0, sent 0
  Default minimum time between advertisement runs is 30 seconds

 For address family: IPv4 Unicast
  BGP table version 1, neighbor version 0
  Index 1, Offset 0, Mask 0x2
  0 accepted prefixes consume 0 bytes
  Prefix advertised 0, suppressed 0, withdrawn 0
  Number of NLRIs in the update sent: max 0, min 0

  Connections established 0; dropped 0
  Last reset never
  No active TCP connection

Configs: (Very simple)

R1
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname r1
!
logging rate-limit console 10 except errors
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
no ip dhcp-client network-discovery
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface Loopback1
 ip address 2.2.2.2 255.255.255.0
!
interface Loopback2
 no ip address
!
interface Loopback3
 no ip address
!
interface Loopback4
 no ip address
!
interface Ethernet0
 no ip address
 no ip route-cache
 no ip mroute-cache
!
interface Serial0
 ip address 192.1.1.1 255.255.255.0
 no ip route-cache
 no ip mroute-cache
!
interface Serial1
 ip address 193.1.1.1 255.255.255.0
 no ip route-cache
 no ip mroute-cache
!
router bgp 100
 bgp log-neighbor-changes
 neighbor 192.1.1.2 remote-as 200
!
ip kerberos source-interface any
ip classless
no ip http server
!
!
alias exec shi sh ip int brief
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
 transport input all
line vty 0 4
 login
!
end

R2
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname r2
!
logging rate-limit console 10 except errors
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
no ip dhcp-client network-discovery
!
!
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
 ip ospf network point-to-point
!
interface Ethernet0
 no ip address
 no ip route-cache
 no ip mroute-cache
!
interface Serial0
 ip address 192.1.1.2 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 clockrate 500000
!
interface Serial1
 ip address 194.1.1.2 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 clockrate 500000
!
router ospf 1
 log-adjacency-changes
 passive-interface Serial0
 network 192.1.1.0 0.0.0.255 area 0
 network 194.1.1.0 0.0.0.255 area 0
!
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 neighbor 192.1.1.1 remote-as 100
!
ip kerberos source-interface any
ip classless
no ip http server
!
!
alias exec shi sh ip int brief
!
line con 0
 exec-timeout 60 0
 transport input none
line aux 0
 transport input all
line vty 0 4
 login
!
end



This archive was generated by hypermail 2.1.4 : Sat Sep 07 2002 - 19:48:22 GMT-3