Bridging across serial intf not working

From: Lab Candidate (labccie@xxxxxxxxx)
Date: Sat Aug 03 2002 - 19:49:53 GMT-3


   
Hi group,

I'm stuck at this bridging over serial interfaces. real simple layout to test b
ridging:

r3-s0--------s0-r5-s1---------s1-r6

s0 and s1 on r5 are put in bridge-group 1, while r3 and r6 are acting as pc hos
ts to ping each
other. pings never got through, not even able to ping BVI 1 on r5.

But, if i replaced serial interfaces with ethernet intfs as below, r3 and r6 ar
e able to ping each
other and the BVI 2 of r5. what is going on here?

r3-e0--------f0-r5-f1---------f0-r6

r3:

interface Serial0/0
 ip address 1.1.1.3 255.0.0.0
 clock rate 64000
!
interface Ethernet0/0
 ip address 2.2.2.3 255.255.255.0
 half-duplex

r5:

interface Serial0/0
 no ip address
 bridge-group 1
!
interface Serial0/1
 no ip address
 bridge-group 1
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 bridge-group 2
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 bridge-group 2
!
interface BVI1
 ip address 1.1.1.5 255.0.0.0
!
interface BVI2
 ip address 2.2.2.5 255.255.255.0
!
bridge irb
!
bridge 1 protocol ieee
bridge 1 route ip
bridge 2 protocol ieee
bridge 2 route ip
!

r6:

interface FastEthernet0/0
 ip address 2.2.2.6 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 1.1.1.6 255.0.0.0
 clock rate 64000
!

========================================

r6#p 2.2.2.5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.5, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/4 ms
r6#p 2.2.2.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
r6#p 2.2.2.6

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
r6#p 1.1.1.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
r6#p 1.1.1.5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.5, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
r6#

====================================================
r3#ping 2.2.2.6

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
r3#ping 2.2.2.5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
r3#ping 1.1.1.6

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.6, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
r3#ping 1.1.1.5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.5, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
r3#



This archive was generated by hypermail 2.1.4 : Sat Sep 07 2002 - 19:48:15 GMT-3