RE: BGP - Suppressing Specific Routes

From: Bruce Williams (bruce@xxxxxxxxxxxxxxxxxxxxxx)
Date: Sun Jul 28 2002 - 22:31:40 GMT-3


   
The "aggregate address x.x.x.x y.y.y.y suppress-map map name" worked. Router
3 is eBGP peer with R5. R3 is advertising 3 loopbacks 200.200.200.0 /24,
200.200.201.0 /24 and 200.200.202.0 /24. I aggregated them into 200.200.0.0
255.255.0.0 and suppressed all of the three more specific routes with a
route map. I pasted R3's configs and the "sh ip bgp" from R5.

!
hostname r3
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
interface Loopback900
 ip address 200.200.200.1 255.255.255.0
 no ip directed-broadcast
!
interface Loopback901
 ip address 200.200.201.1 255.255.255.0
 no ip directed-broadcast
!
interface Loopback902
 ip address 200.200.202.1 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0
 ip address 172.16.50.3 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet1
 ip address 172.16.35.3 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
 no fair-queue
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
router bgp 1
 network 172.16.0.0
 network 200.200.200.0
 network 200.200.201.0
 network 200.200.202.0
 aggregate-address 200.200.0.0 255.255.0.0 suppress-map suppres
 neighbor 172.16.35.5 remote-as 2
!
ip classless
!
access-list 99 permit 200.200.200.0 0.0.0.255
access-list 99 permit 200.200.201.0 0.0.0.255
access-list 99 permit 200.200.202.0 0.0.0.255
route-map suppres permit 10
 match ip address 99
!
route-map suppres deny 20
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
!
end

r5#sh ip bgp
BGP table version is 4, local router ID is 172.16.35.5
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf Weight Path
*> 172.16.0.0 0.0.0.0 0 32768 i
* 172.16.35.3 0 0 1 i
*> 200.200.0.0/16 172.16.35.3 0 1 i
r5#

Bruce

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Ted McDermott
Sent: Sunday, July 28, 2002 4:23 PM
To: ccielab@groupstudy.com
Subject: BGP - Suppressing Specific Routes

In Cisco - BGP Case Studies Section 4
(http://www.cisco.com/warp/customer/459/16.html), the
author gives two solutions for suppressing the
specific local route 160.10.0.0 while advertising an
aggregate 160.0.0.0 route. Since an "aggregate
summary-only" command would not suppress the more
specific local route, the author gives two options,
both of which involve creating a static route to
null0. Neither of these would be acceptable if static
routes are not allowed. Is there any solution for this
which avoids static routes?



This archive was generated by hypermail 2.1.4 : Sat Sep 07 2002 - 19:36:47 GMT-3