From: Lekan Magbagbeola (lekkyl@xxxxxxxxxxx)
Date: Wed Jul 17 2002 - 06:16:58 GMT-3
Hi Umit,
I just tried this out on my testbed and it worked. Here is the sample
ouputs from my router (R2) bridging IP traffic between two VLANs 1 and
300. Router R14's ethernet interface is in VLAN 1 while router R1 in VLAN
300.
Follow the solutions as outlined before and it should work. Make sure you
check on the switch port to make sure that your router doing the bridging
is in trunking mode.
I hope this helps.
Lekan
*****************
R1#ping 150.10.20.14
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.10.20.14, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/6/8 ms
******************
R2#wr ter
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
!
ip subnet-zero
no ip domain-lookup
ipx routing 00e0.b063.f945
ipx internal-network 2
!
voice-port 2/0/0
!
voice-port 2/0/1
!
bridge irb
!
!
!
interface FastEthernet1/0
no ip address
no ip directed-broadcast
!
interface FastEthernet1/0.1
encapsulation isl 1
no ip redirects
no ip directed-broadcast
bridge-group 1
!
interface FastEthernet1/0.300
encapsulation isl 300
no ip redirects
no ip directed-broadcast
bridge-group 1
!
interface BVI1
no ip address
no ip directed-broadcast
!
ip classless
!
!
bridge 1 protocol ieee
!
line con 0
exec-timeout 0 0
logging synchronous
transport input none
line aux 0
line vty 0 4
!
end
R2#
*****************
R14#wr ter
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R14
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
interface Ethernet0
ip address 150.10.20.14 255.255.255.128
no ip directed-broadcast
!
!
ip classless
!
bridge 1 protocol ieee
!
line con 0
exec-timeout 0 0
logging synchronous
transport input none
line aux 0
line vty 0 4
****************
R1#wr ter
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
!
ip subnet-zero
no ip domain-lookup
!
!
interface Loopback0
ip address 150.10.1.1 255.255.255.0
no ip directed-broadcast
!
interface Ethernet0
ip address 150.10.20.1 255.255.255.128
no ip directed-broadcast
!
bridge 1 protocol ieee
!
line con 0
exec-timeout 0 0
logging synchronous
transport input none
line aux 0
line vty 0 4
!
end
>From: \mit A~kan (TK-Network Gvz|mleri) >Reply-To: \mit A~kan
(TK-Network Gvz|mleri) >To: "'Lekan Magbagbeola'" >CC: "Ccie (E-mail)"
>Subject: RE: bridging on a trunk >Date: Wed, 17 Jul 2002 11:39:25 +0300
> >you can try this on your lab, >it is not working at fastethernet, i
tried with different 3 versions. >if your config work, please send your
IOS version to me. > >-----Original Message----- >From: Lekan Magbagbeola
[mailto:lekkyl@hotmail.com] >Sent: Wednesday, July 17, 2002 11:25 >To:
umit.askan@probil.com.tr >Cc: ccielab@groupstudy.com >Subject: RE:
bridging on a trunk > > > >Umit, > >I'm almost sure that your interface
is not a FasEthernet interface, >because I don't see why the suggested
solutions would not work. This is >evident from your posted config. The
solutions I suggested would work on >fastethernet interfaces only. Can
you confirm this? > >Per the Ip issue, your BVI does not need an IP
address if you only want >to bridge IP traffic between the VLANs, but
make sure the sub-interfaces >are in the same bridge group and that the
vlan# in the "encapsulation >isl vlan#" corresponds to the VLANs that you
already created on your >switch. > >Lekan > > > > >From: \mit A~kan
(TK-Network Gvz|mleri) > >To: 'Lekan Magbagbeola' > >CC: "Ccie (E-mail)"
> >Subject: RE: bridging on a trunk > >Date: Wed, 17 Jul 2002 11:16:39
+0300 > > > >ip is only for the otherside players who is coming with
routing to bvi, > > >beidging plays in bvi between subinterfaces > >but i
tried your suggestiond before, nothing changed. > > > >-----Original
Message----- > >From: Lekan Magbagbeola [mailto:lekkyl@hotmail.com] >
>Sent: Wednesday, July 17, 2002 10:57 > >To: umit.askan@probil.com.tr >
>Cc: ccielab@groupstudy.com > >Subject: RE: bridging on a trunk > > > > >
> > >First Observation, isl works on Fastethernet interfaces i.e 100MB
link. > > >Your posted config below indicates a 10MB interface. You might
want to > >double-check this again. > > > >Secondly, since all you were
trying to do is to bridge traffic between > >your VLANs, you need not
assign an IP Address to the BVI interface. > >Remember that when "irb" is
configured, it bridges all traffic by > >default, you might want to
remove "bridge 1 route ip ". Again, I assume > > >that you just wanted to
bridge your traffic abetween the VLANs and not > >route. > > > >Check the
port status on the switch to make sure that it is in > >"connected state"
and negoatiated 100 MG. As trivial as they sound, > >these might be the
cause of your headache. > > > >Does this info helps? > > > >Lekan > > > >
> > > > > > >From: \mit A~kan (TK-Network Gvz|mleri) > > >To: 'Lekan
Magbagbeola' > > >CC: "Ccie (E-mail)" > > >Subject: RE: bridging on a
trunk > > >Date: Wed, 17 Jul 2002 10:47:50 +0300 > > > > > >Hi, > > >I
tried that. it is working with two ethernet interfaces, but not at > >
>suninterfaces. look ... > > > > > >bridge irb > > >bridge 1 protocol
ieee > > >bridge 1 route ip ------------- for bvi to outside
---------------- > > > > > >int eth 0.1 > > > encapsulation isl 10 > > >
bridge-group 1 > > >int eth 0.2 > > > encapsulation isl 20 > > >
bridge-group 1 > > >int bvi 1 > > > ip add 1.1.1.1 255.255.255.0 > > > >
> >think > > >ip address of router 1 on vlan 10 ------ 1.1.1.2 /24 > >
>ip address of router 2 on vlan 20 ------ 1.1.1.3 /24 > > > > > >1.1.1.1
can go 1.1.1.2 and 1.1.1.3 but 1.1.1.2 can't to 1.1.1.3..... > >
>otherside routers who is coming to 1.1.1.1 can go to the .2 and .3 > > >
> > >-----Original Message----- > > >From: Lekan Magbagbeola
[mailto:lekkyl@hotmail.com] > > >Sent: Wednesday, July 17, 2002 10:15 > >
>To: umit.askan@probil.com.tr; ccielab@groupstudy.com > > >Subject: Re:
bridging on a trunk > > > > > > > > > > > >Umit, > > > > > >Using "irb"
should do the magic. If your router interface is a > > >fastethernet
interface, create a subinterface for each VLAN by using > >
>"encapsulation isl >bridge group. Configure irb, depending on what >
>other things you are > > >trying to do, you do not necessarily have to
assign an IP address to > >the > > >BVI interface. Try this, it should
work. If you still have problem, >how > > > > >about pasting your configs
online here. > > > > > >Lekan > > > > > > > > > > > > > > > > > > >From:
\mit A~kan (TK-Network Gvz|mleri) > > > >Reply-To: \mit A~kan (TK-Network
Gvz|mleri) > > > >To: "Ccie (E-mail)" > > > >Subject: bridging on a trunk
> > > >Date: Wed, 17 Jul 2002 09:35:09 +0300 > > > > > > > >Hi all, > > >
> > > > >I have got a question about bridging. if you have a router whish
>has > > > >only one ethernet interface and you must bridge between two
>different > > > > > >vlans which is coming from that trunk, how can you
run it ? I tried >a > > > > > >lot, but it is not working on
subinterfaces. maybe it is a bug or >it > >is > > > > > > >not supported.
> > > > > > > >Best Regards > > > >umit > > > > > > > >Umit Askan > > >
>Consulting Network Engineer > > > >CCNP, CCDP, CCNP-Security, CCNP-Voice
Access > > > > > > > > > Probil Bilgi Islem Destek ve Danismanlik San. ve
Tic. A.S. > > > >Eski Buyukdere Caddesi Dilaver Sokak No.4 > > >
>Otosanayi 4. Levent 80660 Istanbul > > > > > > > >Tel: +90 (212) 317 61
00 (219) > > > >Direkt : +90 (212) 317 62 19 > > > >Faks: +90 (212) 325
55 15 > > > >E-Mail: umit.askan@probil.com.tr > > > >Web:
www.probil.com.tr > > >
This archive was generated by hypermail 2.1.4 : Sat Sep 07 2002 - 19:36:34 GMT-3