Re: Sync. problem in BGP

From: Hunt Lee (ciscoforme3@xxxxxxxxxxxx)
Date: Mon Jul 01 2002 - 10:16:14 GMT-3


   
Hello Carlo,

So do you mean that each OSPF routing domain has it's own Process ID
& Area number:-

150.150.150.0/24---RTA ---RTB ---RTD---RTF
                           | |
                          RTC RTE

RTA - RTB : OSPF Process 3, OSPF Area 3
RTB - RTC : OSPF Process 1, OSPF Area 1
RTB - RTD : OSPF Process 5, OSPF Area 0
RTD - RTE : OSPF Process 2, OSPF Area 2

Is this correct?

All seems fine, except that RouterC can't sync. with most of it's BGP
routes:

*Mar 1 02:17:17.251 UTC: BGP: no valid path for 150.150.150.0/24
*Mar 1 02:17:17.251 UTC: BGP: no valid path for 193.16.0.0/30
*Mar 1 02:17:17.255 UTC: BGP: no valid path for 193.16.0.8/30

RouterC#sh ip bgp
BGP table version is 4, local router ID is 172.16.0.2
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf Weight Path
* i150.150.150.0/24 193.16.0.2 0 100 0 (65530) i
*>i172.16.0.0/30 172.16.0.1 0 100 0 i
* i193.16.0.0/30 172.16.0.1 0 100 0 i
* i193.16.0.8/30 172.16.0.18 0 100 0 (65532) i
RouterC#

RouterC#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B -
BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * -
candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     172.16.0.0/30 is subnetted, 3 subnets
O E2 172.16.0.16 [110/64] via 172.16.0.1, 00:53:41, Serial1
O E2 172.16.0.12 [110/64] via 172.16.0.1, 00:53:26, Serial1
C 172.16.0.0 is directly connected, Serial1
     193.16.0.0/30 is subnetted, 1 subnets
O E2 193.16.0.0 [110/10] via 172.16.0.1, 01:38:59, Serial1
RouterC#

And when I check the OSPF Router ID for RTB, it seems ok to me :)

RouterB#sh ip ospf interface
Ethernet0 is up, line protocol is up
  Internet Address 193.16.0.1/30, Area 3
  Process ID 3, Router ID 172.16.0.1, Network Type BROADCAST, Cost:
10
  Transmit Delay is 1 sec, State BDR, Priority 1
  Designated Router (ID) 150.150.150.1, Interface address 193.16.0.2
  Backup Designated router (ID) 172.16.0.1, Interface address
193.16.0.1
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit
5
    Hello due in 00:00:04
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 2, maximum is 4
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 150.150.150.1 (Designated Router)
  Suppress hello for 0 neighbor(s)
Serial0 is up, line protocol is up
  Internet Address 172.16.0.1/30, Area 1
  Process ID 1, Router ID 172.16.0.17, Network Type POINT_TO_POINT,
Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit
5
    Hello due in 00:00:06
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 3, maximum is 5
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 172.16.0.2
  Suppress hello for 0 neighbor(s)
Serial1 is up, line protocol is up
  Internet Address 172.16.0.17/30, Area 0
  Process ID 5, Router ID 193.16.0.1, Network Type POINT_TO_POINT,
Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit
5
    Hello due in 00:00:04
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 3
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 193.16.0.9
  Suppress hello for 0 neighbor(s)

hostname RouterA
!
!
interface Loopback0
 ip address 150.150.150.1 255.255.255.0
!
interface Ethernet0
 description Eth to RouterB
 ip address 193.16.0.2 255.255.255.252
!
router ospf 3
 log-adjacency-changes
 network 193.16.0.0 0.0.0.7 area 3
!
router bgp 65530
 bgp log-neighbor-changes
 bgp confederation identifier 1
 bgp confederation peers 65531
 network 150.150.150.0 mask 255.255.255.0
 neighbor 193.16.0.1 remote-as 65531
 no auto-summary

-------------------------------------------------

hostname RouterB
!
!
interface Ethernet0
 description Eth to RouterA
 ip address 193.16.0.1 255.255.255.252
!
interface Serial0
 description Serial to RouterC
 ip address 172.16.0.1 255.255.255.252
 clockrate 64000
!
interface Serial1
 description Serial to RouterD
 ip address 172.16.0.17 255.255.255.252
!
router ospf 5
 log-adjacency-changes
 redistribute ospf 1 subnets
 redistribute ospf 3 subnets
 network 172.16.0.16 0.0.0.3 area 0
!
router ospf 1
 log-adjacency-changes
 redistribute ospf 5 subnets
 redistribute ospf 3 subnets
 network 172.16.0.0 0.0.0.3 area 1
!
router ospf 3
 log-adjacency-changes
 redistribute ospf 5 subnets
 redistribute ospf 1 subnets
 network 193.16.0.0 0.0.0.3 area 3
!
router bgp 65531
 bgp log-neighbor-changes
 bgp confederation identifier 1
 bgp confederation peers 65530 65532
 network 172.16.0.0 mask 255.255.255.252
 network 193.16.0.0 mask 255.255.255.252
 neighbor 172.16.0.2 remote-as 65531
 neighbor 172.16.0.18 remote-as 65532
 neighbor 193.16.0.2 remote-as 65530
 no auto-summary
!
-------------------------------------------------------------------

RTC

interface Serial1
 description Serial to RouterB
 ip address 172.16.0.2 255.255.255.252
 no ip directed-broadcast
!
router ospf 1
 network 172.16.0.0 0.0.0.3 area 1
!
router bgp 65531
 bgp confederation identifier 1
 neighbor 172.16.0.1 remote-as 65531

--------------------------------------------------------------------

RTD

!
interface Ethernet0
 description Eth to RouterF
 ip address 193.16.0.9 255.255.255.252
 no ip directed-broadcast
!
interface Serial0
 description Serial to RouterE
 ip address 172.16.0.14 255.255.255.252
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
 clockrate 64000
!
interface Serial1
 description Serial to RouterB
 ip address 172.16.0.18 255.255.255.252
 no ip directed-broadcast
 clockrate 64000

router ospf 5
 redistribute ospf 2 subnets
 network 172.16.0.16 0.0.0.3 area 0
!
router ospf 2
 redistribute ospf 5 subnets
 network 172.16.0.12 0.0.0.3 area 2
!
router bgp 65532
 bgp log-neighbor-changes
 bgp confederation identifier 1
 bgp confederation peers 65531
 network 193.16.0.8 mask 255.255.255.252
 neighbor 172.16.0.13 remote-as 65532
 neighbor 172.16.0.17 remote-as 65531
 neighbor 193.16.0.10 remote-as 2
 no auto-summary
!

---------------------------------------------------------------

RTE

interface Serial0
 description Serial to RouterD
 ip address 172.16.0.13 255.255.255.252
 no fair-queue
!
router ospf 2
 network 172.16.0.12 0.0.0.3 area 2
!
router bgp 65532
 bgp confederation identifier 1
 neighbor 172.16.0.14 remote-as 65532
 no auto-summary

----------------------------------------------------------------

RTF

interface Ethernet0
 description Eth to RouterD
 ip address 193.16.0.10 255.255.255.252
 no ip mroute-cache
 no ip route-cache
!
!
router bgp 2
 neighbor 193.16.0.9 remote-as 1
 no auto-summary

So what's wrong?? Any ideas will be greatly apprecatied =^o^=

Thanks!!

Regards,
Hunt

Well, that's not what I'm saying, but yes, if that were the case,
then
that particular route would show on RTC. But I guess some other
routes
could vanish now from RTE. (You can not have the same router ID for
two different routers...)

Another way of doing it is having one OSPF routing domain for each
confed sub-as, and another for inter-sub-as routing, and
redistributing
between them. All those are hacks for lab requirements, not real
world alternatives, of course :-)

Michael Popovich wrote:
>
> So you would say that RTB's BGP ID needs to be the same as RTD's
OSPF
> ID?
>
> I am unclear how 172.16.0.12 is getting into OSPF. You said it was
> advertised by RTD in BGP. Can I assume it is also advertised in
OSPF
on
> the same router?
>
> MP
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On
Behalf
Of
> Carlos G Mendioroz
> Sent: Tuesday, June 25, 2002 6:07 AM
> To: Hunt Lee
> Cc: ccielab@groupstudy.com
> Subject: Re: Sync. problem in BGP
>
> In a nutshell, iBGP sync when the IGP is OSPF requires not only
that
> the received route is already in the FIB (routing table) but also
> that the OSPF originator's ID is the same as the iBGP neighbour's
ID.
>
> This creates problems especially with route reflectors, but also
> when OSPF crosses AS borthers like in confeds.
>
> Hunt Lee wrote:
> >
> > Okay folks, I'm back as I have bummed into another problem last
nite
> > =)
> >
> > 150.150.150.0/24---RTA ---RTB ---RTD---RTF
> > | |
> > RTC RTE
> >
> > RTA, B, C, D, & E are in a Confederation called AS 1, in which:-
> >
> > RTA is sub-AS 65530
> > RTB & RTC are both in sub-AS 65531
> > RTD & RTE are both in sub-AS 65532
> >
> > RTF is in AS 2
> >
> > RTB, C, D & E are running OSPF as IGP. And OSPF is being
> > redistributed into BGP at RTB.
> >
> > The network i172.16.0.12/30 is being advertised into BGP by BGP
> > "network" command on RTD. i172.16.0.13 & .14 are the interfaces
IP
> > for RTD & RTE.
> >
> > Ok, here is the thing. RTC just can't see this link via BGP (it
kept
> > on saying it's not sync), even though it is reachable via OSPF.
With
> > OSPF, shouldn't BGP think that it is sync, and installs it as
best
> > route?
> >
> > Am I missing something here?
> >
> > RouterC#sh ip bgp
> > BGP table version is 8, local router ID is 172.16.0.2
> > Status codes: s suppressed, d damped, h history, * valid, > best,
i
-
> > internal
> > Origin codes: i - IGP, e - EGP, ? - incomplete
> >
> > Network Next Hop Metric LocPrf Weight Path
> > * i150.150.150.0/24 193.16.0.2 0 100 0
(65530)
i
> > *>i172.16.0.0/30 172.16.0.1 0 100 0 ?
> > * i172.16.0.12/30 172.16.0.18 30 100 0 ?
> > *>i172.16.0.16/30 172.16.0.1 0 100 0 ?
> > *>i193.16.0.0/30 172.16.0.1 0 100 0 ?
> > * i193.16.0.8/30 172.16.0.18 0 100 0
(65532)
i
> >
> > RouterC#sh ip bgp 172.16.0.12/30
> > BGP routing table entry for 172.16.0.12/30, version 0
> > Paths: (1 available, no best path)
> > Not advertised to any peer
> > Local
> > 172.16.0.18 (metric 128) from 172.16.0.1 (193.16.0.1)
> > Origin incomplete, metric 30, localpref 100, valid,
internal,
> > not synchronized, ref 2
> >
> > RouterC#sh ip route
> > Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile,
B
-
> > BGP
> > D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter
area
> > N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external
type
2
> > E1 - OSPF external type 1, E2 - OSPF external type 2, E -
EGP
> > i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * -
> > candidate default U - per-user static route, o - ODR
> >
> > Gateway of last resort is not set
> >
> > 172.16.0.0/30 is subnetted, 3 subnets
> > O 172.16.0.16 [110/128] via 172.16.0.1, 01:43:32, Serial1
> > O 172.16.0.12 [110/192] via 172.16.0.1, 01:43:32, Serial1
<--
> > but it is reachable via OSPF ??
> > C 172.16.0.0 is directly connected, Serial1
> > 193.16.0.0/30 is subnetted, 1 subnets
> > O 193.16.0.0 [110/74] via 172.16.0.1, 01:43:32, Serial1
> > RouterC#
> >
> > Thanks all!
> >
> > H.
> >
> > http://www.sold.com.au - SOLD.com.au
> > - Find yourself a bargain!



This archive was generated by hypermail 2.1.4 : Sat Sep 07 2002 - 19:36:16 GMT-3