From: David Luu (wicked01@xxxxxxxxxxxxx)
Date: Thu May 23 2002 - 17:00:36 GMT-3
passive-interface for bri0/dialer1 for igrp, your igrp now is triggering
the line with updates
At 09:29 AM 5/23/2002 -0700, Jeongwoo Park wrote:
>Here is the entire config on R3 and R5
>For some reason, R5 brings the isdn line up and R3 drop it.
>
>
>R3#wr t
>Building configuration...
>Current configuration:
>!
>version 12.0
>service timestamps debug uptime
>service timestamps log uptime
>no service password-encryption
>!
>hostname R3
>!
>enable password cisco
>!
>username R5 password 0 cisco
>ip subnet-zero
>no ip domain-lookup
>isdn switch-type basic-ni
>!
>!
>!
>interface Ethernet0
>ip address 170.100.43.3 255.255.255.0
>no ip directed-broadcast
>ip ospf interface-retry 0
>!
>interface Serial0
>bandwidth 128
>ip address 170.100.52.3 255.255.255.0
>no ip directed-broadcast
>encapsulation frame-relay
>ip ospf interface-retry 0
>no ip mroute-cache
>shutdown
>no fair-queue
>frame-relay map ip 170.100.52.2 103 broadcast
>frame-relay map ip 170.100.52.5 103 broadcast
>!
>interface Serial1
>bandwidth 128
>ip address 170.100.44.1 255.255.255.252
>no ip directed-broadcast
>ip ospf interface-retry 0
>shutdown
>!
>interface BRI0
>no ip address
>no ip directed-broadcast
>encapsulation ppp
>ip ospf interface-retry 0
>dialer pool-member 1
>isdn switch-type basic-ni
>isdn spid1 0835866101 8358661
>isdn spid2 0835866301 8358663
>no peer neighbor-route
>ppp authentication chap
>ppp multilink
>!
>interface Dialer1
>ip address 170.100.2.6 255.255.255.0
>no ip directed-broadcast
>encapsulation ppp
>ip ospf interface-retry 0
>ip ospf demand-circuit
>dialer remote-name 5
>dialer string 8358662
>dialer string 8358664
>dialer pool 1
>no peer neighbor-route
>ppp authentication chap
>ppp multilink
>!
>router ospf 1
>area 2 virtual-link 170.100.200.6
>network 170.100.2.0 0.0.0.3 area 0
>network 170.100.43.0 0.0.0.255 area 3
>network 170.100.44.0 0.0.0.3 area 2
>network 170.100.52.0 0.0.0.255 area 0
>!
>ip classless
>!
>access-list 100 deny ospf any any
>access-list 100 permit ip any any
>dialer-list 1 protocol ip list 100
>!
>!
>line con 0
>exec-timeout 0 0
>transport input none
>line aux 0
>line vty 0 4
>login
>!
>end
>R3#
>
>R5#wr t
>Building configuration...
>Current configuration:
>!
>version 12.0
>service timestamps debug uptime
>service timestamps log uptime
>no service password-encryption
>!
>hostname R5
>!
>enable password cisco
>!
>username R3 password 0 cisco
>ip subnet-zero
>no ip domain-lookup
>isdn switch-type basic-ni
>!
>!
>!
>interface Ethernet0
>ip address 170.100.42.17 255.255.255.240
>no ip directed-broadcast
>ip nat inside
>!
>interface Serial0
>no ip address
>no ip directed-broadcast
>encapsulation frame-relay
>no ip mroute-cache
>no fair-queue
>!
>interface Serial0.1 multipoint
>ip address 170.100.51.35 255.255.255.0
>no ip directed-broadcast
>ip nat outside
>frame-relay map ip 170.100.51.33 204 broadcast
>!
>interface Serial0.2 multipoint
>bandwidth 128
>ip address 170.100.52.35 255.255.255.0
>no ip directed-broadcast
>ip nat outside
>ip ospf network point-to-multipoint
>ip ospf interface-retry 0
>ip ospf hello-interval 10
>frame-relay map ip 170.100.52.32 202 broadcast
>frame-relay map ip 170.100.52.33 203 broadcast
>!
>interface Serial1
>no ip address
>no ip directed-broadcast
>shutdown
>!
>interface BRI0
>no ip address
>no ip directed-broadcast
>encapsulation ppp
>dialer pool-member 1
>isdn switch-type basic-ni
>isdn spid1 0835866201 8358662
>isdn spid2 0835866401 8358664
>ppp authentication chap
>ppp multilink
>!
>interface Dialer1
>ip address 170.100.2.1 255.255.255.0
>no ip directed-broadcast
>encapsulation ppp
>ip ospf interface-retry 0
>ip ospf demand-circuit
>dialer remote-name R3
>dialer string 8358661
>dialer string 8358663
>dialer pool 1
>dialer-group 1
>no peer neighbor-route
>ppp authentication chap
>ppp multilink
>!
>router ospf 1
>redistribute igrp 2 subnets
>redistribute rip subnets
>network 170.100.2.4 0.0.0.3 area 0
>network 170.100.52.0 0.0.0.255 area 0
>!
>router rip
>version 2
>redistribute ospf 1
>redistribute igrp 2
>passive-interface Dialer1
>passive-interface Serial0.1
>passive-interface Serial0.2
>network 170.100.0.0
>default-metric 2
>no auto-summary
>!
>router igrp 2
>redistribute ospf 1
>redistribute rip
>passive-interface Ethernet0
>passive-interface Serial0.2
>network 170.100.0.0
>default-metric 128000 100 255 1 1500
>!
>ip nat inside source list 1 interface Ethernet0 overload
>ip classless
>!
>access-list 100 deny ospf any any
>access-list 100 deny ip any host 224.0.0.9
>access-list 100 permit ip any any
>dialer-list 1 protocol ip list 100
>!
>!
>line con 0
>exec-timeout 0 0
>transport input none
>line aux 0
>line vty 0 4
>!
>end
>R5#
>
>-----Original Message-----
>From: Joon Cho - StarBand - MRT [mailto:Joon.Cho@StarBand.com]
>Sent: Thursday, May 23, 2002 8:24 AM
>To: Jeongwoo Park; David Luu; ccielab@groupstudy.com
>Subject: RE: ISDN flapping !!
>
>Hello JP,
>
>I see couple of things missing on your configuration.
>Under R3's int dialer 1, add "dialer remote-name R5", and "dialer pool
>1".
>Since you didn't have dialer remote-name R5, ppp authentication was
>failing.
>
>Joon
>
>
>-----Original Message-----
>From: Jeongwoo Park [mailto:jpark@wams.com]
>Sent: Thursday, May 23, 2002 1:09 AM
>To: 'David Luu'; Jeongwoo Park; 'ccielab@groupstudy.com'
>Subject: RE: ISDN flapping !!
>Importance: High
>
>
>In the below output, it is disconnected from R3.
>Do you have any idea what at R3 would disconnect the call as soon as
>line is
>up. The call lasted only one second.
>
>JP
>
>-----Original Message-----
>From: David Luu [mailto:wicked01@ix.netcom.com]
>Sent: Wednesday, May 22, 2002 9:40 PM
>To: Jeongwoo Park; 'ccielab@groupstudy.com'
>Subject: RE: ISDN flapping !!
>
>do a passive-interface on the bri under RIPv2
>
>At 08:51 PM 5/22/2002 -0700, Jeongwoo Park wrote:
> >Yes
> >-----Original Message-----
> >From: David Luu [mailto:wicked01@ix.netcom.com]
> >Sent: Wednesday, May 22, 2002 8:34 PM
> >To: Jeongwoo Park; 'ccielab@groupstudy.com'
> >Subject: RE: ISDN flapping !!
> >
> >ah i see whats happening now....
> >if you look at the destination ip for the dial cause, the ip is
>224.0.0.9,
> >which is the multicast address for RIPv2...
> >and if you look at your previous debug you will notice that the line
>was
> >brought up around every 30 seconds, which is the update interval for
> >RIPv2...
> >
> >are you running RIPv2 on the router?
> >
> >At 08:21 PM 5/22/2002 -0700, Jeongwoo Park wrote:
> > >This is what I got after deb dialer
> > >It is still flapping
> > >
> > >JP
> > >R5#
> > >1d07h: BR0 DDR: rotor dialout [priority]
> > >1d07h: BR0 DDR: Dialing cause ip (s=170.100.2.1, d=224.0.0.9)
> > >1d07h: BR0 DDR: Attempting to dial 8358661
> > >1d07h: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
> > >1d07h: %DIALER-6-BIND: Interface BR0:1 bound to profile Di1
> > >1d07h: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 8358661
> > >1d07h: %ISDN-6-DISCONNECT: Interface BRI0:1 disconnected from
>8358661
>R3,
> > >call
> > >lasted 1 seconds
> > >1d07h: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down
> > >1d07h: BR0 DDR: has total 2 call(s), dial_out 0, dial_in 0
> > >1d07h: %DIALER-6-UNBIND: Interface BR0:1 unbound from profile Di1
> > >1d07h: BR0:1 DDR: disconnecting call
> > >
> > >-----Original Message-----
> > >From: David Luu [mailto:wicked01@ix.netcom.com]
> > >Sent: Wednesday, May 22, 2002 8:13 PM
> > >To: Jeongwoo Park; 'ccielab@groupstudy.com'
> > >Subject: Re: ISDN flapping !!
> > >
> > >do a show dialer, and see what the reason is for the line being
>brought
>up
> > >
> > >At 07:11 PM 5/22/2002 -0700, Jeongwoo Park wrote:
> > > >Hi guys, Help !!
> > > >Look at this logs
> > > >00:19:35: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
> > > >00:19:35: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to
>8358662
> > > >00:19:36: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down
> > > >00:20:03: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
> > > >00:20:03: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to
>8358662
> > > >00:20:04: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down
> > > >00:20:31: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
> > > >00:20:31: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to
>8358662
> > > >00:20:31: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down
> > > >
> > > >Yeah, definitely idsn line is flapping.
> > > >Here is my config
> > > >R3---------R5
> > > >
> > > >R3;
> > > >Username R5 password 0 cisco
> > > >
> > > >interface BRI0
> > > >no ip address
> > > >no ip directed-broadcast
> > > >encapsulation ppp
> > > >ip ospf interface-retry 0
> > > >ip ospf demand-circuit
> > > >dialer pool-member 1
> > > >isdn switch-type basic-ni
> > > >isdn spid1 0835866101 8358661
> > > >isdn spid2 0835866301 8358663
> > > >ppp authentication chap
> > > >ppp multilink
> > > >!
> > > >interface Dialer1
> > > >ip address 170.100.2.6 255.255.255.0
> > > >no ip directed-broadcast
> > > >encapsulation ppp
> > > >ip ospf interface-retry 0
> > > >dialer in-band
> > > >dialer string 8358662
> > > >dialer string 8358664
> > > >ppp authentication chap
> > > >ppp multilink
> > > >!
> > > >dialer-list 1 protocol ip permit
> > > >
> > > >R5;
> > > >Username R3 password 0 cisco
> > > >
> > > >interface BRI0
> > > >no ip address
> > > >no ip directed-broadcast
> > > >encapsulation ppp
> > > >dialer pool-member 1
> > > >isdn switch-type basic-ni
> > > >isdn spid1 0835866201 8358662
> > > >isdn spid2 0835866401 8358664
> > > >ppp authentication chap
> > > >ppp multilink
> > > >!
> > > >interface Dialer1
> > > >ip address 170.100.2.1 255.255.255.0
> > > >no ip directed-broadcast
> > > >encapsulation ppp
> > > >dialer remote-name R3
> > > >dialer string 8358661
> > > >dialer string 8358663
> > > >dialer pool 1
> > > >dialer-group 1
> > > >ppp authentication chap
> > > >ppp multilink
> > > >!
> > > >dialer-list 1 ip protocol permit
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:59:07 GMT-3