RE: BGP

From: Lupi, Guy (Guy.Lupi@xxxxxxxxxxxxx)
Date: Thu May 23 2002 - 12:03:44 GMT-3


   
Try removing the network statement, removing the route to null 0, putting
the network statement back in, and doing a hard reset on the bgp.

-----Original Message-----
From: SHARMA,MOHIT (HP-Germany,ex1) [mailto:mohit_sharma@hp.com]
Sent: Thursday, May 23, 2002 10:47 AM
To: 'Erhan Kurt'; Song Mu; Dang Quang Minh; 'Yan-Hui Liang';
ccielab@groupstudy.com
Subject: RE: BGP

Hi,

I have tried using -network 172.16.1.0 mask 255.255.255.128
network 172.16.1.0 mask 255.255.255.0

Heres the output.
giggles#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname giggles
!
!
ip subnet-zero
!
!
!
interface Loopback0
 ip address 172.16.1.7 255.255.255.128
 no ip directed-broadcast
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial0
 ip address 172.16.100.10 255.255.255.252
 no ip directed-broadcast
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0
 no ip address
 no ip directed-broadcast
 shutdown
!
router bgp 300
 no synchronization
 network 172.16.1.7 mask 255.255.255.128
 neighbor 172.16.100.9 remote-as 700
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.100.9
ip route 172.16.1.7 255.255.255.255 Null0
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
end

sh ip ro-
Gateway of last resort is 172.16.100.9 to network 0.0.0.0

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.1.0/25 is directly connected, Loopback0
C 172.16.100.8/30 is directly connected, Serial0
S* 0.0.0.0/0 [1/0] via 172.16.100.9

giggles#sh ip bgp
giggles#

giggles#sh ip bgp s
BGP router identifier 172.16.1.7, local AS number 300
BGP table version is 1, main routing table version 1

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down
State/PfxRcd

172.16.100.9 4 700 1842 1855 1 0 0 01:23:09 0

giggles#sh ip bgp neighbors 172.16.100.9 advertised-routes
giggles#

-----Original Message-----
From: Erhan Kurt [mailto:kurt@superonline.net]
Sent: Donnerstag, 23. Mai 2002 15:52
To: SHARMA,MOHIT (HP-Germany,ex1); Erhan Kurt; Song Mu; Dang Quang Minh;
'Yan-Hui Liang'; ccielab@groupstudy.com
Subject: RE: BGP

Keep trying.. You have to use given subnet on loopbacks :)

Send your last sh ru, sh ip rou, sh ip bgp su, sh ip bgp

-----Original Message-----
From: SHARMA,MOHIT (HP-Germany,ex1) [mailto:mohit_sharma@hp.com]
Sent: 23 Mayis 2002 Persembe 16:51
To: 'Erhan Kurt'; Song Mu; Dang Quang Minh; 'Yan-Hui Liang';
ccielab@groupstudy.com
Subject: RE: BGP

So guys I am back with the same problem.
I have tried quite a number of combinations of network statements, but it
either does not advertise anything or just advertises the whole 172.16.0.0
subnet.

I guess it is then not such a good idea to use a bigger subnet for loopback
interfaces, so I will use 255.255.255.255 subnet for my loopbacks.

Smiles,

Mohit.
-----Original Message-----
From: Erhan Kurt [mailto:kurt@superonline.net]
Sent: Donnerstag, 23. Mai 2002 15:21
To: Song Mu; Dang Quang Minh; 'SHARMA,MOHIT (HP-Germany,ex1)'; 'Yan-Hui
Liang'; ccielab@groupstudy.com
Subject: RE: BGP

You may not use any static routes unless specifically said.

Cheers,
Erhan

-----Original Message-----
From: Song Mu [mailto:songmu@yahoo.com]
Sent: 23 Mayis 2002 Persembe 15:47
To: Dang Quang Minh; 'SHARMA,MOHIT (HP-Germany,ex1)'; 'Yan-Hui Liang';
ccielab@groupstudy.com
Subject: RE: BGP

I suspect that it because the network you try to advertise is not in your
routing table. Try use show ip route on the local router. If you can not
see the network, then add a static route: ip route 172.16.1.7
255.255.255.128 null0 use show ip route to verify it appeares on the routing
table, then you would see it from the remote.

Hope this will solve your problem.

Song

--- Dang Quang Minh <minhdq@saigonctt.com> wrote:
> Try 'neighbor ebgp-multihop 2'
>
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf
> Of SHARMA,MOHIT (HP-Germany,ex1)
> Sent: Thursday, May 23, 2002 5:49 PM
> To: 'Yan-Hui Liang'; ccielab@groupstudy.com
> Subject: RE: BGP
>
> HI All,
>
> Thanx for your inputs.
>
> I have disbaled both auto summary and synchronisation on the routers.
> After giving the command network 172.16.1.5 mask 255.255.255.128 I
> still do not see this advertised.
>
> hostname giggles
> !
> !
> ip subnet-zero
> !
> !
> !
> interface Loopback0
> ip address 172.16.1.7 255.255.255.128
> no ip directed-broadcast
> !
> interface Serial0
> ip address 172.16.100.10 255.255.255.252
> no ip directed-broadcast
>
> !
> interface BRI0
> no ip address
> no ip directed-broadcast
> shutdown
> !
> router bgp 300
> no synchronization
> network 172.16.1.4 mask 255.255.255.128
> neighbor 172.16.100.9 remote-as 700
> no auto-summary
> !
> ip classless
> ip route 0.0.0.0 0.0.0.0 172.16.100.9
> !
> end
>
> giggles#sh ip bgp neighbors 172.16.100.9 advertised-routes giggles#
>
> Any other suggestions please?
>
> Smiles,
>
> Mohit.
>
> -----Original Message-----
> From: Yan-Hui Liang [mailto:Yan-Hui.Liang@sprint-canada.com]
> Sent: Mittwoch, 22. Mai 2002 19:19
> To: SHARMA,MOHIT (HP-Germany,ex1); ccielab@groupstudy.com
> Subject: RE: BGP
>
>
>
> Did you disable auto summary under BGP? then use network 172.16.1.5
> mask 255.255.255.128
> -----Original Message-----
> From: SHARMA,MOHIT (HP-Germany,ex1) [mailto:mohit_sharma@hp.com]
> Sent: Wednesday, May 22, 2002 12:52 PM
> To: ccielab@groupstudy.com
> Subject: BGP
>
>
> Hi All,
>
> I have an issue with BGP.
>
> I am using 172.16.1.0/25 subnet for the looopback interfaces on my lab
> routers.
>
> I have a router in an AS with the loopback interface ip 172.16.1.5
>
> Is it possible that I can advertise only this IP to other external
> AS's.
>
> I have tried this but somehow it always advertises some weird subnet.
>
> Can you use such a big subnet for loopbacks?
>
>
> Smiles,
>



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:59:06 GMT-3