Re: OT: Quality of Service & Queuing

From: David (david_knot@xxxxxxxxx)
Date: Mon May 20 2002 - 09:56:31 GMT-3


   
As per the setup below (see orig message below) the E1
is live now & we are about to apply the voice configs
to carry voice over the E1 link. Can I please double
check the configs (before & after the voice configs)
with you guys. If anyone has full woring configs, Id
appreciate it if they forward them.

Before Voice stuff:

hostname berlin_router
!
ip subnet-zero
ip cef
!
call rsvp-sync
!
!
controller E1 0/0
 channel-group 0 unframed
!
!
interface FastEthernet0/0
 no ip address
!
interface FastEthernet0/0.1
 encapsulation dot1Q 1 native
 ip address 172.16.1.1 255.255.0.0
!
interface FastEthernet0/0.2
 encapsulation dot1Q 2
 ip address 172.17.1.1 255.255.0.0
!
interface Serial0/0:0
 ip address 172.18.1.1 255.255.0.0

!
router ospf 1
. . .
!
end

hostname cat35_berlin_switch
!
ip subnet-zero
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport priority default 5
!
interface FastEthernet0/3
 switchport access vlan 2
 switchport priority default 5
 spanning-tree portfast
!
interface FastEthernet0/4
 switchport access vlan 2
 switchport priority default 5
 spanning-tree portfast
!
...
interface VLAN1
 ip address 172.16.22.22 255.255.0.0
 no ip directed-broadcast
 no ip route-cache
!
!
end

hostname remote_router
!
ip subnet-zero
ip cef
!
!
controller E1 0/0
 channel-group 0 unframed
!
interface FastEthernet0/0
 no ip address
!
interface FastEthernet0/0.1
 encapsulation dot1Q 1 native
 ip address 172.19.1.1 255.255.0.0
!
interface FastEthernet0/0.2
 encapsulation dot1Q 2
 ip address 172.20.1.1 255.255.0.0
!
interface Serial0/0:0
 ip address 172.18.2.2255.255.0.0

!
router ospf 1

. . .

!
end

hostname cat35_remote_switch
!
ip subnet-zero
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport priority default 5
!
interface FastEthernet0/3
 switchport access vlan 2
 switchport priority default 5
 spanning-tree portfast
!
interface FastEthernet0/4
 switchport access vlan 2
 switchport priority default 5
 spanning-tree portfast
!
...
interface VLAN1
 ip address 172.19.22.22 255.255.0.0
 no ip directed-broadcast
 no ip route-cache
!
!
end

After Voice stuff:

hostname berlin_router
!
ip subnet-zero
ip cef
!
call rsvp-sync
!
class-map voice

 match access-group 102
!
policy-map policy1

 class voice

 priority 100

!
!
controller E1 0/0
 channel-group 0 unframed
!
!
interface FastEthernet0/0
 no ip address
!
interface FastEthernet0/0.1
 encapsulation dot1Q 1 native
 ip address 172.16.1.1 255.255.0.0
!
interface FastEthernet0/0.2
 encapsulation dot1Q 2
 ip address 172.17.1.1 255.255.0.0
!
interface multilink1
ip address 172.18.1.1 255.255.0.0
no ip directed-broadcast
no ip mroute-cache
service-policy output policy1
ppp multilink
ppp multilink fragment-delay 20
ppp multilink interleave
!
interface Serial0/0:0
no ip address
no ip directed-broadcast
encapsulation ppp
no fair-queue
ppp multilink
multilink-group 1

!
router ospf 1
. . .
!
access-list 102 permit udp any any range 16384 49151
!
end

hostname remote_router
!
ip subnet-zero
ip cef
!
class-map voice

 match access-group 102
!
policy-map policy1

 class voice

 priority 100
!
controller E1 0/0
 channel-group 0 unframed
!
interface FastEthernet0/0
 no ip address
!
interface FastEthernet0/0.1
 encapsulation dot1Q 1 native
 ip address 172.19.1.1 255.255.0.0
!
interface FastEthernet0/0.2
 encapsulation dot1Q 2
 ip address 172.20.1.1 255.255.0.0
!
interface multilink1
ip address 172.18.2.2 255.255.0.0
no ip directed-broadcast
no ip mroute-cache
service-policy output policy1
ppp multilink
ppp multilink fragment-delay 20
ppp multilink interleave
!
interface Serial0/0:0
no ip address
no ip directed-broadcast
encapsulation ppp
no fair-queue
ppp multilink
multilink-group 1
!
router ospf 1
. . .
!
access-list 102 permit udp any any range 16384 49151
!
end

--------------------

Setting up 2 sites in Germany connecting via E1 line.
The client wants to carry voice over the same line.
Theyre using Lucent PBXs at both sites. PBXs will
convert the voice to UDP packets. There are no IP
telephone involved, So not complete IP Telephony
setup.

Well setup COS & QOS on the Catalyst 3550XL & Cisco
2650 router. Catalysts are setup with a separate Voice
traffic VLAN 10 & ingress & engress ports with COS=5.

Were wondering what Queuing type to use on the E1
connecting using Cisco 2650. Cisco.com talks about LLQ
but is there anything better than that? Has anyone got
some sample configs for the router different Queuing
methods?

Thanks

David



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:59:02 GMT-3