RE: IRB with OSPF/EIGRP

From: Lupi, Guy (Guy.Lupi@xxxxxxxxxxxxx)
Date: Sun Apr 21 2002 - 21:11:42 GMT-3


   
Here they are, mind you I would never think this to be on the lab, just
something foolish I thought up. While we are on the subject, my
bridge-group address command is not working. I had the same command using
transparent bridging, and it only allowed broadcasts to and from token ring
1, now it isn't working. Can you not use bridge-group address commands to
filter when doing IRB? Thanks.

R6

r6#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r6
!
!
ip subnet-zero
no ip domain-lookup
ipx routing 0000.0c36.f309
!
!
bridge irb
!
!
!
interface Loopback0
 ip address 6.6.6.6 255.255.255.0
 no ip directed-broadcast
 ip ospf network point-to-point
 ip ospf interface-retry 0
!
interface Tunnel0
 ip address 3.6.3.6 255.255.255.0
 no ip directed-broadcast
 ip ospf interface-retry 0
 tunnel source 64.64.64.6
 tunnel destination 64.64.64.3
!
interface Tunnel1
 ip address 4.6.4.6 255.255.255.0
 no ip directed-broadcast
 ip ospf interface-retry 0
 tunnel source 64.64.64.6
 tunnel destination 64.64.64.4
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
 shutdown
 media-type 10BaseT
!
interface Ethernet1
 no ip address
 no ip directed-broadcast
 shutdown
 media-type 10BaseT
!
interface Serial0
 ip address 172.16.7.6 255.255.255.0
 no ip directed-broadcast
 encapsulation frame-relay
 ip ospf network broadcast
 ip ospf interface-retry 0
 ip ospf priority 255
 no ip mroute-cache
 ipx network 561
 no fair-queue
 no arp frame-relay
 frame-relay map ip 172.16.7.1 662 broadcast
 frame-relay map ip 172.16.7.5 665 broadcast
 frame-relay map ipx 561.0010.7b80.e936 662 broadcast
 frame-relay map ipx 561.0010.7b36.e1dd 665 broadcast
 no frame-relay inverse-arp
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial2
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial3
 no ip address
 no ip directed-broadcast
 shutdown
!
interface TokenRing0
 no ip address
 no ip directed-broadcast
 ip ospf network broadcast
 ip ospf interface-retry 0
 ipx network 36
 ring-speed 16
 bridge-group 1
!
interface TokenRing1
 no ip address
 no ip directed-broadcast
 ip ospf network broadcast
 ip ospf interface-retry 0
 ipx network 46
 ring-speed 16
 bridge-group 1
!
interface BVI1
 ip address 64.64.64.6 255.255.255.0
 no ip directed-broadcast
 ip ospf interface-retry 0
!
router ospf 100
 network 3.6.3.0 0.0.0.255 area 0
 network 4.6.4.0 0.0.0.255 area 0
 network 6.6.6.0 0.0.0.255 area 0
 network 63.63.63.0 0.0.0.255 area 0
 network 64.64.64.0 0.0.0.255 area 0
 network 172.16.7.0 0.0.0.255 area 0
!
ip classless
!
!
!
!
!
bridge 1 protocol ieee
 bridge 1 route ip
 bridge 1 route ipx
 no bridge 1 bridge ipx
bridge 1 address ffff.ffff.ffff discard
!
line con 0
 logging synchronous
 transport input none
line aux 0
line vty 0 4
!
end

r6#

R4

r4#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r4
!
no logging console
!
ip subnet-zero
no ip domain-lookup
ipx routing 0008.de5c.a38a
!
!
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.0
 no ip directed-broadcast
 ip ospf network point-to-point
 ipx network 4444
!
interface Loopback2
 ip address 4.44.44.44 255.255.255.0
 no ip directed-broadcast
!
interface Tunnel0
 ip address 4.6.4.4 255.255.255.0
 no ip directed-broadcast
 tunnel source 64.64.64.4
 tunnel destination 64.64.64.6
!
interface Serial0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
 no fair-queue
!
interface Serial1
 no ip address
 no ip directed-broadcast
 shutdown
!
interface TokenRing0
 ip address 64.64.64.4 255.255.255.0
 no ip directed-broadcast
 ip ospf network broadcast
 ipx network 46
 ring-speed 16
!
interface BRI0
 no ip address
 no ip directed-broadcast
 shutdown
!
router ospf 100
 network 4.4.4.0 0.0.0.255 area 0
 network 4.6.4.0 0.0.0.255 area 0
 network 64.64.64.0 0.0.0.255 area 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 TokenRing0
!
!
!
!
!
line con 0
 logging synchronous
 transport input none
line aux 0
line vty 0 4
!
end

r4#

R3

r3#sh run
Building configuration...

Current configuration : 1057 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r3
!
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
ipx routing 0008.de6c.6382
!
!
!
!
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.0
 ip ospf network point-to-point
 ipx network 3333
!
interface Loopback2
 ip address 3.33.33.33 255.255.255.0
!
interface Tunnel0
 ip address 3.6.3.3 255.255.255.0
 tunnel source 64.64.64.3
 tunnel destination 64.64.64.6
!
interface Serial0
 no ip address
 shutdown
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
interface TokenRing0
 ip address 64.64.64.3 255.255.255.0
 ip ospf network broadcast
 ipx network 36
 ring-speed 16
!
interface BRI0
 no ip address
 shutdown
 isdn x25 static-tei 0
!
router ospf 100
 log-adjacency-changes
 network 3.3.3.0 0.0.0.255 area 0
 network 3.6.3.0 0.0.0.255 area 0
 network 64.64.64.0 0.0.0.255 area 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 TokenRing0
ip http server
!
!
!
!
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
!
end

r3#

~-----Original Message-----
~From: Ahmed Mamoor Amimi [mailto:mamoor@ieee.org]
~Sent: Sunday, April 21, 2002 9:00 PM
~To: Lupi, Guy; 'Bob Sinclair'
~Cc: ccielab@groupstudy.com
~Subject: Re: IRB with OSPF/EIGRP
~
~
~If ur doing IRB with the tokenrings then u should be using SRT on TR
~interfaces....
~
~Lupi let us see ur config ... i am interested in see that on TR...
~
~And i am sure it will work if it is SRT
~
~-Mamoor
~
~
~
~----- Original Message -----
~From: Lupi, Guy <Guy.Lupi@eurekaggn.com>
~To: 'Bob Sinclair' <bsin@erols.com>
~Cc: <ccielab@groupstudy.com>
~Sent: Monday, April 22, 2002 4:43 AM
~Subject: RE: IRB with OSPF/EIGRP
~
~
~> Really!?!? That is strange, with the exception of the
~OSPF/EIGRP thing,
~it
~> is working just as I would expect it to work. Where did you
~see that it
~> wasn't supported? Not that I don't believe you, I just want
~to take a
~look,
~> because it seems to be working.
~>
~> ~-----Original Message-----
~> ~From: Bob Sinclair [mailto:bsin@erols.com]
~> ~Sent: Sunday, April 21, 2002 6:58 PM
~> ~To: Lupi, Guy
~> ~Cc: ccielab@groupstudy.com
~> ~Subject: Re: IRB with OSPF/EIGRP
~> ~
~> ~
~> ~Guy,
~> ~
~> ~If I understand you correctly, you want to do IRB with Token
~> ~Ring interfaces. This is not supported.
~> ~
~> ~-Bob
~> ~
~> ~----- Original Message -----
~> ~From: "Lupi, Guy" <Guy.Lupi@eurekaggn.com>
~> ~To: "Lupi, Guy" <Guy.Lupi@eurekaggn.com>; <ccielab@groupstudy.com>
~> ~Sent: Sunday, April 21, 2002 3:44 PM
~> ~Subject: RE: IRB with OSPF/EIGRP
~> ~
~> ~
~> ~> Ok, I have it working now with IRB, but it is on Ethernet.
~> ~Same setup as
~> ~> below, but the routers below I described before are token
~> ~ring. So I have
~> ~> it working with IRB using all Ethernet, but it doesn't seem
~> ~to work with IRB
~> ~> when it is all token ring. Any ideas?
~> ~>
~> ~> ~-----Original Message-----
~> ~> ~From: Lupi, Guy
~> ~> ~Sent: Sunday, April 21, 2002 3:05 PM
~> ~> ~To: 'ccielab@groupstudy.com'
~> ~> ~Subject: IRB with OSPF/EIGRP
~> ~> ~
~> ~> ~
~> ~> ~I have a setup like below, and I was trying to run OSPF or
~> ~> ~EIGRP between the
~> ~> ~two routers that are in the bridge group and the BVI router,
~> ~> ~but I couldn't
~> ~> ~get it to work until I used tunnels. Has anyone gotten
~> ~OSPF or EIGRP
~> ~> ~working with IRB without using tunnels? Thanks.
~> ~> ~
~> ~> ~
~> ~> ~
~> ~> ~ r6
~> ~> ~ BVI
~> ~> ~ / \
~> ~> ~ / \
~> ~> ~ r3 r4



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:58:15 GMT-3