From: Brian Dennis (brian@xxxxxx)
Date: Fri Apr 19 2002 - 22:05:06 GMT-3
If a lab scenario said to not advertise the network via RIP or IGRP then
you're just going to have to filter that network out of your updates.
You maybe able to look into using redistribute connected so you can pick
and choose which interfaces to advertise out rather than just all
interfaces within the classful address space.
Example using RIPv2:
10.1.1.0/24
|
| 192.168.1.0/24
R1------------------R2---
|
|
10.1.2.0/24
Rather than this on R1:
<config>
router rip
version 2
distribute-list 100 out (interface to R2)
network 10.0.0.0
network 192.168.1.0
passive interface (10.1.1.0 interface)
passive interface (10.1.2.0 interface)
no auto-summary
!
access-list 100 permit ip 10.1.2.0 0.0.0.0 255.255.255.0 0.0.0.0
</config>
You could do this:
<config>
router rip
version 2
network 192.168.1.0
redistribute connected metric 1 route-map CCIE
no auto-summary
!
route-map CCIE permit 10
match ip address 100
!
access-list 100 permit ip 10.1.2.0 0.0.0.0 255.255.255.0 0.0.0.0
</config>
Of course this wouldn't be very useful with RIPv1 and IGRP because they
will auto summarize the 10.0.0.0 network going across the 192.168.1.0
network anyways.
If you want to be creative you could just shut the interface down. Then
the network won't be in the IGRP or RIP updates but I don't think that
is the answer they will be looking for. ;-)
Good Luck,
Brian Dennis, CCIE #2210 (R&S/ISP Dial)
-----Original Message-----
From: Krake, Kris [mailto:KKrake@AEGONUSA.com]
Sent: Friday, April 19, 2002 4:46 PM
To: Brian Dennis
Cc: ccielab@groupstudy.com
Subject: RE: IGRP/RIP advertising passive connected interfaces that are
member s of other routing processes
I understand your point and agree...but...the question I have is it ok
in
terms of lab requirements to have connected networks that are part of
other
routing protocols sucked into RIP and/or IGRP due the lack of a mask
command
like in EIGRP.
KK
-----Original Message-----
From: Brian Dennis [mailto:brian@5g.net]
Sent: Friday, April 19, 2002 7:20 PM
To: ccielab@groupstudy.com
Subject: RE: IGRP/RIP advertising passive connected interfaces that are
member s of other routing processes
Passive interface doesn't have anything to do with what networks are
advertised or not with the exception of IS-IS. Passive interface only
relates to the sending of updates out an interface or the sending of
hellos out. Remember that a router with passive interface enabled can
still receive updates on that interface (RIP and IGRP).
With IS-IS the passive interface command will advertise the IP network
for the interface that is made passive but the router will not try to
form a neighbor relationship out that interface.
As a side note Cisco added the "default" option to the passive interface
command in IOS version 12.0 which means that all interfaces can be made
passive with one command.
Brian Dennis, CCIE #2210 (R&S/ISP Dial)
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Krake, Kris
Sent: Friday, April 19, 2002 3:31 PM
To: ccielab@groupstudy.com
Subject: IGRP/RIP advertising passive connected interfaces that are
member s of other routing processes
I was doing some work with IGRP/RIP and redistribution into OSPF and I
came
across something interesting I'd never really noticed. My requirements
are
to make sure the IGRP and RIP are not advertising out any non-specified
interfaces. Fine, put in passive interfaces. Here's the question. If
you
look farther into say the IGRP process you will see networks advertised
out
"non-passive" interfaces for interfaces that are passive. For
example...
R1 ------ R2 -------R3
IGRP OSPF
R2 and R1 are talking rip and R2 and R3 are OSPF neighbors. In the IGRP
process I have specified that the interface on R2 connecting to R3 is
passive. Both networks R1-R2 and R2-R3 are in the same major network.
On R1
I will see the network in IGRP for the link between R2 and R3. The only
way
I know to keep that from happening is to apply some type of distribute
list.
I'm wondering if there is something else that could be done to keep that
from happening. The requirement was not to "advertise" out any non
specified interfaces so I *think* I've met the requirements but I've got
non
IGRP networks stuck in my IGRP process. Is there a way to keep
connected
interfaces from being a part of the IGRP process? I know with EIGRP and
the
new mask command you can keep that from happening but what about RIP and
IGRP?
Thoughts?
Kris
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Kris A. Krake
AIT Network Engineering and Consulting
502.560.2716
kkrake@aegonusa.com
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:58:14 GMT-3