Re: OSPF - IGRP

From: Sean C (Upp_and_Upp@xxxxxxxxxxx)
Date: Tue Apr 16 2002 - 14:26:18 GMT-3


   
Hi Tarek,

Here's a solution I've done for one of the commercial labs. In this
instance the only route that wasn't being properly propagated to IGRP was
the ASBR's directly connected /28 network - 150.10.10.0/28. I created a 2nd
OSPF process, redistributed the ASBR's connected interfaces into the second
OSPF, summarized the redistibuted connected interface to a /24 network and
then redistributed both OSPF 1 and OSPF 2 into IGRP. The reason I had to do
this was when redistibuting the connecting interfaces into OSPF 1 (and never
created a 2nd OSPF process), summarization would not work because the route
I wanted to summarize was also a network statement in the same OSFP process.
By creating the 2nd OSPF process I was able to properly summarize the /28
network to a /24 route. When doing this, though, it will create a Null0
route in the ASBR's routing table.

router ospf 1
router-id 150.10.5.5
redistribute igrp 1 metric 65 metric-type 1 subnets route-map permit-igrp
network 150.10.10.0 0.0.0.15 area 1
.... there are other network statements here that are irrevelant to the
example.....
!
router ospf 2
router-id 200.150.150.5
summary-address 150.10.10.0 255.255.255.0
redistribute connected metric 20 subnets
passive-interface Ethernet0
passive-interface Serial0.1
passive-interface Serial0.2
passive-interface Serial0.3
passive-interface BRI0
!
router igrp 1
redistribute ospf 1 metric 1500 10 255 1 1500 route-map deny-igrp
redistribute ospf 2 metric 1500 10 255 1 1500 route-map deny-igrp
passive-interface BRI0
passive-interface Ethernet0
passive-interface Serial0.1
passive-interface Serial0.2
network 150.10.0.0

HTH,
Sean

----- Original Message -----
From: "Tarek Sabry" <tsabry@houston.sns.slb.com>
To: "'DAN DORTON'" <DHSTS68@dhs.state.il.us>; <dan_schaw@yahoo.com>
Cc: <ccielab@groupstudy.com>
Sent: Tuesday, April 16, 2002 12:35 PM
Subject: RE: OSPF - IGRP

> Great. Those ideas make a lot of sense. I'll start by trying out Dan's
plan.
> I hope there's nothing "illegal" about it for lab purposes :)
>
> I will also try to do the extra-area solution.
>
> However what I would like to find an answer to is why do a lot of
solutions
> use the summary address for this problem. It seems that if the
> summary-address works then it should be the simplest apprach.
>
> Thanks
> Tarek
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
> DAN DORTON
> Sent: Tuesday, April 16, 2002 11:02 AM
> To: tsabry@houston.sns.slb.com; dan_schaw@yahoo.com
> Cc: ccielab@groupstudy.com
> Subject: RE: OSPF - IGRP
>
>
> Let say you have a range of 172.168.1.0/28 in ospf that you need to get
into
> a 172.168.2.0/24 IGRP, or RIP domain.
>
> Summary-address only works INTO ospf right?
>
> You need to make this 172.168.1.0/28 network into a 172.168.1.0/24 network
> to overcome the rip/igrp domains classful boundry problems right?
>
> Create a loopback with address 172.168.1.17/28 at your ASBR.
> Do not advertise this network into OSPF.
> Instead create a route-map to permit it.
>
> access-list 1 permit 172.168.1.16 0.0.0.15
>
> route-map con2ospf permit 10
> match ip address 1
>
> Then create a summary address under ospf.
>
> router ospf 1
> summary-address 172.168.1.0 255.255.255.0
>
> Then redistribute connected INTO ospf with the route-map.
>
> router ospf 1
> redistribute connected subnets route-map con2ospf
>
> Since 172.168.1.16/28 network fits into the summary-address range of
> 172.168.1.0/24 ospf will create a route to null 0 for the 172.168.1.0/24
> network.
>
> Because connecteds being redistributed INTO ospf are external networks the
> summary-address works.
>
> Because 172.168.1.0/28 & 172.168.1.16/28 both fit into the major network
> 172.168.1.0/24 the summary-address will work to reach both networks.
>
> Because 172.168.1.0/24 route matches the 172.168.2.0/24 network on the
> igrp/rip domain at the classfull 172.168.0.0/16 & the mask of /24 which is
> on the igrp/rip domain the igrp/rip domain will accept the summary route.
>
> Hope this helps everyone.
>
> Dan
>
> >>> Tarek Sabry <tsabry@houston.sns.slb.com> 04/16/02 10:10AM >>>
> Muhammad
>
> Thanks for your reply.
>
> I fully agree that summary-address is for injecting a summary INTO OSPF
and
> not to redistribute into another protocol. But I've seen people using it
> otherwise :( Is this IOS-related?
>
> How can I create area-range when the router I'm trying to redistribute at
is
> not an ABR? I only have area-1 and IGRP on this router.
>
> Creating statics is also prohibited in the lab. Right?
>
> Thanks again
> Tarek
>
> -----Original Message-----
> From: Muhamamd Durrani [mailto:dan_schaw@yahoo.com]
> Sent: Tuesday, April 16, 2002 8:56 AM
> To: Tarek Sabry
> Cc: ccielab@groupstudy.com
> Subject: Re: OSPF - IGRP
>
>
> Hi Tarek ,
>
> With Summary-Address you cannot re-distribute to other
> routing protocol . Its for the Summary Address for
> Ecternal Routes .
>
> I would rather say create a Summary Address with "Area
> range " commad on the router you want to summarized
> the addresses on, with the mask configured on the
> interfaces running IGRP. If the mask is now same as
> configured on IGRP interfaces than you wil not see the
> route on IGRP router .
>
> Another way that I could see is to create a static
> route on ASBR to NULL 0 and redistribute static into
> IGRP process ..but again the mask SHOULD match with
> interaces configured with IGRP .
>
>
> Let me know id I am wrong .
>
> Regards,
> Muhammad
>
>
> --- Tarek Sabry <tsabry@houston.sns.slb.com> wrote:
> > Hi
> >
> > I understand that there may be more than one way to
> > redistribute VLSM into
> > FLSM. However the only way that seems to work for me
> > when redistributing
> > OSPF into IGRP is the brilliant method suggested by
> > someone a little while
> > back, whereby I need to create an intermediate OSPF
> > process. I don't feel
> > comfortable with just this way though, because the
> > proctors may object to
> > it.
> >
> > So let's say we have a /26 network connected to the
> > OSPF side of the
> > redistributing router. Someone had suggested before
> > that a good way of
> > achieveing what I want would be to redistribute
> > connected into OSPF and
> > create a "summary-address" of a /24, and this route
> > would be redistributed
> > into IGRP with the rest of the OSPF routes.
> >
> > Is that supposed to work??? Well doesn't the
> > "summary-address" inject a
> > route INTO OSPF and not OUT OF it?? Also how come I
> > do not see any routes to
> > "Null 0" after I create my OSPF summary address?
> >
> > What are common gotchas for OSPF summaries??
> >
> > Thanks a lot
> > Tarek
> >



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:58:10 GMT-3