From: Erick B. (erickbe@xxxxxxxxx)
Date: Sun Apr 14 2002 - 00:21:33 GMT-3
The dialer pool command has a min-link and max-link
option you can configure. Set the min-link to 2.
--- Mingzhou Nie <mnie@yahoo.com> wrote:
> Here are the configs. I configured based on
> following techtip. Yes, I
> configured "ppp multilink". If I change "dialer
> load-threshold 1" to
> "dialer load-threshold 10", it keeps only bri0:1 up.
> What I really want
> is when primary interface's down, two bri lines come
> up and when
> primary interface's backup, both bri lines should be
> down.
>
> How can I do that? Thanks.
>
>
http://www.cisco.com/warp/public/793/access_dial/bri_isdn_11049.html
>
> 2503A#show run
> Building configuration...
>
> Current configuration : 1418 bytes
> !
> version 12.1
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname 2503A
> !
> !
> username 4500A password 0 cisco
> !
> !
> !
> !
> ip subnet-zero
> !
> isdn switch-type basic-5ess
> !
> !
> !
> interface Loopback0
> ip address 10.10.1.1 255.255.255.0
> ip ospf network point-to-point
> !
> interface Ethernet0
> ip address 10.10.7.1 255.255.255.0
> !
> interface Serial0
> bandwidth 512
> no ip address
> encapsulation frame-relay
> no fair-queue
> !
> interface Serial0.1 point-to-point
> ip address 10.10.5.1 255.255.255.0
> frame-relay interface-dlci 100
> !
> interface Serial1
> no ip address
> !
> interface BRI0
> no ip address
> encapsulation ppp
> load-interval 30
> dialer pool-member 1
> isdn switch-type basic-5ess
> !
> interface Dialer0
> ip address 10.10.6.1 255.255.255.0
> encapsulation ppp
> dialer pool 1
> dialer remote-name 4500A
> dialer idle-timeout 30
> dialer string 94724811
> dialer string 94724812
> dialer load-threshold 10 either
> dialer watch-group 1
> dialer-group 1
> ppp multilink
> !
> router ospf 1
> log-adjacency-changes
> network 10.10.1.0 0.0.0.255 area 0
> network 10.10.5.0 0.0.0.255 area 0
> network 10.10.6.0 0.0.0.255 area 0
> network 10.10.7.0 0.0.0.255 area 0
> !
> ip classless
> ip http server
> !
> access-list 101 deny ospf any any
> access-list 101 permit ip any any
> dialer watch-list 1 ip 10.10.8.0 255.255.255.0
> dialer-list 1 protocol ip list 101
> !
> !
> line con 0
> exec-timeout 0 0
> line aux 0
> line vty 0 4
> login
> !
> end
>
> 2503A#
>
> 4500A#show run
> Building configuration...
>
> Current configuration:
> !
> version 11.3
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname 4500A
> !
> !
> username 2503A password 0 cisco
> isdn switch-type basic-ni1
> !
> !
> !
> interface Loopback0
> ip address 10.10.2.1 255.255.255.0
> ip ospf network point-to-point
> !
> interface Ethernet0
> ip address 10.10.8.1 255.255.255.0
> !
> interface Ethernet1
> no ip address
> shutdown
> !
> interface Serial0
> no ip address
> encapsulation frame-relay
> no arp frame-relay
> no fair-queue
> no frame-relay inverse-arp
> !
> interface Serial0.1 point-to-point
> ip address 10.10.5.2 255.255.255.0
> bandwidth 512
> frame-relay interface-dlci 100
> !
> interface Serial1
> no ip address
> encapsulation frame-relay
> bandwidth 512
> !
> interface Serial2
> no ip address
> shutdown
> !
> interface Serial3
> no ip address
> shutdown
> !
> interface BRI0
> no ip address
> encapsulation ppp
> dialer pool-member 1
> isdn spid1 919472481100
> isdn spid2 919472481201
> ppp authentication chap
> !
> interface BRI1
> no ip address
> shutdown
> !
> interface BRI2
> no ip address
> shutdown
> !
> interface BRI3
> no ip address
> shutdown
> !
> interface Dialer0
> ip address 10.10.6.2 255.255.255.0
> encapsulation ppp
> dialer remote-name 2503A
> dialer pool 1
> dialer-group 1
> ppp authentication chap callin
> !
> router ospf 1
> network 10.10.2.0 0.0.0.255 area 0
> network 10.10.5.0 0.0.0.255 area 0
> network 10.10.6.0 0.0.0.255 area 0
> network 10.10.8.0 0.0.0.255 area 0
> !
> no ip classless
> ip route 0.0.0.0 0.0.0.0 10.5.1.1
> !
> access-list 101 deny ospf any any
> access-list 101 permit ip any any
> dialer-list 1 protocol ip list 101
> !
> line con 0
> exec-timeout 0 0
> line aux 0
> line vty 0 4
> login
> !
> end
>
> 4500A#
> --- Kathleen Burns <beta311@cox.net> wrote:
> > I believe this is due to load threshold you have
> set. Your first
> > line dials
> > and connects, then your load-threshold kicks in
> and brings up the
> > other
> > line. After the idle time out the first line drop
> but the second
> > line is
> > still up, so the load threshold kicks in again.
> Try changing your
> > load-threshold to 2 and that should be enough of a
> delay to drop both
> > lines...
> >
> > Bill
> >
> > -----Original Message-----
> > From: nobody@groupstudy.com
> [mailto:nobody@groupstudy.com]On Behalf
> > Of
> > Mingzhou Nie
> > Sent: Friday, April 12, 2002 10:15 PM
> > To: ccielab@groupstudy.com
> > Subject: dialer watch with dialer load-threshold
> >
> >
> > This is interesting. I'm configuring dialer watch
> on dialer profile.
> > 2503a is calling 4500a. If I enter "dialer
> load-threshold 1 either"
> > in
> > interface dialer0, even after serial interfaces
> come back, r1 keeps
> > bringing up isdn link. If I took it out, isdn link
> becomes idle at
> > next
> > idle time out. Why is that?
> >
> > Mingzhou Nie
> >
> > 1w6d: %DIALER-6-UNBIND: Interface BR0:1 unbound
> from profile Di0
> > 1w6d: %ISDN-6-DISCONNECT: Interface BRI0:1
> disconnected from
> > 94724811
> > , call ls
> > 1w6d: %LINK-3-UPDOWN: Interface BRI0:1, changed
> state to down
> > 1w6d: %LINEPROTO-5-UPDOWN: Line protocol on
> Interface BRI0:1, changed
> > state to n
> > 1w6d: %LINK-3-UPDOWN: Interface BRI0:1, changed
> state to up
> > 1w6d: %DIALER-6-BIND: Interface BR0:1 bound to
> profile Di0
> > 1w6d: %LINEPROTO-5-UPDOWN: Line protocol on
> Interface BRI0:1, changed
> > state to p
> > 1w6d: %ISDN-6-CONNECT: Interface BRI0:1 is now
> connected to 94724811
> > 1w6d: %DIALER-6-UNBIND: Interface BR0:2 unbound
> from profile Di0
> > 1w6d: %ISDN-6-DISCONNECT: Interface BRI0:2
> disconnected from
> > 94724811
> > , call ls
> > 1w6d: %LINK-3-UPDOWN: Interface BRI0:2, changed
> state to down
> > 1w6d: %LINEPROTO-5-UPDOWN: Line protocol on
> Interface BRI0:2, changed
> > state to n
> > 1w6d: %LINK-3-UPDOWN: Interface BRI0:2, changed
> state to up
> > 1w6d: %DIALER-6-BIND: Interface BR0:2 bound to
> profile Di0
> > 1w6d: %LINEPROTO-5-UPDOWN: Line protocol on
> Interface BRI0:2, changed
> > state to p
> > 1w6d: %ISDN-6-CONNECT: Interface BRI0:2 is now
> connected to 94724811
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:58:07 GMT-3