From: Lupi, Guy (Guy.Lupi@xxxxxxxxxxxxx)
Date: Wed Apr 03 2002 - 22:41:28 GMT-3
I didn't use the route map to redistribute the routes, but I figure if the
requirement isn't "the routes have to appear on r2" but is "r2 and it's
connected subnets must have connectivity to all subnets", you could do
policy routing, this works, I have tried it before. You create the
route-map, then tell the router to use this as a local policy route-map, and
apply it on any interface that is not connected to the gateway router. So
that any local traffic from the router follows the route-map, and any
incoming packets on interfaces not connected to the gateway router get
policy routed using this route-map.
route-map connecttoclassless
match ip addr 1
set ip next hop [ip of gateway router]
!
access-list 1 permit [ip block] [mask bits]
access-list 1 permit [ip block] [mask bits]
-----Original Message-----
From: Jason
To: Lupi, Guy; 'Warren J Dubose '
Cc: ''Mas Kato' '; ccielab@groupstudy.com
Sent: 4/3/2002 8:30 PM
Subject: RE: OSPF to IGRP redistribution (I know this has been killed, th
i s is short I promise)
You cannot summarize area 0, doyle's first book talks about that the
best way to solve this problem is to use a tunnel. I am also curious as
to how you used a route-map to redistribute the routes?
Jason
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Lupi, Guy
Sent: Wednesday, April 03, 2002 6:54 PM
To: 'Warren J Dubose '
Cc: ''Mas Kato' '; 'ccielab@groupstudy.com '
Subject: RE: OSPF to IGRP redistribution (I know this has been killed,
th i s is short I promise)
I have a loopback on it that I put in area 1, is that no good? Anyway,
here
is the config and routing table for r1, the summary route to null 0 is
there, is that not allowed on the lab? It isn't a static route, thanks
for
your time.
r1#sh ip route
141.63.0.0/16 is variably subnetted, 7 subnets, 4 masks
O 141.63.1.0/24 is a summary, 04:54:06, Null0
C 141.63.1.0/26 is directly connected, Loopback0
C 141.63.7.0/24 is directly connected, Serial0
C 141.63.7.0/25 is directly connected, Serial0
O IA 141.63.5.0/27 [110/65] via 141.63.7.5, 02:53:23, Serial0
C 141.63.10.0/25 is directly connected, Loopback99
C 141.63.12.0/24 is directly connected, Ethernet0
r1#
r1#sh run
Building configuration...
Current configuration : 1532 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r1
!
logging rate-limit console 10 except errors
no logging console
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
cns event-service server
!
!
!
!
!
interface Loopback0
ip address 141.63.1.1 255.255.255.192
ip ospf network point-to-point
!
interface Loopback99
ip address 141.63.10.1 255.255.255.128
ip ospf network point-to-point
!
interface Ethernet0
ip address 141.63.12.1 255.255.255.0
!
interface Ethernet1
no ip address
shutdown
!
interface Serial0
ip address 141.63.7.11 255.255.255.0 secondary
ip address 141.63.7.1 255.255.255.128
encapsulation frame-relay
ip ospf network broadcast
no fair-queue
no arp frame-relay
frame-relay map ip 141.63.7.5 115 broadcast
no frame-relay inverse-arp
!
interface Serial1
no ip address
shutdown
!
router ospf 100
log-adjacency-changes
area 0 range 141.63.5.0 255.255.255.0
summary-address 141.63.1.0 255.255.255.0
redistribute connected subnets
network 141.63.7.0 0.0.0.127 area 0
network 141.63.10.0 0.0.0.127 area 1
!
router igrp 100
redistribute ospf 100
passive-interface default
no passive-interface Ethernet0
network 141.63.0.0
default-metric 1500 128 128 128 128
!
ip kerberos source-interface any
ip classless
no ip http server
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
r1#
-----Original Message-----
From: Warren J Dubose
To: Lupi, Guy
Cc: 'Mas Kato'; ccielab@groupstudy.com
Sent: 4/3/2002 5:13 PM
Subject: RE: OSPF to IGRP redistribution (I know this has been killed,
thi
s is short I promise)
Guy,
MAS is correct.
How can r1 belong to 2 areas when it is connected to r1 talking IGRP?
There are two types of summarization in ospf:
Intra-area route summarization
---- summarization can occur at two points in an OSPF network at
"AREA BORDERS", where ABRs can be configured to announce a single
Summary
LSA for the range of networks residing within a "specific area"
Inter-routing Domain Route Summarization
--- on ASBRs at "route redistribution points" where ospf routes are
being
exported to another routing protocol, or non-ospf routes are being
imported into opsf.
Check out Doyle's or Caslow's book pertaining to summarization of OSPF.
This should help ;)
Regards,
Warren
On Wed, 3 Apr 2002, Lupi, Guy wrote:
> Right, that is what I did, R1 is a member of 2 areas, area 1 and area
0.
> Here is a partial output of "show ip ospf". This is why I don't
understand
> why it isn't working. I thought that as long as the router was an
ABR, you
> could use area range to summarize and inject into IGRP.
>
> r1#sh ip os
> Routing Process "ospf 100" with ID 141.63.10.1 and Domain ID
0.0.0.100
> Supports only single TOS(TOS0) routes
> Supports opaque LSA
> It is an area border and autonomous system boundary router
>
> -----Original Message-----
> From: Mas Kato [mailto:loomis_towcar@speedracer.com]
> Sent: Wednesday, April 03, 2002 4:30 PM
> To: Lupi, Guy
> Cc: ccielab@groupstudy.com
> Subject: RE: OSPF to IGRP redistribution (I know this has been killed,
> this is short I promise)
>
>
> Guy,
>
> Although router1 is certainly an ASBR, it really doesn't become an ABR
until
> it becomes a member of two or more OSPF areas. If you hung another
> OSPF-speaking router off of router1 and placed it in an area different
from
> router5, you would then see the results of your 'area range' command
on that
> new router, because that new router would know how to read the type 3
> summary LSAs being originated by router1.
>
> Regards,
>
> Mas Kato
> https://ecardfile.com/id/mkato
>
> > "Lupi, Guy" <Guy.Lupi@eurekaggn.com> "'ccielab@groupstudy.com'"
> <ccielab@groupstudy.com>Date: Wed, 3 Apr 2002 14:44:12 -0500
> >Reply-To: "Lupi, Guy" <Guy.Lupi@eurekaggn.com>
> >
> >I know this has been covered in detail before, I just want to verify
> >something. I have the following:
> >
> >router2---------router1--------router5
> >
> >Router 5 and router 1 are OSPF, router 2 and router 1 is igrp only.
I know
> >how to use the secondary address, tunnel, and route-map methods. I
know
> how
> >to use summary address on router 1 to get connected routes that are
not in
> >OSPF onto router 2. I cannot get routes from router 5 to router 2
using
> >area range on router 1. Router 1 is an ASBR, and an ABR. I cannot
use the
> >area range command to get the route from r5 to r2, and summary
address
> would
> >never work, but tunnels, route-maps, and secondary addresses work. I
> >thought that if the router was an ABR, you could do "area-range [area
route
> >is from] x.x.x.x x.x.x.x". Thanks.
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:57:53 GMT-3