RE: DLSW and Source Bridge LONG

From: Chua, Parry (Parry.Chua@xxxxxxxxxx)
Date: Wed Mar 27 2002 - 22:32:29 GMT-3


   
This what I would suggest :

1. Set the mac address no require bit-swap, use the following combination
   00, 18, 24, 3C, 42, 5A, 66, 7E, 81, 99, A5, BD, C3, DB, E7, FF.
   - You may pick those combination that has even value, 00, 24, 42, 66, FF
   - Do test.

2. Next change to any value that require bit-swap and test again, this time you
 may
   need to perform bit-swap-in-byte for the remote mac address...

Parry Chua

-----Original Message-----
From: Lupi, Guy [mailto:Guy.Lupi@eurekaggn.com]
Sent: Thursday, March 28, 2002 1:10 AM
To: 'Richard Wheat'
Cc: 'Ahmed Mamoor Amimi'; John Neiberger; Chua, Parry; 'Jason Sinclair
'; ''Frank B' '; ccielab@groupstudy.com
Subject: RE: DLSW and Source Bridge LONG

I will give it a shot and let you know how it goes, thanks.

-----Original Message-----
From: Richard Wheat [mailto:rwheat@ami.com.au]
Sent: Wednesday, March 27, 2002 8:57 AM
To: Lupi, Guy
Cc: 'Ahmed Mamoor Amimi'; John Neiberger; Parry.Chua@compaq.com; 'Jason
Sinclair '; ''Frank B' '; ccielab@groupstudy.com
Subject: Re: DLSW and Source Bridge LONG

Guy,

To get this to work you will need to byte-swap the addresses on your dspu
pu and host definitions. Remember that to R6, R5's address will be
4444.4444.4444, and vice versa. Look at the sh dlsw reach output it
shows the problem - see that dlsw is searching for 2222.2222.2222
locally but it knows about 4444.4444.4444 locally. Reconfigure with
some other choice for an address at one end and byte-swap the dspu
r-mac addresses. If you keep the same addresses - byte-swapping
gives you the opposite address ie. 2222.2222.2222 becomes
4444.4444.4444 - this won't prevent it working but could cause confusion.

HTH,
Richard.

"Lupi, Guy" wrote:

> I just set up a token ring router with the dspu config that Mamoor put
out,
> and it does work now as expected without the transparent bridge in there.
> Now if I could only get r5 to come up with the dspu configuration, it
> doesn't seem to be responding to queries from r1. Here are the configs
and
> a drawing, anyone see anything wrong with r5? Once again, thanks to
> everyone for their help and responses:
>
> r6-------to0-------r3------r8--------r1-----e0-----r5
> ^ ^
> | |
> DSPU Config here DSPU Config here
>
> r3#sh conf
> Using 956 out of 32762 bytes
> !
> version 12.1
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname r3
> !
> no logging console
> !
> !
> !
> !
> !
> ip subnet-zero
> no ip domain-lookup
> !
> !
> !
> !
> !
> source-bridge ring-group 12
> dlsw local-peer peer-id 3.3.3.3 group 83 cost 1 lf 1500
> dlsw remote-peer 0 tcp 8.8.8.8 lf 1500
> !
> interface Loopback0
> ip address 3.3.3.3 255.255.255.255
> !
> interface Serial0
> ip address 3.8.3.3 255.255.255.0
> no fair-queue
> !
> interface Serial1
> no ip address
> shutdown
> !
> interface TokenRing0
> ip address 3.6.3.3 255.255.255.0
> ring-speed 16
> source-bridge 1 1 12
> source-bridge spanning
> !
> interface BRI0
> no ip address
> shutdown
> isdn x25 static-tei 0
> !
> router ospf 100
> log-adjacency-changes
> network 3.3.3.3 0.0.0.0 area 0
> network 3.6.3.0 0.0.0.255 area 0
> network 3.8.3.0 0.0.0.255 area 0
> network 198.207.193.0 0.0.0.0 area 0
> !
> ip classless
> ip http server
> !
> !
> bridge 1 protocol ieee
> !
> line con 0
> line aux 0
> line vty 0 4
> !
> end
>
> r3#sh dlsw reach
> DLSw Local MAC address reachability cache list
> Mac Addr status Loc. port rif
> 2222.2222.2222 SEARCHING LOCAL
> 4444.4444.4444 FOUND LOCAL TokenRing0 0690.0011.00C0
>
> DLSw Remote MAC address reachability cache list
> Mac Addr status Loc. peer
> 2222.2222.2222 SEARCHING REMOTE
>
> DLSw Local NetBIOS Name reachability cache list
> NetBIOS Name status Loc. port rif
>
> DLSw Remote NetBIOS Name reachability cache list
> NetBIOS Name status Loc. peer
>
> r3#
>
> r6#sh run
> Building configuration...
>
> Current configuration:
> !
> version 12.0
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname r6
> !
> no logging console
> !
> ip subnet-zero
> no ip domain-lookup
> !
> !
> !
> !
> !
> dspu host TEST xid-snd 00000000 rmac 2222.2222.2222 rsap 4 lsap 4
> !
> interface Loopback0
> ip address 6.6.6.6 255.255.255.255
> no ip directed-broadcast
> ip ospf interface-retry 0
> !
> interface Ethernet0
> no ip address
> no ip directed-broadcast
> shutdown
> media-type 10BaseT
> !
> interface Ethernet1
> no ip address
> no ip directed-broadcast
> shutdown
> media-type 10BaseT
> !
> interface Serial0
> no ip address
> no ip directed-broadcast
> no ip mroute-cache
> shutdown
> no fair-queue
> !
> interface Serial1
> no ip address
> no ip directed-broadcast
> shutdown
> !
> interface Serial2
> no ip address
> no ip directed-broadcast
> shutdown
> !
> interface Serial3
> no ip address
> no ip directed-broadcast
> shutdown
> !
> interface TokenRing0
> mac-address 4444.4444.4444
> ip address 3.6.3.6 255.255.255.0
> no ip directed-broadcast
> ip ospf interface-retry 0
> ring-speed 16
> dspu enable-host lsap 4
> dspu start TEST
> !
> interface TokenRing1
> no ip address
> no ip directed-broadcast
> shutdown
> !
> router ospf 100
> network 3.6.3.0 0.0.0.255 area 0
> network 6.6.6.6 0.0.0.0 area 0
> network 66.66.66.0 0.0.0.255 area 0
> !
> ip classless
> !
> !
> !
> line con 0
> transport input none
> line aux 0
> line vty 0 4
> login
> !
> end
>
> r6#
>
> r5#sh run
> Building configuration...
>
> Current configuration : 867 bytes
> !
> version 12.1
> no service single-slot-reload-enable
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname r5
> !
> logging rate-limit console 10 except errors
> no logging console
> !
> ip subnet-zero
> no ip finger
> !
> cns event-service server
> !
> !
> !
> !
> !
> dspu pu TEST rmac 4444.4444.4444 rsap 4 lsap 4
> !
> interface Loopback0
> ip address 5.5.5.5 255.255.255.255
> !
> interface Ethernet0
> mac-address 2222.2222.2222
> ip address 11.11.11.5 255.255.255.0
> dspu enable-pu lsap 4
> dspu start TEST
> !
> interface Serial0
> no ip address
> shutdown
> !
> interface Serial1
> no ip address
> shutdown
> !
> router ospf 100
> log-adjacency-changes
> network 5.5.5.5 0.0.0.0 area 0
> network 11.11.11.0 0.0.0.255 area 0
> !
> ip kerberos source-interface any
> ip classless
> no ip http server
> !
> !
> !
> line con 0
> transport input none
> line aux 0
> line vty 0 4
> login
> !
> end
>
> r5#
>
> ~-----Original Message-----
> ~From: Ahmed Mamoor Amimi [mailto:mamoor@ieee.org]
> ~Sent: Saturday, March 23, 2002 11:42 AM
> ~To: John Neiberger; Lupi, Guy; Parry.Chua@compaq.com; 'Jason
> ~Sinclair ';
> ~''Frank B' '
> ~Cc: ccielab@groupstudy.com
> ~Subject: Re: RE: DLSW and Source Bridge LONG
> ~
> ~
> ~I am also interested in this thread. as i was also doing but
> ~didnt not get
> ~through...
> ~
> ~I tested this with DSPU but no circuit formation....
> ~
> ~I guess this is the issue of cononical/non-cononical.
> ~
> ~
> ~-Mamoor
> ~
> ~
> ~----- Original Message -----
> ~From: John Neiberger <neiby@ureach.com>
> ~To: Lupi, Guy <Guy.Lupi@eurekaggn.com>; <Parry.Chua@compaq.com>; 'Jason
> ~Sinclair ' <sinclairj@powertel.com.au>; ''Frank B' '
> ~<frank@buff-net.com>
> ~Cc: <ccielab@groupstudy.com>
> ~Sent: Saturday, March 23, 2002 9:16 PM
> ~Subject: Re: RE: DLSW and Source Bridge LONG
> ~
> ~
> ~> I'm going to make a guess here. For SRB to work, the end
> ~> devices must be aware that they are using SRB. This is
> ~> obviously not the case with TB.
> ~>
> ~> In your lab, when you had your router configured for SRB, did
> ~> you have your workstations also configured for SRB? If not,
> ~> that might explain why your SRB setup didn't work but your TB
> ~> setup did.
> ~>
> ~> I just woke up so don't blame me if I completely wrong. :-)
> ~>
> ~> John
> ~>
> ~>
> ~>
> ~> ---- On Sat, 23 Mar 2002, Lupi, Guy (Guy.Lupi@eurekaggn.com)
> ~> wrote:
> ~>
> ~> > Ok, here it is next weekend, and I have set up this scenario
> ~> again.
> ~> > Here is
> ~> > the output and config of r3 when it is NOT working:
> ~> >
> ~> > r3#sh conf
> ~> > Using 960 out of 32762 bytes
> ~> > !
> ~> > version 12.1
> ~> > service timestamps debug uptime
> ~> > service timestamps log uptime
> ~> > no service password-encryption
> ~> > !
> ~> > hostname r3
> ~> > !
> ~> > no logging console
> ~> > !
> ~> > !
> ~> > !
> ~> > !
> ~> > !
> ~> > ip subnet-zero
> ~> > no ip domain-lookup
> ~> > !
> ~> > !
> ~> > !
> ~> > !
> ~> > !
> ~> > source-bridge ring-group 12
> ~> > dlsw local-peer peer-id 3.3.3.3 group 83 cost 1 lf 1500
> ~> > dlsw remote-peer 0 tcp 8.8.8.8 lf 1500
> ~> > !
> ~> > interface Loopback0
> ~> > ip address 3.3.3.3 255.255.255.255
> ~> > !
> ~> > interface Serial0
> ~> > ip address 3.8.3.3 255.255.255.0
> ~> > no fair-queue
> ~> > !
> ~> > interface Serial1
> ~> > no ip address
> ~> > shutdown
> ~> > !
> ~> > interface TokenRing0
> ~> > ip address 33.33.33.33 255.255.255.0
> ~> > ring-speed 16
> ~> > source-bridge 1 1 12
> ~> > source-bridge spanning
> ~> > !
> ~> > interface BRI0
> ~> > no ip address
> ~> > shutdown
> ~> > isdn x25 static-tei 0
> ~> > !
> ~> > router ospf 100
> ~> > log-adjacency-changes
> ~> > passive-interface TokenRing0
> ~> > network 3.3.3.3 0.0.0.0 area 0
> ~> > network 3.8.3.0 0.0.0.255 area 0
> ~> > network 198.207.193.0 0.0.0.0 area 0
> ~> > !
> ~> > ip classless
> ~> > ip http server
> ~> > !
> ~> > !
> ~> > bridge 1 protocol ieee
> ~> > !
> ~> > line con 0
> ~> > line aux 0
> ~> > line vty 0 4
> ~> > !
> ~> > end
> ~> >
> ~> > r3#sh dlsw reach
> ~> > DLSw Local MAC address reachability cache list
> ~> > Mac Addr status Loc. port rif
> ~> > 0000.306c.cf50 FOUND LOCAL TokenRing0
> ~> 0690.0011.00C0
> ~> >
> ~> > DLSw Remote MAC address reachability cache list
> ~> > Mac Addr status Loc. peer
> ~> >
> ~> > DLSw Local NetBIOS Name reachability cache list
> ~> > NetBIOS Name status Loc. port rif
> ~> >
> ~> > DLSw Remote NetBIOS Name reachability cache list
> ~> > NetBIOS Name status Loc. peer
> ~> >
> ~> > r3#sh dlsw peer
> ~> > Peers: state pkts_rx pkts_tx type
> ~> drops ckts TCP
> ~> > uptime
> ~> > TCP 8.8.8.8 CONNECT 38 59 conf
> ~> 0 0 0
> ~> > 00:11:19
> ~> > Total number of connected peers: 1
> ~> > Total number of connections: 1
> ~> >
> ~> > r3#
> ~> >
> ~> >



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:57:24 GMT-3