RE: IPX Eigrp with static SAP

From: Nelson Salvatorelli (nsalvato@xxxxxxxxx)
Date: Sun Mar 24 2002 - 22:00:48 GMT-3


   
Hi,

I was curious (and a bit exceptical) and tried this scenario in my lab... and i
t worked...!

My configs below... Didn't have to disable split horizon... Since this is a ful
l mesh topology... Disabling split horizon could cause loops...

My topology was:

                                                        wgr1
                                                          |s2/0
                                                          |
                                                          |
                                                    FR_Switch
                                                    / \
                                                   / \
                                                  /s2/0 \ s2/0
                                                wgr2 wgr3
                                                  |e0/0 |e0/0
                                             ---+------------+---

Config details:

- IPX Netw C in NBMA cloud
- IPX Netw 2F in Ethernet link between wgr2 and wgr3
- IPX Netw CAFI, FEA and FAFA on wgr2, wgr3 and wgr1 respectively on each loopb
ack0 interface
- IPX static servers configured on each router

Hope it helps...

-nelson

---- wgr1 ----

version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname wgr1r1
!
!
clock timezone GMT 0
ip subnet-zero
no ip domain-lookup
!
ipx routing 0000.0000.0001
!
!
!
interface Loopback0
 no ip address
 ipx network FAFA
!
interface Ethernet0/0
 no ip address
 shutdown
!
interface Ethernet1/0
 no ip address
 shutdown
!
interface Serial2/0
 no ip address
 encapsulation frame-relay
 logging event dlci-status-change
 ipx network C
 no fair-queue
 frame-relay map ipx C.0000.0000.0002 102 broadcast
 frame-relay map ipx C.0000.0000.0003 103 broadcast
!
interface Serial3/0
 no ip address
 shutdown
!
interface Serial4/0
 no ip address
 shutdown
!
interface Serial5/0
 no ip address
 shutdown
!
interface Serial6/0
 no ip address
 shutdown
!
ip classless
no ip http server
ip pim bidir-enable
!
!
!
!
ipx router eigrp 100
 network C
 log-neighbor-changes
!
!
ipx router rip
 no network C
 no network FAFA
!
!
ipx sap 5 APPSERV FAFA.0000.0000.0030 498 7
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
end

wgr1r1#sh ipx eigrp neigh

IPX EIGRP Neighbors for process 100
H Address Interface Hold Uptime SRTT RTO Q Seq Type
                                        (sec) (ms) Cnt Num
1 C.0000.0000.0003 Se2/0 163 00:23:15 387 2322 0 11
0 C.0000.0000.0002 Se2/0 156 00:23:16 438 2628 0 11
wgr1r1#
wgr1r1#
wgr1r1#sh ipx route
Codes: C - Connected primary network, c - Connected secondary network
       S - Static, F - Floating static, L - Local (internal), W - IPXWAN
       R - RIP, E - EIGRP, N - NLSP, X - External, A - Aggregate
       s - seconds, u - uses, U - Per-user static/Unknown, H - Hold-down

5 Total IPX routes. Up to 1 parallel paths and 16 hops allowed.

No default route known.

C C (FRAME-RELAY), Se2/0
C FAFA (UNKNOWN), Lo0
E 2F [2195456/1] via C.0000.0000.0003, age 00:03:38,
                         1u, Se2/0
E FEA [2297856/0] via C.0000.0000.0003, age 00:09:56,
                         3u, Se2/0
E CAFE [2297856/0] via C.0000.0000.0002, age 00:09:56,
                         3u, Se2/0
wgr1r1#sh ipx ser
Codes: S - Static, P - Periodic, E - EIGRP, N - NLSP, H - Holddown, + = detail
U - Per-user static
3 Total IPX Servers

Table ordering is based on routing and server info

   Type Name Net Address Port Route Hops Itf
E 4 PRINTER CAFE.0000.0000.0010:0496 2297856/00 2 Se2/
0
S 5 APPSERV FAFA.0000.0000.0030:0498 conn 7 Lo0
E 7 FILE FEA.0000.0000.0020:0497 2297856/00 11 Se2/
0
wgr1r1#

---- wgr2 ----

!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname wg1r2
!
!
ip subnet-zero
no ip domain-lookup
!
ipx routing 0000.0000.0002
!
!
!
interface Loopback0
 no ip address
 ipx network CAFE
!
interface Ethernet0/0
 no ip address
 ipx network 2F
!
interface Ethernet1/0
 no ip address
 shutdown
!
interface Serial2/0
 no ip address
 encapsulation frame-relay
 logging event dlci-status-change
 ipx network C
 no fair-queue
 frame-relay map ipx C.0000.0000.0001 201 broadcast
 frame-relay map ipx C.0000.0000.0003 203 broadcast
!
interface Serial3/0
 no ip address
 shutdown
!
interface Serial4/0
 no ip address
 shutdown
!
interface Serial5/0
 no ip address
 shutdown
!
interface Serial6/0
 no ip address
 shutdown
!
ip classless
no ip http server
ip pim bidir-enable
!
!
!
!
ipx router eigrp 100
 network CAFE
 network C
 log-neighbor-changes
!
!
ipx router rip
 no network CAFE
 no network C
!
!
ipx sap 4 PRINTER CAFE.0000.0000.0010 496 1
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
end

wg1r2#sh ipx eigrp neigh

IPX EIGRP Neighbors for process 100
H Address Interface Hold Uptime SRTT RTO Q Seq Type
                                        (sec) (ms) Cnt Num
1 C.0000.0000.0003 Se2/0 153 00:23:25 407 2442 0 11
0 C.0000.0000.0001 Se2/0 149 00:23:29 166 996 0 10
wg1r2#
wg1r2#sh ipx route
Codes: C - Connected primary network, c - Connected secondary network
       S - Static, F - Floating static, L - Local (internal), W - IPXWAN
       R - RIP, E - EIGRP, N - NLSP, X - External, A - Aggregate
       s - seconds, u - uses, U - Per-user static/Unknown, H - Hold-down

5 Total IPX routes. Up to 1 parallel paths and 16 hops allowed.

No default route known.

C C (FRAME-RELAY), Se2/0
C 2F (NOVELL-ETHER), Et0/0
C CAFE (UNKNOWN), Lo0
E FEA [2297856/0] via C.0000.0000.0003, age 00:10:18,
                         8u, Se2/0
E FAFA [2297856/1] via C.0000.0000.0001, age 00:02:52,
                         8u, Se2/0
wg1r2#
wg1r2#sh ipx ser
Codes: S - Static, P - Periodic, E - EIGRP, N - NLSP, H - Holddown, + = detail
U - Per-user static
3 Total IPX Servers

Table ordering is based on routing and server info

   Type Name Net Address Port Route Hops Itf
S 4 PRINTER CAFE.0000.0000.0010:0496 conn 1 Lo0
P 5 APPSERV FAFA.0000.0000.0030:0498 2297856/01 2 Et0/
0
E 7 FILE FEA.0000.0000.0020:0497 2297856/00 11 Se2/
0
wg1r2#
wg1r2#

---- wgr3 ----

!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname wg1r3
!
!
clock timezone GMT 0
ip subnet-zero
no ip domain-lookup
!
ipx routing 0000.0000.0003
!
!
!
interface Loopback0
 no ip address
 ipx network FEA
!
interface Ethernet0/0
 no ip address
 ipx network 2F
!
interface Ethernet1/0
 no ip address
 shutdown
!
interface Serial2/0
 no ip address
 encapsulation frame-relay
 logging event dlci-status-change
 ipx network C
 no fair-queue
 frame-relay map ipx C.0000.0000.0001 301 broadcast
 frame-relay map ipx C.0000.0000.0002 302 broadcast
!
interface Serial3/0
 no ip address
 shutdown
!
interface Serial4/0
 no ip address
 shutdown
!
interface Serial5/0
 no ip address
 shutdown
!
interface Serial6/0
 no ip address
 shutdown
!
ip classless
no ip http server
ip pim bidir-enable
!
!
!
!
ipx router eigrp 100
 network C
 network FEA
 log-neighbor-changes
!
!
ipx router rip
 no network FEA
 no network C
!
!
ipx sap 7 FILE FEA.0000.0000.0020 497 10
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
end

wg1r3#sh ipx eigrp neigh

IPX EIGRP Neighbors for process 100
H Address Interface Hold Uptime SRTT RTO Q Seq Type
                                        (sec) (ms) Cnt Num
1 C.0000.0000.0002 Se2/0 150 00:23:22 207 1242 0 11
0 C.0000.0000.0001 Se2/0 153 00:23:25 161 966 0 10
wg1r3#
wg1r3#sh ipx route
Codes: C - Connected primary network, c - Connected secondary network
       S - Static, F - Floating static, L - Local (internal), W - IPXWAN
       R - RIP, E - EIGRP, N - NLSP, X - External, A - Aggregate
       s - seconds, u - uses, U - Per-user static/Unknown, H - Hold-down

5 Total IPX routes. Up to 1 parallel paths and 16 hops allowed.

No default route known.

C C (FRAME-RELAY), Se2/0
C 2F (NOVELL-ETHER), Et0/0
C FEA (UNKNOWN), Lo0
E CAFE [2297856/0] via C.0000.0000.0002, age 00:10:09,
                         7u, Se2/0
E FAFA [2297856/1] via C.0000.0000.0001, age 00:02:42,
                         5u, Se2/0
wg1r3#sh ipx ser
Codes: S - Static, P - Periodic, E - EIGRP, N - NLSP, H - Holddown, + = detail
U - Per-user static
3 Total IPX Servers

Table ordering is based on routing and server info

   Type Name Net Address Port Route Hops Itf
E 4 PRINTER CAFE.0000.0000.0010:0496 2297856/00 2 Se2/
0
P 5 APPSERV FAFA.0000.0000.0030:0498 2297856/01 2 Et0/
0
S 7 FILE FEA.0000.0000.0020:0497 conn 10 Lo0
wg1r3#



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:57:20 GMT-3