From: Gregg Malcolm (greggm@xxxxxxxxxxxxx)
Date: Wed Mar 20 2002 - 16:30:07 GMT-3
Try putting a /24 mask on your bgp network 1.1.1.1 statement. Looks like
it's defaulting to classfull behavior.
HTH, Gregg
----- Original Message -----
From: "Lab Candidate" <labccie@yahoo.com>
To: <ccielab@groupstudy.com>
Sent: Wednesday, March 20, 2002 10:47 AM
Subject: BGP routes don't show up in BGP table
> Here is a basic BGP setup with r1 and r2:
> r1 AS100 r2 AS200
> s0----------------s0
> lo0 1.1.1.1 lo0 2.2.2.2
> I am advertising both r1's and r2's loopbacks lo0 by putting under a
network statement.
> but somehow they never showed up in the other's BGP table. What am I doing
wrong?
> here is the configs and output from both r1 and r2:
>
> r1#
> 1d00h: BGP: 192.168.1.2 went from Idle to Active
> 1d00h: BGP: 192.168.1.2 open active, delay 15324ms
> 1d00h: BGP: 192.168.1.2 open active, local address 192.168.1.1
> 1d00h: BGP: scanning routing tables
> 1d00h: BGP: nettable_scan: invalidate local path for 1.0.0.0/8
> 1d00h: BGP: nettable_scan: invalidate sourced path for 1.0.0.0/8
> 1d00h: BGP: no valid path for 1.0.0.0/8
> 1d00h: BGP: nettable_walker 1.0.0.0/8 no best path
>
> r1#sh ip ro
> Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
> U - per-user static route, o - ODR
>
> Gateway of last resort is not set
>
> 1.0.0.0/24 is subnetted, 1 subnets
> C 1.1.1.0 is directly connected, Loopback0
> C 192.168.1.0/24 is directly connected, Serial0
>
> r1#sh ip bgp
> {blank}
> r1#
>
> r1#sh run
> Building configuration...
>
> Current configuration:
> !
> version 12.0
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname r1
> !
> !
> ip subnet-zero
> !
> !
> !
> interface Loopback0
> ip address 1.1.1.1 255.255.255.0
> no ip directed-broadcast
> !
> interface Ethernet0
> no ip address
> no ip directed-broadcast
> shutdown
> !
> interface Serial0
> ip address 192.168.1.1 255.255.255.0
> no ip directed-broadcast
> clockrate 64000
> !
> interface Serial1
> no ip address
> no ip directed-broadcast
> shutdown
> !
> router bgp 100
> network 1.1.1.1
> neighbor 192.168.1.2 remote-as 200
> !
> ip classless
> !
> !
> line con 0
> exec-timeout 0 0
> logging synchronous
> transport input none
> line aux 0
> line vty 0 4
> !
> end
>
> r1#
> r1#sh ip bgp nei
> BGP neighbor is 192.168.1.2, remote AS 200, external link
> Index 1, Offset 0, Mask 0x2
> BGP version 4, remote router ID 2.2.2.2
> BGP state = Established, table version = 25, up for 00:03:02
> Last read 00:00:03, hold time is 180, keepalive interval is 60 seconds
> Minimum time between advertisement runs is 30 seconds
> Received 6 messages, 0 notifications, 0 in queue
> Sent 6 messages, 0 notifications, 0 in queue
> Prefix advertised 0, suppressed 0, withdrawn 0
> Connections established 1; dropped 0
> Last reset never
> 0 accepted prefixes consume 0 bytes
> 0 history paths consume 0 bytes
> Connection state is ESTAB, I/O status: 1, unread input bytes: 0
> Local host: 192.168.1.1, Local port: 11000
> Foreign host: 192.168.1.2, Foreign port: 179
>
> Enqueued packets for retransmit: 0, input: 0 mis-ordered: 0 (0 bytes)
>
> Event Timers (current time is 0x545E3C0):
> Timer Starts Wakeups Next
> Retrans 19 12 0x0
> TimeWait 0 0 0x0
> AckHold 6 2 0x0
> SendWnd 0 0 0x0
> KeepAlive 0 0 0x0
> GiveUp 0 0 0x0
> PmtuAger 0 0 0x0
> DeadWait 0 0 0x0
>
> iss: 278568032 snduna: 278568157 sndnxt: 278568157 sndwnd: 16260
> irs: 2897909981 rcvnxt: 2897910106 rcvwnd: 16260 delrcvwnd: 124
>
> SRTT: 614 ms, RTTO: 4262 ms, RTV: 1517 ms, KRTT: 0 ms
> minRTT: 24 ms, maxRTT: 300 ms, ACK hold: 200 ms
> Flags: higher precedence, nagle
>
> Datagrams (max data segment is 1460 bytes):
> Rcvd: 11 (out of order: 0), with data: 6, total data bytes: 124
> Sent: 10 (retransmit: 12), with data: 6, total data bytes: 124
> r1#
>
> =================== r2 config and debug =================
> r2#sh run
> Building configuration...
>
> Current configuration:
> !
> version 12.0
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname r2
> !
> !
> ip subnet-zero
> !
> !
> !
> interface Loopback0
> ip address 2.2.2.2 255.255.255.0
> no ip directed-broadcast
> !
> interface Ethernet0
> no ip address
> no ip directed-broadcast
> shutdown
> !
> interface Serial0
> ip address 192.168.1.2 255.255.255.0
> no ip directed-broadcast
> !
> interface Serial1
> no ip address
> no ip directed-broadcast
> shutdown
> !
> router bgp 200
> network 2.2.2.2
> neighbor 192.168.1.1 remote-as 100
> !
> ip classless
> !
> !
> line con 0
> transport input none
> line aux 0
> line vty 0 4
> !
> end
>
> r2#
> r2#sh ip int b
> Interface IP-Address OK? Method Status
Protocol
>
> Ethernet0 unassigned YES unset administratively down
down
>
> Loopback0 2.2.2.2 YES manual up up
>
> Serial0 192.168.1.2 YES manual up up
>
> Serial1 unassigned YES unset administratively down
down
>
> r2#sh ip ro
> Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
> U - per-user static route, o - ODR
>
> Gateway of last resort is not set
>
> 2.0.0.0/24 is subnetted, 1 subnets
> C 2.2.2.0 is directly connected, Loopback0
> C 192.168.1.0/24 is directly connected, Serial0
>
> r2#sh ip bgp
> {blank}
> r2#
>
> r2#sh ip bgp nei
> r2#sh ip bgp neighbors
> BGP neighbor is 192.168.1.1, remote AS 100, external link
> Index 1, Offset 0, Mask 0x2
> BGP version 4, remote router ID 1.1.1.1
> BGP state = Established, table version = 23, up for 00:00:17
> Last read 00:00:16, hold time is 180, keepalive interval is 60 seconds
> Minimum time between advertisement runs is 30 seconds
> Received 3 messages, 0 notifications, 0 in queue
> Sent 3 messages, 0 notifications, 0 in queue
> Prefix advertised 0, suppressed 0, withdrawn 0
> Connections established 1; dropped 0
> Last reset never
> 0 accepted prefixes consume 0 bytes
> 0 history paths consume 0 bytes
> Connection state is ESTAB, I/O status: 1, unread input bytes: 0
> Local host: 192.168.1.2, Local port: 179
> Foreign host: 192.168.1.1, Foreign port: 11000
>
> Enqueued packets for retransmit: 0, input: 0 mis-ordered: 0 (0 bytes)
>
> Event Timers (current time is 0xF02CC):
> Timer Starts Wakeups Next
> Retrans 4 0 0x0
> TimeWait 0 0 0x0
> AckHold 3 2 0x0
> SendWnd 0 0 0x0
> KeepAlive 0 0 0x0
> GiveUp 0 0 0x0
> PmtuAger 0 0 0x0
> DeadWait 0 0 0x0
>
> iss: 2897909981 snduna: 2897910049 sndnxt: 2897910049 sndwnd: 16317
> irs: 278568032 rcvnxt: 278568100 rcvwnd: 16317 delrcvwnd: 67
>
> SRTT: 710 ms, RTTO: 4442 ms, RTV: 1511 ms, KRTT: 0 ms
> minRTT: 16 ms, maxRTT: 300 ms, ACK hold: 200 ms
> Flags: passive open, nagle, gen tcbs
>
> Datagrams (max data segment is 1460 bytes):
> Rcvd: 6 (out of order: 0), with data: 3, total data bytes: 67
> Sent: 6 (retransmit: 0), with data: 3, total data bytes: 67
> r2#sh ip bgp neighbors ?
> A.B.C.D Neighbor to display information about
> <cr>
>
>
>
>
>
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:57:14 GMT-3