From: Brian Lodwick (xpranax@xxxxxxxxxxx)
Date: Wed Mar 13 2002 - 19:02:27 GMT-3
I can't believe I left out the most important piece of the puzzle, I was in
a hurry.
Sorry about that.
r6#sh run
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r6
!
!
ip subnet-zero
no ip routing
no ip domain-lookup
!
voice-port 1/0/0
!
voice-port 1/1/0
!
voice-port 1/0/1
!
voice-port 1/1/1
!
partition flash 2 8 8
!
!
source-bridge ring-group 100
source-bridge transparent 100 10 2 1
!
!
interface Ethernet0/0
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
bridge-group 1
!
interface Serial0/0
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
shutdown
!
interface TokenRing0/0
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
ring-speed 16
source-bridge 6 10 100
source-bridge spanning
!
ip classless
!
!
bridge 1 protocol ieee
bridge 1 bitswap_layer3_addresses
alias exec ip sh ip route
alias exec int sh ip int brief
alias exec ipx sh ipx route
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
Here's some other good stuff you can use to see the RIF information so that
you can take the MAC address and ring information to practice reading RIF's.
r4#sh int tok 0
TokenRing0 is up, line protocol is up
Hardware is TMS380, address is 0000.3090.f134 (bia 0000.3090.f134)
Internet address is 34.0.0.4/24
MTU 1500 bytes, BW 16000 Kbit, DLY 630 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation SNAP, loopback not set
r4#sh arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 34.0.0.3 0 0000.3052.9963 SNAP TokenRing0
Internet 34.0.0.4 - 0000.3090.f134 SNAP TokenRing0
r4#sh rif
Codes: * interface, - static, + remote
Dst HW Addr Src HW Addr How Idle(min) Vlan Routing Information Field
0005.772b.8c82 N/A To0 0 - -
0000.3090.f134 N/A To0 * - -
0000.3052.9963 N/A To0 0 - 0A10.0041.006A.0642.00A0
r3#sh int e0
Ethernet0 is up, line protocol is up
Hardware is Lance, address is 0000.0c4a.99c6 (bia 0000.0c4a.99c6)
Internet address is 34.0.0.3/24
MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec, rely 255/255, load 1/255
Encapsulation ARPA, loopback not set, keepalive set (10 sec)
r3#sh arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 34.0.0.3 - 0000.0c4a.99c6 ARPA Ethernet0
Internet 34.0.0.4 1 0000.0c09.8f2c ARPA Ethernet0
r6#sh bridge
Total of 300 station blocks, 297 free
Codes: P - permanent, S - self
Bridge Group 1:
Address Action Interface Age RX count TX count
0000.0c4a.99c6 forward Ethernet0/0 2 113 104
00e0.1ee7.fd92 forward Ethernet0/0 0 18 0
0000.0c09.8f2c forward RingGroup100 2 107 105
r6#sh rif
Codes: * interface, - static, + remote
Dst HW Addr Src HW Addr How Idle (min) Routing Information Field
4000.0000.2000 N/A - 0 -
0000.3090.f134 N/A BG1 2 0A90.0041.006A.0642.00A0
0000.3052.9963 N/A To0/0 4 0890.00A2.064A.0060
000a.cec6.2587 N/A To0/0 * -
r6#sh source-bridge
Local Interfaces: receive transmit
srn bn trn r p s n max hops cnt cnt drops
To0/0 6 10 100 * f 7 7 7 104 134 0
Global RSRB Parameters:
TCP Queue Length maximum: 100
Ring Group 100:
No TCP peername set, TCP transport disabled
Maximum output TCP queue length, per peer: 100
Rings:
bn: 2 rn: 10 locvrt ma: 400a.cec6.2507 Bridge-group 1 fwd: 104
bn: 10 rn: 6 local ma: 400a.cec6.2587 TokenRing0/0 fwd: 105
Explorers: ------- input ------- ------- output -------
spanning all-rings total spanning all-rings total
To0/0 3 0 3 29 0 29
Explorer fastswitching enabled
Local switched: 14 flushed 0 max Bps 38400
rings inputs bursts throttles output drops
To0/0 0 0 0 0
>From: Anand Ghody <vze2hq65@verizon.net>
>To: Brian Lodwick <xpranax@hotmail.com>
>CC: ccielab@groupstudy.com
>Subject: Re: Translational Bridging is driving me nuts!!! CONFIG
>Date: Wed, 13 Mar 2002 15:54:02 -0500
>
>Brian,
>
> I may have missed it, put could to show me the config of the
>translational bridge (r6). Thnaks.
>
>Anand
>
>
>Brian Lodwick wrote:
>
>>A little while back there was a question to the list talking about
>>translational bridging and there was some controversy if you could
>>send layer-3 traffic through a router serving as a translational bridge.
>>
>>I also said I would lab it up for the original person who posted their
>>config to prove that you can.
>>
>>So here it is.
>>My setup:
>>
>>r3)e0 -----CAT5000----- e0/0(r6)tok0/0 -----CAT3920---- tok0(r4
>>
>>
>>r3's ethernet 0 interface is addressed 34.0.0.3 255.255.255.0
>>r4's token-ring 0 interface is addressed 34.0.0.4 255.255.255.0
>>
>>r3#ping
>>Protocol [ip]:
>>Target IP address: 34.0.0.4
>>Repeat count [5]: 100
>>Datagram size [100]:
>>Timeout in seconds [2]:
>>Extended commands [n]:
>>Sweep range of sizes [n]:
>>Type escape sequence to abort.
>>Sending 100, 100-byte ICMP Echos to 34.0.0.4, timeout is 2 seconds:
>>!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
>>!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
>>Success rate is 100 percent (100/100), round-trip min/avg/max = 8/9/12 ms
>>
>>r4#ping
>>Protocol [ip]:
>>Target IP address: 34.0.0.3
>>Repeat count [5]: 100
>>Datagram size [100]:
>>Timeout in seconds [2]:
>>Extended commands [n]:
>>Sweep range of sizes [n]:
>>Type escape sequence to abort.
>>Sending 100, 100-byte ICMP Echos to 34.0.0.3, timeout is 2 seconds:
>>!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
>>!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
>>Success rate is 100 percent (100/100), round-trip min/avg/max = 4/9/12 ms
>>
>>
>>Below are the configs from all routers and switches:
>>
>>r3#sh run
>>Building configuration...
>>
>>Current configuration:
>>!
>>version 12.0
>>service timestamps debug uptime
>>service timestamps log uptime
>>no service password-encryption
>>!
>>hostname r3
>>!
>>!
>>ip subnet-zero
>>no ip domain-lookup
>>!
>>!
>>!
>>interface Ethernet0
>>ip address 34.0.0.3 255.255.255.0
>>no ip directed-broadcast
>>!
>>interface Serial0
>>no ip address
>>no ip directed-broadcast
>>encapsulation frame-relay
>>no ip mroute-cache
>>no fair-queue
>>!
>>interface Serial0.301 point-to-point
>>ip address 10.0.0.3 255.255.255.0
>>no ip directed-broadcast
>>frame-relay interface-dlci 301 protocol ip 10.0.0.1
>>!
>>interface Serial1
>>no ip address
>>no ip directed-broadcast
>>shutdown
>>!
>>ip classless
>>!
>>alias exec ip sh ip route
>>alias exec int sh ip int brief
>>alias exec ipx sh ipx route
>>!
>>line con 0
>>transport input none
>>line aux 0
>>line vty 0 4
>>login
>>!
>>end
>>
>>
>>
>>r4#sh run
>>Building configuration...
>>
>>Current configuration : 857 bytes
>>!
>>version 12.2
>>no service single-slot-reload-enable
>>service timestamps debug uptime
>>service timestamps log uptime
>>no service password-encryption
>>!
>>hostname r4
>>!
>>logging rate-limit console 10 except errors
>>!
>>ip subnet-zero
>>no ip finger
>>no ip domain-lookup
>>!
>>no ip dhcp-client network-discovery
>>!
>>!
>>!
>>!
>>interface Serial0
>>no ip address
>>encapsulation frame-relay
>>!
>>interface Serial0.401 point-to-point
>>ip address 10.0.0.4 255.255.255.0
>>frame-relay interface-dlci 401 protocol ip 10.0.0.1
>>!
>>interface Serial1
>>no ip address
>>shutdown
>>!
>>interface TokenRing0
>>mtu 1500
>>ip address 34.0.0.4 255.255.255.0
>>ring-speed 16
>>multiring all
>>!
>>ip kerberos source-interface any
>>ip classless
>>ip http server
>>!
>>!
>>alias exec ip sh ip route
>>alias exec int sh ip int brief
>>alias exec ipx sh ipx route
>>!
>>line con 0
>>transport input none
>>line aux 0
>>line vty 0 4
>>login
>>!
>>end
>>
>>(r6 tok0/0 is plugged into port 4 on the 3920, and r4 tok0 is plugged
>>into port 2 on the 3920)
>>
>>TrBRF/TrCRF ID Brdg/Rng Ports Local State
>>Bridge1 10 0x01 preferred
>> Ring4 15 0x04 yes preferred
>> Ring6 20 0x06 yes preferred
>>
>>
>>Port Mode TrCRF TrBRF
>> 1 Static trcrf-default trbrf-default
>> 2 Static Ring4 Bridge1
>> 3 Static trcrf-default trbrf-default
>> 4 Static Ring6 Bridge1
>>
>>
>>VLAN ID 10
>>VLAN Name Bridge1
>>State Operational
>>MTU 1500
>>Bridge Number 0x01
>>
>>
>>VLAN ID 15
>>VLAN Name Ring4
>>Parent VLAN Bridge1
>>State Operational
>>Ring Number 0x04
>>Bridging Mode SRB
>>Max ARE Bridge Hop Count 7
>>Max STE Bridge Hop Count 7
>>Backup CRF No
>>Ports in TrCRF 2
>>
>>
>>VLAN ID 20
>>VLAN Name Ring6
>>Parent VLAN Bridge1
>>State Operational
>>Ring Number 0x06
>>Bridging Mode SRB
>>Max ARE Bridge Hop Count 7
>>Max STE Bridge Hop Count 7
>>Backup CRF No
>>Ports in TrCRF 4
>>
>>(r6 eth0/0 is plugged into port 3/3 on the CAT5000, and r3 eth0 is
>>plugged into port 3/1 on the CAT5000) this stuff really has no bearing
>>except ofcourse the ports need to be in the same VLAN. Nothing
>>different on the CAT5000.
>>
>>
>>cat5 (enable) sh vlan
>>VLAN Name Status IfIndex Mod/Ports, Vlans
>>---- -------------------------------- --------- -------
>>------------------------
>>1 default active 91 1/1-2
>> 3/1,3/3,3/7-12
>>2 VlanA active 96
>>3 VlanB active 97 3/6
>>4 VlanC active 98 3/5
>>10 VLAN0010 active 99 3/2,3/4
>>
>>
>>
>>>>>Brian
>>>>
>>
>>
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:57:04 GMT-3