Re: NAT and Policy Routing

From: David A Goddard (goddardtek@xxxxxxxxx)
Date: Tue Mar 12 2002 - 19:44:03 GMT-3


   
Bob, I got it to work, and am not sure w/out looking at your configs what's
wrong with your setup. But one thing for sure that I have found to check on,
is to make sure you have route-cache turned off of your outside NAT
interface.

  I have R1 in use as a workstation with a default route to R2

  R2 connects to R3 and R4 via Frame relay
  R3 and R4 are connected via ethernet

R1
| - (ethernet)
R2
| \ (frame relay)
| \
R3----R4 (ethernet)

here are my configs for R2 (I'm using OSPF for routing)

!
hostname R2
!
interface Ethernet0
 ip address 10.0.0.2 255.255.255.0 secondary
 ip address 200.0.0.2 255.255.255.0
 ip nat inside
 ip policy route-map POLICY
!
interface Serial0
 no ip address
 encapsulation frame-relay
 no ip route-cache
 no ip mroute-cache
!
interface Serial0.3 point-to-point
 ip address 30.0.0.2 255.255.255.0
 ip nat outside
 no ip route-cache
 no ip mroute-cache
 frame-relay interface-dlci 203
!
interface Serial0.4 point-to-point
 ip address 40.0.0.2 255.255.255.0
 ip nat outside
 no ip route-cache
 no ip mroute-cache
 frame-relay interface-dlci 204
!
router ospf 110
 network 30.0.0.0 0.0.0.255 area 0
 network 40.0.0.0 0.0.0.255 area 0
 network 200.0.0.0 0.0.0.255 area 0
!
ip nat pool NATME 200.0.0.5 200.0.0.31 prefix-length 27
ip nat inside source list 1 pool NATME overload
ip classless
!
access-list 1 permit 10.0.0.0 0.0.0.255 log
route-map POLICY permit 10
 match ip address 1
 set ip next-hop 30.0.0.3
!
!
end

hth,
Dave



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:57:02 GMT-3