oops! RE: trouble with dialer profile + multilink PPP + demand-ci rcuit

From: James.Irwin@xxxxxxxxxxxxx
Date: Wed Mar 06 2002 - 14:11:05 GMT-3


   
First rule in changing things when troubleshooting: Change only 1 thing at
a time!

Not following that rule, of course, caused me to overlook a statement in the
configs - and that was the problem with the link flapping!

I found it as soon as I posted a few minutes ago....everything works now,
perfectly.

****************************
My configs are as follows:
****************************
Calling Router:

interface BRI0
 no ip address
 encapsulation ppp
 ip ospf network point-to-point
 dialer pool-member 1
 isdn switch-type basic-net3
 no peer neighbor-route
 no cdp enable
!
interface Dialer1
 ip address 170.10.129.1 255.255.255.252
 encapsulation ppp
 ip ospf network point-to-point
 ip ospf cost 9999
 ip ospf demand-circuit
 dialer remote-name SanDiego
 dialer pool 1
 dialer idle-timeout 45
 dialer enable-timeout 5
 dialer string 1111
 dialer load-threshold 1 outbound
 dialer max-call 4096
 dialer-group 1
 no peer neighbor-route
 no cdp enable
 ppp multilink
!
router eigrp 1
 redistribute ospf 1
 passive-interface BRI0
 passive-interface Dialer1
 passive-interface Serial0
 network 170.10.0.0
 default-metric 1544 100 100 254 1500
 no auto-summary
!
router ospf 1
 redistribute eigrp 1 metric 100 subnets route-map Deny_bri
 passive-interface Serial1
 network 170.10.30.2 0.0.0.0 area 0
 network 170.10.129.1 0.0.0.0 area 0
 network 170.20.0.1 0.0.0.0 area 0
!
ip classless
no ip http server
!
access-list 5 deny 170.10.129.1
access-list 5 permit any
dialer-list 1 protocol ip permit
route-map Deny_bri deny 10
 match ip address 5
!
route-map Deny_bri permit 20
!
!

Called Router:

interface BRI0
 no ip address
 encapsulation ppp
 ip ospf network non-broadcast
 dialer pool-member 1
 isdn switch-type basic-net3
 no peer neighbor-route
!
interface Dialer1
 ip address 170.10.129.2 255.255.255.252
 encapsulation ppp
 ip ospf network point-to-point
 ip ospf cost 9999
 ip ospf demand-circuit
 dialer remote-name GreenBay
 dialer pool 1
 dialer string 2222
 dialer load-threshold 1 outbound
 dialer max-call 4096
 dialer-group 1
 no peer neighbor-route
 ppp multilink
!
router ospf 1
 network 170.10.29.1 0.0.0.0 area 0
 network 170.10.49.2 0.0.0.0 area 1
 network 170.10.129.2 0.0.0.0 area 0
 network 170.30.0.1 0.0.0.0 area 0
!
ip classless
no ip http server
!
dialer-list 1 protocol ip permit

********************************

Remember to use loopback interfaces on all ospf routers.

If having adjacency problems - check and double check your network
statements under the ospf process.

calling routers neighbors:
sh ip ospf nei

Neighbor ID Pri State Dead Time Address Interface
170.30.0.1 1 FULL/ - - 170.10.129.2 Dialer1
170.10.30.1 1 FULL/ - 00:00:35 170.10.30.1 Serial0

called router neighbors:
sh ip ospf nei

Neighbor ID Pri State Dead Time Address Interface
170.20.0.1 1 FULL/ - - 170.10.129.1 Dialer1
170.10.30.1 1 FULL/ - 00:00:34 170.10.29.2 Serial0
170.10.49.1 1 FULL/ - 00:00:34 170.10.49.1 Serial1

That's what it should look like using demand-circuit.

*******************************************************



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:56:55 GMT-3