From: Erick B. (erickbe@xxxxxxxxx)
Date: Wed Mar 06 2002 - 02:12:17 GMT-3
R1 probably isn't learning the 172.16.1.0/24 route.
On R2, s0/0 is 172.16.1.x/30 and s0/1 is
172.16.4.x/24. 172.16.x.x is a classful network to
RIP. Without considering the summary address
configured under OSPF, only 172.16.x.0/24 routes will
be sent out s0/1. The 172.16.1.0/30 will not get
advertised.
Now getting to the OSPF part and the summary-address
attempting to summarize the /30 to a /24. The way the
summary-address works was changed in 12.1 or 12.1T
code and a summary will not be created if that
interface is already part of OSPF. This is what you're
probably running into here.
HTH, Erick
--- John Neiberger <neiby@ureach.com> wrote:
> What does the routing table of R1 look like? Does
> it have a
> route back to R3?
>
> John
>
>
>
> ---- On Tue, 5 Mar 2002, Jeongwoo Park
> (Jpark@wams.com) wrote:
>
> > Here is the layout.
> > R1----R2-----R3.
> > On R3 I have the routes 172.16.6.1 and
> 172.16.7.1,which are
> R1's
> > loopback
> > interfaces.
> > But I can't ping those interfaces from R3.
> >
> > Here is config.
> > R1#wr t
> > #######
> > Current configuration:
> > !
> > version 10.2
> > service tcp-small-servers
> > !
> > hostname R1
> > !
> > enable password wams
> > !
> > ip subnet-zero
> > !
> > interface Loopback0
> > ip address 172.16.6.1 255.255.255.0
> > !
> > interface Loopback1
> > ip address 172.16.7.1 255.255.255.0
> > !
> > interface Ethernet0
> > no ip address
> > shutdown
> > !
> > interface Ethernet1
> > no ip address
> > shutdown
> > !
> > interface Serial0
> > ip address 172.16.4.2 255.255.255.0
> > shutdown
> > !
> > interface Serial1
> > ip address 172.16.4.2 255.255.255.0
> > !
> > router rip
> > network 172.16.0.0
> > !
> > ip host R2 172.16.5.1
> > ip host R3 172.16.20.1
> > ip classless
> > !
> > line con 0
> > line aux 0
> > transport input all
> > line vty 0 4
> > exec-timeout 0 0
> > password wams
> > login
> > telnet transparent
> > line vty 5 15
> > login
> > !
> > end
> >
> > R2#wr t
> > Building configuration...
> >
> > Current configuration : 1081 bytes
> > !
> > version 12.1
> > service timestamps debug uptime
> > service timestamps log uptime
> > no service password-encryption
> > !
> > hostname R2
> > !
> > !
> > !
> > !
> > !
> > !
> > ip subnet-zero
> > ip host R3 172.16.20.1
> > ip host R1 172.16.6.1
> > !
> > !
> > !
> > !
> > interface Loopback0
> > ip address 172.16.5.1 255.255.255.0
> > !
> > interface Ethernet0
> > no ip address
> > shutdown
> > !
> > interface Serial0
> > ip address 172.16.1.1 255.255.255.252
> > no fair-queue
> > clockrate 500000
> > !
> > interface Serial1
> > ip address 172.16.4.1 255.255.255.0
> > clockrate 500000
> > !
> > interface BRI0
> > no ip address
> > shutdown
> > isdn x25 static-tei 0
> > !
> > router ospf 1
> > log-adjacency-changes
> > summary-address 172.16.1.0 255.255.255.0
> > summary-address 172.16.20.0 255.255.255.0
> > redistribute rip metric 30 subnets
> > network 172.16.1.0 0.0.0.3 area 0
> > !
> > router rip
> > redistribute ospf 1
> > passive-interface Serial0
> > network 172.16.0.0
> > default-metric 2
> > !
> > ip classless
> > ip http server
> > !
> > alias exec r sh ip route
> > !
> > line con 0
> > exec-timeout 0 0
> > password wams
> > line aux 0
> > line vty 0 2
> > exec-timeout 0 0
> > privilege level 15
> > password wams
> > login
> > line vty 3 4
> > privilege level 15
> > password wams
> > login
> > !
> > end
> >
> > R3#wr t
> > Building configuration...
> >
> > Current configuration : 915 bytes
> > !
> > version 12.2
> > service timestamps debug uptime
> > service timestamps log uptime
> > no service password-encryption
> > !
> > hostname R3
> > !
> > enable password wams
> > !
> > ip subnet-zero
> > !
> > !
> > no ip domain-lookup
> > ip host R2 172.16.5.1
> > ip host R1 172.16.6.1
> > !
> > !
> > !
> > !
> > interface Loopback0
> > ip address 172.16.20.1 255.255.255.240
> > !
> > interface Loopback1
> > ip address 172.16.20.17 255.255.255.240
> > !
> > interface Ethernet0/0
> > no ip address
> > shutdown
> > half-duplex
> > !
> > interface Serial0/0
> > ip address 172.16.1.2 255.255.255.252
> > !
> > interface Ethernet0/1
> > no ip address
> > shutdown
> > half-duplex
> > !
> > router ospf 1
> > log-adjacency-changes
> > summary-address 172.16.20.0 255.255.255.0
> > redistribute connected subnets
> > network 172.16.1.0 0.0.0.3 area 0
> > network 172.16.20.0 0.0.0.15 area 0
> > !
> > ip classless
> > ip http server
> > !
> > alias exec r sh ip route
> > !
> > line con 0
> > line aux 0
> > transport input all
> > line vty 0 4
> > exec-timeout 0 0
> > password wams
> > login
> > line vty 5 15
> > login
> > !
> > end
> >
> > R3's routing table
> > R3#sh ip rou
> > Codes: C - connected, S - static, I - IGRP, R -
> RIP, M -
> mobile, B - BGP
> > D - EIGRP, EX - EIGRP external, O - OSPF,
> IA - OSPF
> inter area
> > N1 - OSPF NSSA external type 1, N2 - OSPF
> NSSA
> external type 2
> > E1 - OSPF external type 1, E2 - OSPF
> external type 2,
> E - EGP
> > i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS
> level-2, ia -
> IS-IS
> > inter
> > area
> > * - candidate default, U - per-user static
> route, o -
> ODR
> > P - periodic downloaded static route
> >
> > Gateway of last resort is not set
> >
> > 172.16.0.0/16 is variably subnetted, 8
> subnets, 3 masks
> > O 172.16.20.0/24 is a summary, 00:35:06,
> Null0
> > C 172.16.20.0/28 is directly connected,
> Loopback0
> > O E2 172.16.4.0/24 [110/30] via 172.16.1.1,
> 00:29:00,
> Serial0/0
> > C 172.16.20.16/28 is directly connected,
> Loopback1
> > O E2 172.16.5.0/24 [110/30] via 172.16.1.1,
> 00:29:00,
> Serial0/0
> > O E2 172.16.6.0/24 [110/30] via 172.16.1.1,
> 00:29:00,
> Serial0/0
> > O E2 172.16.7.0/24 [110/30] via 172.16.1.1,
> 00:29:00,
> Serial0/0
> > C 172.16.1.0/30 is directly connected,
> Serial0/0
> > R3#
> > R3#ping 172.16.6.1
> >
> > Type escape sequence to abort.
> > Sending 5, 100-byte ICMP Echos to 172.16.6.1,
> timeout is 2
> seconds:
> > .....
> > Success rate is 0 percent (0/5)
> > R3#
> >
> > Thanks in adv.
> >
> > JP
> >
>
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:56:54 GMT-3