BGP table map

From: Sandro Ciffali (sandyccie@xxxxxxxxx)
Date: Thu Feb 21 2002 - 01:07:44 GMT-3


   
I am doing following in my lab to test table map.

I have R1 Ethernet R3 Frame R4 Ethernet R5

R1 Ebgp R3 BGP redist. Eigrp R4 Redist. Eigrp Ebgp R5

On R1 i have following network 180.10.10.0/24,
181.10.10.0/24, 183.10.10.0/24, 184.10.10.0/24.

I am redistributing two of the above network and
remaining two have network statements. This is done in
order to generate the ? for two and i for the
remaining two. On R3 i see it fine, I am using table
map on R3, redistributing this BGP to eigrp 234 on R3,
So the bgp routes go in IGP table of R3 and R4, Then
on R4 I am using table-map again, I expect on R5 ebgp
table the network origin code to be intact but does
not, Can some one explain to me what i doing wrong?
Following are the configs

R1

interface Loopback0
 ip address 180.10.10.1 255.255.255.0
!
interface Loopback1
 ip address 183.10.10.1 255.255.255.0
!
interface Loopback2
 ip address 181.10.10.1 255.255.255.0
!
interface Loopback3
 ip address 184.10.10.1 255.255.255.0
!
interface Ethernet0/0
 ip address 10.10.10.1 255.255.255.0
 router rip
 network 180.10.0.0
 network 181.10.0.0
!
router bgp 1
 network 183.10.10.0 mask 255.255.255.0
 network 184.10.10.0 mask 255.255.255.0
 redistribute rip
 neighbor 10.10.10.3 remote-as 234
 no auto-summary
R1#sh ip bgp
BGP table version is 13, local router ID is 10.10.10.1
Status codes: s suppressed, d damped, h history, *
valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf
Weight Path
*> 180.10.10.0/24 0.0.0.0 0
32768 ?
*> 181.10.10.0/24 0.0.0.0 0
32768 ?
*> 183.10.10.0/24 0.0.0.0 0
32768 i
*> 184.10.10.0/24 0.0.0.0 0
32768 i

R3
interface Ethernet0/0
 ip address 10.10.10.3 255.255.255.0
interface Serial0/0
 ip address 10.10.20.3 255.255.255.0
 encapsulation frame-relay
 no ip route-cache
 ip split-horizon
 no ip mroute-cache
 frame-relay map ip 10.10.20.2 304 broadcast
 frame-relay map ip 10.10.20.4 304 broadcast
 frame-relay interface-dlci 304
 no frame-relay inverse-arp
router eigrp 234
 redistribute bgp 234 metric 1544 10 255 1 1500
 network 10.0.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
router bgp 234
 table-map setatt
 bgp log-neighbor-changes
 neighbor 10.10.10.1 remote-as 1
ip as-path access-list 10 permit .*
!
route-map setatt permit 10
 match as-path 10
 set automatic-tag

R3#sh ip bgp
BGP table version is 5, local router ID is 10.10.20.3
Status codes: s suppressed, d damped, h history, *
valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf
Weight Path
*> 180.10.10.0/24 10.10.10.1 0
    0 1 ?
*> 181.10.10.0/24 10.10.10.1 0
    0 1 ?
*> 183.10.10.0/24 10.10.10.1 0
    0 1 i
*> 184.10.10.0/24 10.10.10.1 0
    0 1 i
R3#

R3# sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M
- mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA -
OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA
external type 2
       E1 - OSPF external type 1, E2 - OSPF external
type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS
level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static
route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 10.10.10.2 to network
200.200.200.0

D* 200.200.200.0/24 [90/1915392] via 10.10.10.2,
00:38:47, Ethernet0/0
     184.10.0.0/24 is subnetted, 1 subnets
B 184.10.10.0 [20/0] via 10.10.10.1, 00:17:59
     10.0.0.0/24 is subnetted, 3 subnets
C 10.10.10.0 is directly connected, Ethernet0/0
C 10.10.20.0 is directly connected, Serial0/0
D 10.10.30.0 [90/1812992] via 10.10.10.2,
00:38:47, Ethernet0/0
     183.10.0.0/24 is subnetted, 1 subnets
B 183.10.10.0 [20/0] via 10.10.10.1, 00:18:00
     181.10.0.0/24 is subnetted, 1 subnets
B 181.10.10.0 [20/0] via 10.10.10.1, 00:18:01
     180.10.0.0/24 is subnetted, 1 subnets
B 180.10.10.0 [20/0] via 10.10.10.1, 00:18:01

R4
interface Ethernet0/0
 ip address 10.10.30.1 255.255.255.0
interface Serial0/0
 ip address 10.10.20.4 255.255.255.0
 no ip directed-broadcast
 encapsulation frame-relay
 no ip route-cache
 ip split-horizon
 no ip mroute-cache
 logging event subif-link-status
 logging event dlci-status-change
 frame-relay map ip 10.10.20.2 402 broadcast
 frame-relay map ip 10.10.20.3 403 broadcast
 frame-relay interface-dlci 402
 frame-relay interface-dlci 403
 no frame-relay inverse-arp
router eigrp 234
 network 10.0.0.0
router bgp 234
 table-map setta
 redistribute eigrp 234
 neighbor 10.10.30.10 remote-as 50
ip as-path access-list 10 permit .*
route-map setta permit 10
 match as-path 10
 set automatic-tag

R4#sh ip bgp
BGP table version is 7, local router ID is
200.200.200.10
Status codes: s suppressed, d damped, h history, *
valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf
Weight Path
*> 10.0.0.0 0.0.0.0 281600
32768 ?
*> 180.10.0.0 0.0.0.0 0
32768 ?
*> 181.10.0.0 0.0.0.0 0
32768 ?
*> 183.10.0.0 0.0.0.0 0
32768 ?
*> 184.10.0.0 0.0.0.0 0
32768 ?
*> 200.200.200.0 0.0.0.0 0
32768 ?
R4#sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M
- mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA -
OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA
external type 2
       E1 - OSPF external type 1, E2 - OSPF external
type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS
level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

C* 200.200.200.0/24 is directly connected, Loopback0
     184.10.0.0/24 is subnetted, 1 subnets
D EX 184.10.10.0 [170/2172416] via 10.10.20.3,
00:14:40, Serial0/0
     10.0.0.0/8 is variably subnetted, 4 subnets, 2
masks
D 10.10.10.0/24 [90/2195456] via 10.10.20.3,
00:20:42, Serial0/0
                      [90/2195456] via 10.10.20.2,
00:20:42, Serial0/0
D 10.0.0.0/8 is a summary, 00:20:42, Null0
C 10.10.20.0/24 is directly connected, Serial0/0
C 10.10.30.0/24 is directly connected,
Ethernet0/0
     183.10.0.0/24 is subnetted, 1 subnets
D EX 183.10.10.0 [170/2172416] via 10.10.20.3,
00:14:40, Serial0/0
     181.10.0.0/24 is subnetted, 1 subnets
D EX 181.10.10.0 [170/2172416] via 10.10.20.3,
00:14:40, Serial0/0
     180.10.0.0/24 is subnetted, 1 subnets
D EX 180.10.10.0 [170/2172416] via 10.10.20.3,
00:14:40, Serial0/0

R5

interface Ethernet0/0
 ip address 10.10.30.10 255.255.255.0
router bgp 50
 bgp log-neighbor-changes
 neighbor 10.10.30.1 remote-as 234
 neighbor 10.10.30.1 soft-reconfiguration inbound
R5#sh ip bgp
BGP table version is 7, local router ID is 10.10.30.10
Status codes: s suppressed, d damped, h history, *
valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf
Weight Path
*> 10.0.0.0 10.10.30.1 281600
    0 234 ?
*> 180.10.0.0 10.10.30.1 0
    0 234 ?
*> 181.10.0.0 10.10.30.1 0
    0 234 ?
*> 183.10.0.0 10.10.30.1 0
    0 234 ?
*> 184.10.0.0 10.10.30.1 0
    0 234 ?
*> 200.200.200.0 10.10.30.1 0
    0 234 ?



This archive was generated by hypermail 2.1.4 : Thu Jun 20 2002 - 13:46:29 GMT-3