RE: Dialer Watch

From: Steven M. Sowell (ssowell@xxxxxxxx)
Date: Tue Feb 19 2002 - 14:55:22 GMT-3


   
I am using 2600's on 12.1(9), but have used several IOS versions
successfully, with no special effort required for dialer watch to function
over dialer profiles. Here's the pertinent config commands from the two
routers I just used.( YOu may notice some commands in here related to OSPF
demand circuit, but I've done this with EIGRP as well)
Hope this helps,
Steven Sowell
CCIE#7317

hostname R4
username R2 password 0 ccprep
isdn switch-type basic-ni
!
interface Loopback0
 ip address 10.1.194.4 255.255.255.255
!
interface Serial0/0
 ip address 10.1.220.10 255.255.255.252
!
interface BRI0/0
 no ip address
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-ni
 isdn spid1 81355511120101
 isdn spid2 81355511130101
 no peer neighbor-route
 ppp authentication chap
!
interface Dialer1
 ip address 10.1.220.18 255.255.255.252
 encapsulation ppp
 dialer pool 1
 dialer idle-timeout 40
 dialer string 5551110
 dialer watch-group 1
 dialer-group 1
 no peer neighbor-route
 ppp authentication chap
!
router ospf 1
 area 5 nssa no-summary
 network 10.1.220.10 0.0.0.0 area 0
 network 10.1.220.18 0.0.0.0 area 5
!
access-list 110 deny tcp any any eq bgp
access-list 110 deny eigrp any any
access-list 110 permit ip any any
access-list 1001 permit 5040 30.ffff.ffff.ffff 7
dialer watch-list 1 ip 10.1.195.1 255.255.255.255
dialer watch-list 1 ip 10.1.196.0 255.255.255.128
dialer-list 1 protocol ip list 110

hostname R2
username R4 password 0 ccprep
isdn switch-type basic-ni
!
interface Loopback0
 ip address 10.1.192.2 255.255.255.255
!
interface Serial0/0.1 point-to-point
 ip address 10.1.220.6 255.255.255.252
!
interface BRI0/0
 ip address 10.1.220.17 255.255.255.252
 encapsulation ppp
 ip ospf demand-circuit
 dialer idle-timeout 40
 dialer map ip 10.1.220.18 name R4 broadcast 5551112
 dialer-group 1
 isdn switch-type basic-ni
 isdn spid1 81355511100101
 isdn spid2 81355511110101
 isdn caller 5551112
 no peer neighbor-route
 ppp authentication chap
!
router ospf 1
 area 5 nssa no-summary
 network 10.1.192.2 0.0.0.0 area 0
 network 10.1.196.2 0.0.0.0 area 1
 network 10.1.220.6 0.0.0.0 area 0
 network 10.1.220.17 0.0.0.0 area 5
!
access-list 110 deny tcp any any eq bgp
access-list 110 permit ip any any
dialer-list 1 protocol ip list 110

-----Original Message-----
From: RSiddappa@NECBNS.com [mailto:RSiddappa@NECBNS.com]
Sent: Sunday, February 17, 2002 3:36 PM
To: ssowell@gate.net; jlaurens@cisco.com; Guy.Lupi@eurekaggn.com;
ccielab@groupstudy.com
Subject: RE: Dialer Watch

Steven,

What is the IOS verion u r running and did u use any extra commands for it
to work.

R.

-----Original Message-----
From: Steven M. Sowell [mailto:ssowell@gate.net]
Sent: Sunday, February 17, 2002 11:46 AM
To: jlaurens@cisco.com; Siddappa, Rajeev; Guy.Lupi@eurekaggn.com;
ccielab@groupstudy.com
Subject: RE: Dialer Watch

I have dialer watch using dialer profiles as well. Seems to work fine.

-----Original Message-----
From: Jeremy Laurenson (Cisco) [mailto:jlaurens@cisco.com]
Sent: Saturday, February 16, 2002 4:40 PM
To: RSiddappa@NECBNS.com; ssowell@gate.net; Guy.Lupi@eurekaggn.com;
ccielab@groupstudy.com
Subject: RE: Dialer Watch

I beg to differ - I have dialer-watch running on dialer profiles in my lab
here. IOS12.1.11

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
RSiddappa@NECBNS.com
Sent: Saturday, February 16, 2002 11:03 AM
To: ssowell@gate.net; Guy.Lupi@eurekaggn.com; ccielab@groupstudy.com
Subject: RE: Dialer Watch

And it is not possible to use Dialer Wacth on Dialer profile, but u can use
dialer rotary group to configure the Dialer watch if u do not want to
configure some thing on the physical interface.

R.

-----Original Message-----
From: Steven M. Sowell [mailto:ssowell@gate.net]
Sent: Friday, February 15, 2002 4:21 PM
To: Lupi, Guy; Ccielab@Groupstudy. Com
Subject: RE: Dialer Watch

With legacy DDR, you need to ensure that you add an additional dialer-map
statement with an IP address that matches one of your watched networks. For
instance....

interface BRI0/0
 ip address 10.1.220.18 255.255.255.252
 dialer map ip 10.1.220.17 name R2 broadcast 5551110
 dialer watch-group 1
 dialer map ip 10.1.195.1 name R2 broadcast 5551110

dialer watch-list 1 ip 10.1.195.1 255.255.255.255

Notice above that I have my "real" dialer map to the peer BRI IP address,
and I've added another dialer map that matches EXACTLY one of the watched
routes. Dialer profiles do not have this requirement (because you use
"dialer string" instead of "dialer map")

Steven Sowell
CCIE#7317

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Lupi, Guy
Sent: Friday, February 15, 2002 2:39 PM
To: 'ccielab@groupstudy.com'
Subject: Dialer Watch

I am using dialer watch with EIGRP. I have the standard deny eigrp any any,
then permit ip any any in the access list that the dialer list references.
Without a floating static route, I can only get it to come up when I attempt
to ping the far side of the ISDN connection, with a floating static I can
get it to come up with any IP, as it is supposed to. My question is, is
there any way to get the backup to come up without using the floating
static? I don't think there is, but if anyone could help me out here that
would be great, thanks.



This archive was generated by hypermail 2.1.4 : Thu Jun 20 2002 - 13:46:27 GMT-3