Re: TROUBLES-- ISDN simulator from marc russell

From: Zakir A (procket1@xxxxxxxxxxx)
Date: Thu Jan 03 2002 - 02:43:32 GMT-3


   
I changed my configurations to what Paul suggested, with the following
results:
(I have also included show int bri 0 from both routers if somebody can find
something in there)

R1#sh isdn stat
Global ISDN Switchtype = basic-net3
ISDN BRI0 interface
        dsl 0, interface ISDN Switchtype = basic-net3
    Layer 1 Status:
        DEACTIVATED
    Layer 2 Status:
        Layer 2 NOT Activated
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Activated dsl 0 CCBs = 0
    The Free Channel Mask: 0x80000003
    Total Allocated ISDN CCBs = 0
R1#

R1#ping 192.168.1.2
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
1d01h: BR0 DDR: Dialing cause ip (s=192.168.1.1, d=192.168.1.2)
1d01h: BR0 DDR: Attempting to dial 1111
1d01h: ISDN BR0: Outgoing call id = 0x8020
1d01h: ISDN BR0: Event: Call to 1111 at 64 Kb/s
1d01h: ISDN BR0: Activating ....
1d01h: ISDN BR0: Could not bring up interface
1d01h: BRI0: wait for isdn carrier timeout, call id=0x8020
1d01h: ISDN BR0: Shutting down ISDN Layer 3
1d01h: ISDN BR0: Activating .
Success rate is 0 percent (0/5)
R1#
R1#
1d01h: BR0:1 LCP: State is Closed
1d01h: BR0:1 PPP: Phase is DOWN
1d01h: BR0:1 DDR: disconnecting call
1d01h: BR0:2 LCP: State is Closed
1d01h: BR0:2 PPP: Phase is DOWN
1d01h: BR0:2 DDR: disconnecting call
1d01h: ISDN BR0: Physical layer is IF_DOWN
1d01h: ISDN BR0: Could not bring up interface
1d01h: ISDN BR0: Shutting down ISDN Layer 3
1d01h: ISDN BR0: Shutting down ME
1d01h: ISDN BR0: Shutting down ISDN Layer 3

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
!
username R2 password 0 cisco
ip subnet-zero
isdn switch-type basic-net3
!
!
!
!
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
 shutdown

interface Serial0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
 no fair-queue
!
interface BRI0
 ip address 192.168.1.1 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 dialer map ip 192.168.1.2 name R2 broadcast 1111
 dialer-group 1
 isdn switch-type basic-net3
 ppp authentication chap
!
ip classless
!
access-list 101 permit ip any any
dialer-list 1 protocol ip permit
!
line con 0
exec-timeout 0 0
 transport input none
line vty 0 4
!
end

R1#sh int bri 0
BRI0 is up (spoofing), line protocol is up (spoofing)
  Hardware is BRI with U interface and external S bus interface
  Internet address is 192.168.1.1/24
  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, rely 255/255, load 1/255
  Encapsulation PPP, loopback not set
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0 (size/max/drops); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations 0/0/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 output buffer failures, 0 output buffers swapped out
     24 carrier transitions

ISDN_R2#sh int bri 0
BRI0 is up (spoofing), line protocol is up (spoofing)
  Hardware is BRI with integrated NT1
  Internet address is 10.1.1.2/24
  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, rely 255/255, load 1/255
  Encapsulation PPP, loopback not set
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0 (size/max/drops); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/64/0 (size/threshold/drops)
     Conversations 0/1 (active/max active)
     Reserved Conversations 0/0 (allocated/max allocated)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     8 packets output, 64 bytes, 0 underruns
     0 output errors, 0 collisions, 14 interface resets
     0 output buffer failures, 0 output buffers swapped out
     4 carrier transitions

----- Original Message -----
From: "Greg Sporton" <greg.sporton@nec.com.au>
To: "'Zakir A'" <procket1@pacbell.net>; "'paul jin'" <pauljin@yahoo.com>;
<ccielab@groupstudy.com>
Sent: Wednesday, January 02, 2002 8:52 PM
Subject: RE: TROUBLES-- ISDN simulator from marc russell

> What is the L1 and L2 status of the bri interfaces? (show isdn stat) You
> should see something similar to the following:
>
> ISDN BRI1/0 interface
> dsl 8, interface ISDN Switchtype = basic-ts013
> Layer 1 Status:
> ACTIVE
> Layer 2 Status:
> TEI = 68, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
> Layer 3 Status:
> 0 Active Layer 3 Call(s)
> Activated dsl 8 CCBs = 0
> The Free Channel Mask: 0x80000003
>
> Once you have this information we can see if it's a L1, L2 or L3
> problem. Also, do a 'debug isdn q921' and 'debug isdn q931' then try a
> call. That will show if you are communicating with the switch at L1 and
> L2.
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> Zakir A
> Sent: Thursday, 3 January 2002 3:29 PM
> To: paul jin; ccielab@groupstudy.com
> Subject: Re: TROUBLES-- ISDN simulator from marc russell
>
> I have a very similar basic config, but can never get the line up.
>
> ISDN_R2#sh deb
> PPP:
> PPP authentication debugging is on
> PPP protocol negotiation debugging is on
> ISDN:
> ISDN events debugging is on
> Dial on demand:
> Dial on demand events debugging is on
>
>
>
> ISDN_R2#ping 10.1.1.1
>
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
>
> BRI0: Dialing cause ip (s=10.1.1.2, d=10.1.1.1)
> BRI0: Attempting to dial 1111
> ISDN BR0: Event: Call to 1111 at 64 Kb/s
> ISDN BR0: Activating...
> %ISDN-6-LAYER2DOWN: Layer 2 for Interface BRI0, TEI 255 changed to down
> ISDN BR0: received HOST_DISCONNECT_ACK
> BRI0: wait for carrier timeout, call id=0x8005.
> BRI0: Dialing cause ip (s=10.1.1.2, d=10.1.1.1)
> BRI0: Attempting to dial 1111
> ISDN BR0: Event: Call to 1111 at 64 Kb/s
> ISDN BR0: Activating
> BRI0: wait for carrier timeout, call id=0x8006
> ISDN BR0: Physical layer is IF_DOWN
> ISDN BR0: Shutting down ME
> ISDN BR0: Shutting down ISDN Layer 3.
> Success rate is 0 percent (0/5)
> ISDN_R2#
>
> sh run
> Building configuration...
>
> Current configuration:
> !
> version 11.2
> no service udp-small-servers
> no service tcp-small-servers
> !
> hostname ISDN_R2
> !
> !
> username ISDN_R2 password 0 cisco123
> username ISDN_R1 password 0 cisco123
> partition flash 2 8 8
> !
> isdn switch-type basic-net3
> !
> interface Serial0
> no ip address
> shutdown
> no fair-queue
> !
> interface Serial1
> no ip address
> shutdown
> !
> interface TokenRing0
> no ip address
> shutdown
> !
> interface BRI0
> ip address 10.1.1.2 255.255.255.0
> encapsulation ppp
> dialer map ip 10.1.1.1 name ISDN_R1 broadcast 1111
> dialer-group 1
> ppp authentication chap
> !
> no ip classless
> access-list 101 permit ip any any
> dialer-list 1 protocol ip list 101
> !
> line con 0
> line aux 0
> line vty 0 4
> login
> !
> end
> ----- Original Message -----
> From: paul jin
> To: Zakir A ; ccielab@groupstudy.com
> Sent: Wednesday, January 02, 2002 8:12 PM
> Subject: Re: TROUBLES-- ISDN simulator from marc russell
>
>
> Hi,
> I guess you are talking about the slimline?
> Out of the box, the dial number for port 1 is 1111 and port 2 is 2222.
> both
> channels use the same
> number for each port. And switch type is basic-net3.
>
> The only thing that I have changed on the sim is the default number of
> 1111
> to 5551111 and from 2222 to 5552222.
> Hope this helps.
>
> Here is the base config I used to test out the new phone numbers...
>



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:56:14 GMT-3