From: Michael Popovich (m.popovich@xxxxxxxx)
Date: Sun Dec 30 2001 - 03:56:39 GMT-3
I have R1 in AS300. R3 and R2 are in AS200 each with a serial link to R1. R3
and R2 BGP configurations for R1 are exactly the same. I have manipulated
routes from AS300 to set a weight of 450. I noticed that it worked on R2 but
R3 was still showing a weight of 0 and it's next hop was the ip address on
R1's serial interface directly connected to R2 not itself (R3).
Here are the configurations.
R3
router bgp 200
bgp router-id 190.19.15.97
redistribute eigrp 100 route-map localnet
neighbor internal peer-group
neighbor internal remote-as 200
neighbor internal update-source Loopback0
neighbor internal send-community
neighbor AS300 peer-group
neighbor AS300 remote-as 300
neighbor AS300 update-source Serial0
neighbor AS300 route-map AS300 in
neighbor 190.19.15.81 peer-group internal
neighbor 210.10.10.1 peer-group AS300
no auto-summary
!
ip classless
no ip http server
ip as-path access-list 1 permit ^300$
!
route-map setcommunity permit 10
set community no-export
!
route-map localnet permit 10
match route-type internal
!
route-map AS300 permit 10
match as-path 1
set weight 450
R2
router bgp 200
bgp router-id 190.19.15.51
bgp log-neighbor-changes
redistribute eigrp 100 route-map localnet
neighbor internal peer-group
neighbor internal remote-as 200
neighbor internal update-source Loopback0
neighbor internal send-community
neighbor AS300 peer-group
neighbor AS300 remote-as 300
neighbor AS300 update-source Serial0/1
neighbor AS300 route-map AS300 in
neighbor 190.19.15.81 peer-group internal
neighbor 210.10.10.5 peer-group AS300
no auto-summary
!
ip classless
ip http server
ip as-path access-list 1 permit ^300$
!
route-map setcommunity permit 10
set community no-export
!
route-map localnet permit 10
match route-type internal
!
route-map AS300 permit 10
match as-path 1
set weight 450
R1
router bgp 300
bgp router-id 190.1.1.1
bgp log-neighbor-changes
network 190.1.0.0
neighbor AS200 peer-group
neighbor AS200 remote-as 200
neighbor AS200 update-source Loopback0
neighbor 210.10.10.2 peer-group AS200
neighbor 210.10.10.6 peer-group AS200
When I shutdown the Serial interface connecting R1 and R2 then R3 completely
looses the route to 190.1.1.1.
R1's loopback address is 190.1.1.1/16 and is the only network that AS300 is
advertising. AS200 are advertising the serial addresses connecting R2 and R3
to R1.
When I debug BGP updates on R3 it is telling me that 190.1.0.0/16 is being
denied because of a route-map. I have the same route-map configuration on R2
and it works properly.
R2 IOS is 12.1.11
R3 IOS is 12.1(1)
Thanks in advance.
MP
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:32:49 GMT-3