RE: EIGRP auto summary

From: Chua, Parry (Parry.Chua@xxxxxxxxxx)
Date: Sat Dec 29 2001 - 00:27:50 GMT-3


   
Hi,

I do a similar test on redistribution, I get the result as expected,
below is the config,

lo80,81,82--(r5)-e2/2--f0-(r8)
==============================
r5>interface Loopback80
r5> ip address 192.192.192.1 255.255.255.240
!
r5>interface Loopback81
r5> ip address 192.192.192.17 255.255.255.240
!
r5>interface Loopback82
r5> ip address 192.192.192.33 255.255.255.240
!
r5>interface Ethernet2/2
r5> ip address 141.1.80.5 255.255.255.0
!
r5>router eigrp 80
r5> redistribute connected metric 100 10 255 1 1500 route-map sel
r5> network 141.1.0.0
!
r5>route-map sel permit 10
r5> match interface Loopback80 Loopback81 Loopback82
!
!/////////
!
r5>gateway of last resort is not set

r5> 192.192.192.0/28 is subnetted, 3 subnets
r5>C 192.192.192.0 is directly connected, Loopback80
r5>C 192.192.192.16 is directly connected, Loopback81
r5>C 192.192.192.32 is directly connected, Loopback82
r5>

/////////////////////
r8>interface FastEthernet0
r8> ip address 141.1.80.8 255.255.255.0r8>
r8> no ip directed-broadcast
r8> duplex auto
r8> speed auto
!
r8>router eigrp 80
r8> network 141.1.0.0
!
!////////
!
r8>Gateway of last resort is not set
r8>
r8> 192.192.192.0/28 is subnetted, 3 subnets
r8>D EX 192.192.192.0 [170/25605120] via 141.1.80.5, 00:01:44,
FastEthernet0
r8>D EX 192.192.192.16 [170/25605120] via 141.1.80.5, 00:01:44,
FastEthernet0
r8>D EX 192.192.192.32 [170/25605120] via 141.1.80.5, 00:01:44,
FastEthernet0

As you can see that external routes is no autosummary.
Regards
parry
-----Original Message-----
From: Jeongwoo Park [mailto:Jpark@wams.com]
Sent: Friday, December 28, 2001 4:15 AM
To: 'Annu'; Chua, Parry; ccielab@groupstudy.com; 'sandyccie@yahoo.com'
Subject: RE: EIGRP auto summary

Ok. Now I am clear about my original post. Once I removed the secondary
address(172.16.0.0), auto-summary took place in Router A.
But I found something different from what Cisco doc says. This time I
have a
problem because auto-summary is taking place when it is not supposed to
be.
Here is what is going on;
.
When I looked at the Cisco link
http://www.cisco.com/warp/public/103/eigrp5.html#3 that Annu send me, it
says "EIGRP will not auto-summarize external routes unless there is a
component of the same major network that is an internal route. "
In Router A, auto-summary is taking place even if these three loopback
subnets are external to EIGRP.
Here is my config and routing table.
Router A:
!
interface Loopback1
 ip address 172.16.1.1 255.255.255.252
 no ip directed-broadcast
!
interface Loopback2
 ip address 172.16.1.5 255.255.255.252
 no ip directed-broadcast
!
interface Loopback3
 ip address 172.16.1.9 255.255.255.252
 no ip directed-broadcast
!
interface Ethernet0
 ip address 192.168.1.249 255.255.255.0
 no ip directed-broadcast
 no ip split-horizon eigrp 1
!
router eigrp 1
 redistribute connected
  network 192.168.1.0
!
ip http server
ip classless
!
line con 0
 password xxx
 transport input none
 stopbits 1
line vty 0 4
 exec-timeout 0 0
 password xxx
 login
!
end

sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 192.168.1.250 to network 0.0.0.0

     172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
C 172.16.1.8/30 is directly connected, Loopback3
C 172.16.1.4/30 is directly connected, Loopback2
D 172.16.0.0/16 is a summary, 00:40:15, Null0
C 172.16.1.0/30 is directly connected, Loopback1
C 192.168.1.0/24 is directly connected, Ethernet0
D*EX 0.0.0.0/0 [170/32043520] via 192.168.1.250, 00:44:08, Ethernet0

Can someone tell me what I am missing here?

JP

-----Original Message-----
From: Annu [mailto:annu_roopa@yahoo.com]
Sent: Thursday, December 27, 2001 7:09 AM
To: Chua, Parry; Jeongwoo Park; ccielab@groupstudy.com
Subject: RE: EIGRP auto summary

JP,

The reason for ur EIGRP not auto-summarizing is that
by default EIGRP does not auto-summarise external
routes if there is no internal component of that major
network in its table.

>From ur Lab it looks like EIGRP primary add is
192.168.x.x and the net u are trying is 172.16.0.0
which does not have a entry (secondary address dont
count i think).

Look at this example and hopefully this is the
problem.

http://www.cisco.com/warp/public/103/eigrp5.html#3

Hope this helps,and let me know.I want to know what is
the reason if i am not correct.

Annu

--- "Chua, Parry" <Parry.Chua@compaq.com> wrote:
> Hi,
>
> I perform the similar test, the secondary address at
> ethernet is the
> cause of
> no autosummary. Once you remove the secondary Ip
> address, the summary
> route will be
> show in both routers. next you create a secondary IP
> address with
> different major
> network and advertise it, you will see that it does
> not auto summary for
> this new Ip
> address
>
> Parry Chua
>
> -----Original Message-----
> From: Jeongwoo Park [mailto:Jpark@wams.com]
> Sent: Thursday, December 27, 2001 4:28 PM
> To: 'ccielab@groupstudy.com'
> Subject: EIGRP auto summary
>
>
> Hi
> I created the three loopback interfaces in EIGRP
> running router( Router
> A)
> as following to see if this router can do
> auto-summary.
> Router A:
> !
> interface Loopback1
> ip address 172.16.1.1 255.255.255.252
> no ip directed-broadcast
> !
> interface Loopback2
> ip address 172.16.1.5 255.255.255.252
> no ip directed-broadcast
> !
> interface Loopback3
> ip address 172.16.1.9 255.255.255.252
> no ip directed-broadcast
> !
> interface Ethernet0
> ip address 172.16.10.10 255.255.255.0 secondary
> ip address 192.168.1.249 255.255.255.0
> no ip directed-broadcast
> no ip split-horizon eigrp 1
> !
> router eigrp 1
> redistribute connected
> network 172.16.0.0
> network 192.168.1.0
> !
> ip http server
> ip classless
> !
> line con 0
> password xxx
> transport input none
> stopbits 1
> line vty 0 4
> exec-timeout 0 0
> password xxx
> login
> !
> end
>
> now I checked the other router (Router B) that is
> connected through
> Ethernet
> in order to see if this three loopback subnets were
> auto summarized.
> Unfortunately No even if auto-summary was on by
> default.
> From router B, I was able to see each indivisual
> subnet entries, which
> means
> auto-summary is not working.
> I could manually summarize these three subnet after
> disabling
> auto-summary,
> not automatically.
> Do you know why?
>
> I will appreciate your inputs.
>
> JP
>



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:32:49 GMT-3