From: DAN DORTON (DHSTS68@xxxxxxxxxxxxxxx)
Date: Thu Dec 13 2001 - 12:58:58 GMT-3
The routing protocol takes care of the layer 3 portions.
I believe you are correct that in a callback situation that it would
not work.
Maybe then you could drop the dialer-list portion & just add an
access-list & the ip access-group command on the interface. I have not
tried this yet to verify that it works though.
I know when I didn't have the dialer-list on both sides in my first
scenario that the pings would fail, but I didn't try it with just the
ACL & the ip access-group command.
Perhaps it would work with callback if you specify callback dial
string?
Then specify the map-class with a dial-string on the BRI interface?
Just a guess, but I have not tried it.
>>> "Albert Lu" <albert_ccie@yahoo.com> 12/13/01 12:23AM >>>
Yes, looks good. I tried it out, took out the dialer map on the non
initiating side, and it all works. Not sure how though, how it would
get the
mapping for the other side.
I would assume that there is no way of not using dialer maps on both
sides
if it was a callback scenario.
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
DAN DORTON
Sent: Thursday, December 13, 2001 3:14 AM
To: ccielab@groupstudy.com; BAUERR@toysrus.com
Subject: RE: ISDN dial one way only
Yeah like I said... At least I know mine works...
Might not be proper in theory, but I met all the specs of the lab I
was
attempting, so it must be correct?!?!
>>> "Bauer, Rick" <BAUERR@toysrus.com> 12/12/01 09:59AM >>>
You're correct, that's it you need the dialer-group not the map. That
rings
the bell.
-----Original Message-----
From: DAN DORTON [mailto:DHSTS68@dhs.state.il.us]
Sent: Wednesday, December 12, 2001 10:38 AM
To: BAUERR@toysrus.com
Subject: RE: ISDN dial one way only
No problem. I couldn't get it too work without a dialer-list on both
sides. My pings would not go through.
>>> "Bauer, Rick" <BAUERR@toysrus.com> 12/12/01 09:36AM >>>
Damn, news to me thanks...
-----Original Message-----
From: DAN DORTON [mailto:DHSTS68@dhs.state.il.us]
Sent: Wednesday, December 12, 2001 10:31 AM
To: ccielab@groupstudy.com; BAUERR@toysrus.com
Subject: RE: ISDN dial one way only
hostname R3_2612
!
!
username R2_1604 password 0 cisco
memory-size iomem 15
ip subnet-zero
no ip domain-lookup
isdn switch-type basic-ni
!
!
!
!
!
!
process-max-time 200
!
interface BRI0/0
ip address 172.17.59.49 255.255.255.240
encapsulation ppp
ip ospf cost 2000
ip ospf demand-circuit
dialer load-threshold 1 either
dialer-group 1
isdn switch-type basic-ni
isdn spid1 0835866201 8358662
isdn spid2 0835866401 8358664
no peer neighbor-route
ppp authentication chap
ppp multilink
hold-queue 75 in
!
interface Ethernet0/0
ip address 172.17.59.17 255.255.255.240
no keepalive
!
interface Serial0/0
ip address 172.17.59.1 255.255.255.240
encapsulation frame-relay IETF
ip ospf network point-to-multipoint
ip ospf priority 200
no ip mroute-cache
bandwidth 64
no fair-queue
frame-relay map ip 172.17.59.2 101 broadcast IETF
frame-relay map ip 172.17.59.3 201 broadcast IETF
no frame-relay inverse-arp
frame-relay lmi-type cisco
!
interface TokenRing0/0
ip address 172.17.59.97 255.255.255.252
ring-speed 16
!
interface Serial0/1
ip address 172.17.59.33 255.255.255.240
bandwidth 64
clockrate 64000
!
router ospf 1
redistribute connected metric-type 1 subnets route-map con2ospf
redistribute igrp 1 metric-type 1 subnets route-map igrp2ospf
redistribute rip metric-type 1 subnets
passive-interface Ethernet0/0
passive-interface Serial0/1
network 172.17.59.0 0.0.0.15 area 0
network 172.17.59.48 0.0.0.15 area 0
network 172.17.59.96 0.0.0.3 area 4
default-metric 2000
!
router rip
passive-interface BRI0/0
passive-interface Serial0/0
passive-interface TokenRing0/0
passive-interface Serial0/1
network 172.17.0.0
default-metric 3
no auto-summary
!
router igrp 1
passive-interface BRI0/0
passive-interface Ethernet0/0
passive-interface Serial0/0
passive-interface TokenRing0/0
network 172.17.0.0
default-metric 64 20000 255 1 1500
!
ip classless
!
access-list 1 permit 172.17.59.32 0.0.0.15
access-list 2 permit 172.17.59.192 0.0.0.15
dialer-list 1 protocol ip permit
route-map igrp2ospf permit 10
match ip address 2
!
route-map con2ospf permit 10
match ip address 1
!
!
line con 0
line aux 0
line vty 0 4
login
!
no scheduler allocate
end
hostname R2_1604
!
no logging console
!
username R3_2612 password 0 cisco
ip subnet-zero
no ip domain-lookup
!
ip ssh time-out 120
ip ssh authentication-retries 3
isdn switch-type basic-ni
!
!
!
!
interface Ethernet0
ip address 172.17.59.93 255.255.255.252
no keepalive
!
interface Serial0
no ip address
encapsulation frame-relay IETF
no fair-queue
frame-relay lmi-type cisco
!
interface Serial0.1 multipoint
bandwidth 64
ip address 172.17.59.2 255.255.255.240
ip ospf network point-to-multipoint
frame-relay interface-dlci 100
no frame-relay inverse-arp
!
interface BRI0
ip address 172.17.59.50 255.255.255.240
encapsulation ppp
ip ospf cost 2000
ip ospf demand-circuit
dialer map ip 172.17.59.49 name R3_2612 broadcast 18008358662
dialer load-threshold 1 either
dialer-group 1
isdn switch-type basic-ni
isdn spid1 0835866101 8358661
isdn spid2 0835866301 8358663
no peer neighbor-route
ppp authentication chap
ppp multilink
!
router ospf 1
log-adjacency-changes
network 172.17.59.0 0.0.0.15 area 0
network 172.17.59.48 0.0.0.15 area 0
network 172.17.59.92 0.0.0.3 area 1
!
ip classless
no ip http server
ip pim bidir-enable
!
dialer-list 1 protocol ip permit
!
line con 0
line vty 0 4
!
end
R2_1604#sh ip ospf ne
Neighbor ID Pri State Dead Time Address
Interface
172.17.59.97 1 FULL/ - - 172.17.59.49 BRI0
172.17.59.97 200 FULL/ - 00:01:32 172.17.59.1
Serial0.1
R2_1604#
R2_1604#ping 172.17.59.49
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.17.59.49, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 36/36/36 ms
R2_1604#ping 172.17.59.49
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.17.59.49, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28
ms
R2_1604#sh isdn stat
Global ISDN Switchtype = basic-ni
ISDN BRI0 interface
dsl 0, interface ISDN Switchtype = basic-ni
Layer 1 Status:
ACTIVE
Layer 2 Status:
TEI = 110, Ces = 1, SAPI = 0, State =
MULTIPLE_FRAME_ESTABLISHED
TEI = 112, Ces = 2, SAPI = 0, State =
MULTIPLE_FRAME_ESTABLISHED
TEI 110, ces = 1, state = 5(init)
spid1 configured, spid1 sent, spid1 valid
Endpoint ID Info: epsf = 0, usid = 1, tid = 1
TEI 112, ces = 2, state = 5(init)
spid2 configured, spid2 sent, spid2 valid
Endpoint ID Info: epsf = 0, usid = 3, tid = 1
Layer 3 Status:
2 Active Layer 3 Call(s)
CCB:callid=8023, sapi=0, ces=1, B-chan=1, calltype=DATA
CCB:callid=8024, sapi=0, ces=2, B-chan=2, calltype=DATA
Active dsl 0 CCBs = 2
The Free Channel Mask: 0x80000000
Number of L2 Discards = 0, L2 Session ID = 6
Total Allocated ISDN CCBs = 2
R3_2612#ping 172.17.59.50
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.17.59.50, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/26/28
ms
R3_2612#sh isdn sta
Global ISDN Switchtype = basic-ni
ISDN BRI0/0 interface
dsl 0, interface ISDN Switchtype = basic-ni
Layer 1 Status:
ACTIVE
Layer 2 Status:
TEI = 109, Ces = 1, SAPI = 0, State =
MULTIPLE_FRAME_ESTABLISHED
TEI = 111, Ces = 2, SAPI = 0, State =
MULTIPLE_FRAME_ESTABLISHED
Spid Status:
TEI 109, ces = 1, state = 5(init)
spid1 configured, spid1 sent, spid1 valid
Endpoint ID Info: epsf = 0, usid = 2, tid = 1
TEI 111, ces = 2, state = 5(init)
spid2 configured, spid2 sent, spid2 valid
Endpoint ID Info: epsf = 0, usid = 4, tid = 1
Layer 3 Status:
2 Active Layer 3 Call(s)
Activated dsl 0 CCBs = 2
CCB:callid=0x23, sapi=0x0, ces=0x1, B-chan=1
CCB:callid=0x24, sapi=0x0, ces=0x1, B-chan=2
The Free Channel Mask: 0x80000000
Total Allocated ISDN CCBs = 2
It works for me anyways....
Dan
>>> "Bauer, Rick" <BAUERR@toysrus.com> 12/12/01 09:11AM >>>
I disagree, a dialer map statements map layer 3 address to an isdn
telephone
number. With out a map statement no traffic is passed. If you want to
have
one side dial and the other only answer the don't include the
dialer-group.
-----Original Message-----
From: DAN DORTON [mailto:DHSTS68@dhs.state.il.us]
Sent: Wednesday, December 12, 2001 9:21 AM
To: ccielab@groupstudy.com; albert_ccie@yahoo.com
Subject: Re: ISDN dial one way only
If you are running a routing protocol like an OSPF demand circuit you
should only need a dialer map on the side that you want to initiate
the
call.
You need to allow for interesting traffic on both sides though.
At least that is the way that I have been doing it.
>>> "Albert Lu" <albert_ccie@yahoo.com> 12/12/01 01:58AM >>>
Hello Group,
I'm having a little confusion here regarding ISDN dialing out only
from
one
side, so the other side is not allowed to initate a call. From what I
have
tested before, the dialer statements below should work.
dialer map ip 138.1.35.2 name R5 broadcast
dialer map ip 138.1.35.1 name R3 broadcast 2222
But the only way I can get pings to reply is by adding a number at the
end
of the first dialer map:
dialer map ip 138.1.35.2 name R5 broadcast 1111
R5 does dial out and establishes connection, but it looks like R3 does
not
know how to respond.
Am I missing something?
Albert
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:32:43 GMT-3