From: SFeldberg@xxxxxxxxxxxxx
Date: Tue Dec 04 2001 - 18:11:20 GMT-3
The answer is to have IGRP advertise another calassful network from R2 ( I
used 150.200.0.0/16). R1 then uses "ip default-network 150.200.0.0" to
allow IGRP to establish a default route to r2 without static routes.
On the other side of the network, R3 was not seeing a route back to
140.200.1.0. Having the OSPF process on R2 "default-information oringinate
always" remedied that situation. See configs below.
r1#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is 130.1.1.2 to network 150.200.0.0
1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
140.200.0.0/24 is subnetted, 1 subnets
C 140.200.1.0 is directly connected, Ethernet0
130.1.0.0/24 is subnetted, 2 subnets
I 130.1.2.0 [100/10476] via 130.1.1.2, 00:00:09, Serial0.1
C 130.1.1.0 is directly connected, Serial0.1
I* 150.200.0.0/16 [100/8976] via 130.1.1.2, 00:00:09, Serial0.1
r1#ping 140.200.2.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 140.200.2.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/7/12 ms
r1#sh run
Building configuration...
Current configuration : 1255 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r1
!
!
!
!
!
!
network-clock base-rate 56k
ip subnet-zero
no ip domain-lookup
!
!
controller T1 0
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0
ip address 140.200.1.1 255.255.255.0
!
interface Serial0
no ip address
encapsulation frame-relay
no frame-relay inverse-arp
frame-relay lmi-type cisco
!
interface Serial0.1 point-to-point
ip address 130.1.1.1 255.255.255.0
frame-relay interface-dlci 406
!
interface Serial1
no ip address
shutdown
!
interface Switch0
no ip address
encapsulation frame-relay
no fair-queue
!
interface FR-ATM20
no ip address
shutdown
!
router igrp 12
network 130.1.0.0
network 140.200.0.0
!
ip classless
ip default-network 150.200.0.0
no ip http server
!
!
!
gatekeeper
shutdown
!
!
line con 0
privilege level 15
logging synchronous
line aux 0
line 2 3
line vty 0 4
!
!
voice-port 1/1
timeouts call-disconnect 0
!
voice-port 1/2
timeouts call-disconnect 0
!
voice-port 1/3
timeouts call-disconnect 0
!
voice-port 1/4
timeouts call-disconnect 0
!
voice-port 1/5
timeouts call-disconnect 0
!
voice-port 1/6
timeouts call-disconnect 0
!
!
!
end
r1#
Xyplex -012- LAB:6 session 2 resumed
r2#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
140.200.0.0/16 is variably subnetted, 2 subnets, 2 masks
I 140.200.0.0/16 [100/8576] via 130.1.1.1, 00:01:01, Serial0.1
O IA 140.200.2.0/24 [110/74] via 130.1.2.3, 00:08:43, Serial0.3
130.1.0.0/24 is subnetted, 2 subnets
C 130.1.2.0 is directly connected, Serial0.3
C 130.1.1.0 is directly connected, Serial0.1
C 150.200.0.0/16 is directly connected, Loopback0
r2#sh run
Building configuration...
Current configuration : 1442 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r2
!
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
!
!
interface Loopback0
ip address 150.200.0.2 255.255.0.0
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
no ip address
encapsulation frame-relay
frame-relay lmi-type cisco
!
interface Serial0.1 point-to-point
ip address 130.1.1.2 255.255.255.0
frame-relay interface-dlci 604
!
interface Serial0.3 point-to-point
ip address 130.1.2.2 255.255.255.0
frame-relay interface-dlci 605
!
interface Serial1
no ip address
shutdown
!
interface BRI0
no ip address
shutdown
isdn x25 static-tei 0
!
router ospf 23
log-adjacency-changes
redistribute igrp 12 subnets route-map igrp2ospf
network 130.1.2.0 0.0.0.255 area 0
!
router igrp 12
redistribute ospf 23 metric 1 1 1 1 1 route-map ospf2igrp
passive-interface Serial0.3
network 130.1.0.0
network 150.200.0.0
!
ip classless
ip http server
!
access-list 101 permit ip host 140.200.2.0 host 255.255.255.0
access-list 101 permit ip host 130.1.2.0 host 255.255.255.0
access-list 102 permit ip host 140.200.1.0 host 255.255.255.0
access-list 102 permit ip host 130.1.1.0 host 255.255.255.0
route-map ospf2igrp permit 10
match ip address 101
!
route-map igrp2ospf permit 10
match ip address 102
!
!
!
line con 0
privilege level 15
logging synchronous
line aux 0
line vty 0 4
!
end
r3#ping 140.200.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 140.200.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/9/20 ms
r3#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is 130.1.2.2 to network 0.0.0.0
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback0
140.200.0.0/24 is subnetted, 1 subnets
C 140.200.2.0 is directly connected, Ethernet0
130.1.0.0/24 is subnetted, 2 subnets
C 130.1.2.0 is directly connected, Serial0.1
O E2 130.1.1.0 [110/20] via 130.1.2.2, 00:22:37, Serial0.1
O*E2 0.0.0.0/0 [110/1] via 130.1.2.2, 00:00:28, Serial0.1
r3#sh run
Building configuration...
Current configuration : 1021 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r3
!
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Ethernet0
ip address 140.200.2.3 255.255.255.0
!
interface Serial0
no ip address
encapsulation frame-relay
no frame-relay inverse-arp
frame-relay lmi-type cisco
!
interface Serial0.1 point-to-point
ip address 130.1.2.3 255.255.255.0
frame-relay interface-dlci 506
!
interface Serial1
no ip address
shutdown
!
interface BRI0
no ip address
shutdown
isdn x25 static-tei 0
!
router eigrp 12
network 3.3.3.3 0.0.0.0
network 10.10.10.4 0.0.0.3
no auto-summary
no eigrp log-neighbor-changes
!
router ospf 32
log-adjacency-changes
passive-interface Ethernet0
network 130.1.2.0 0.0.0.255 area 0
network 140.200.2.0 0.0.0.255 area 3
!
ip classless
ip http server
!
!
!
line con 0
privilege level 15
logging synchronous
line aux 0
line vty 0 4
login
!
end
r3#
Steve
David Bader
<David.Bader@e To: "CCIE Lab (E-mail)" <ccielab@g
roupstudy.com>
conis.com> cc:
Sent by: Subject: OSPF / IGRP update drop
nobody@groupst
udy.com
12/04/2001
01:43 PM
Please respond
to David Bader
Hi group
Big problem !!!
140.200.1.0/24 |---R1
|
130.1.1.0/24 |
|
R2----R3---| 140.200.2.0/24
130.1.2.0/24
This problem is a little bit tricky to understand. R2 and R3 are running
OSPF between them and on R3's Lan. R1 and R2 are running IGRP between each
other and on R1's Lan. R2 is mutually redistributing between OSPF and IGRP.
Now to the Problem: the 140.200.2.0/24 gets redistributed as 140.200.0.0/16
on R2. The route comes to R1 but is rejected because it has already a route
from the same major net in its routing table
(http://www.cisco.com/warp/public/105/54.html). The other way
140.200.1.0/24
gets advertised as 140.200.0.0/16 to R2 and is installed in R2's routing
table and in R3's routing table too because of redistribution. So, R3 has a
route to R1 (140.200.0.0/16), but R1 has no route back.
How can i solve this problem without using static routes?
any ideas?
regards dave
David Bader / Systems Engineer / NOS
-------------------------------------------------------------------
ECON!S AG / eBusiness Solutions
- Electronic Business Solutions
- Network and Office Solutions
- Consulting and Projectmanagement
Neumattstrasse 7 / CH 8953 Dietikon / Switzerland
Phone ++41 (0) 1 744 73 73
Direct ++41 (0) 1 744 73 25
Fax ++ 41 (0) 1 744 73 99
<mailto:david.bader@econis.com>
<http://www.econis.com/>
-------------------------------------------------------------------
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:32:37 GMT-3