RE: Another Redistribution Question

From: Nigel Roy (nigel@xxxxxxxxxxxxxxxxx)
Date: Tue Dec 04 2001 - 12:57:01 GMT-3


   
Michael,

>From my study of redistribution the following are the rules used when
you redistribute.

1. The route must be in the IP routing table to be eligible for
redistribution.

2. The route must have been learned by the source protocol or be in a
network statement for the source protocol.

My understanding of the reason for this is to prevent routes going from
one protocol to another and then back again.

Hope this helps

Regards

Nigel

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Michael Brady
Sent: 04 December 2001 04:31
To: ccielab@groupstudy.com
Subject: Another Redistribution Question

I have a question regarding redistribution. I've searched the archives,
and
I can't find
what I'm looking for. I have a simple network like the one below. We
will
say that the
connections between R1, R2 & R3 are serial connections and R2 & R4 is
ethernet. The
network between R1 and R2 and a loopback on R1 is in IGRP 12, the
network
between
R2 and R3 and a loopback on R3 is in EIGRP 23, and the network between
R2
and R4
a loopback on each are running OSPF. On R2, I redistribute between IGRP
and
OSPF,
and between OSPF and EIGRP (not EIGRP and IGRP). My question is why
don't
the
EIGRP routes show up on R1, and the IGRP routes on R3? I only see the
OSPF
routes.
If I look at the OSPF database on R2, I see all of the routes. I would
think that since R2
has the routes in its OSPF database, they would be redistributed into
the
other protocols.
Do I have to redistribute between EIGRP and IGRP too for this to work?
Is
this supposed
to work this way, or am I missing something? Any assistance
understanding
this would
be greatly appreciated.

Thanks!
Michael

R1-------R2-------R3
          |
        R4

CONFIGS:
R1
hostname R1
!
no ip domain-lookup
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 no ip address
 shutdown
!
interface Serial1
 ip address 12.12.12.1 255.255.255.0
 clockrate 64000
!
router igrp 12
 network 1.0.0.0
 network 12.0.0.0
!
line con 0
line aux 0
line vty 0 4
 login
!
end

R2
hostname R2
!
no ip domain-lookup
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0
 ip address 24.24.24.2 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
 ip address 23.23.23.2 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 clockrate 64000
!
interface Serial1
 ip address 12.12.12.2 255.255.255.0
 no ip directed-broadcast
!
router eigrp 23
 redistribute ospf 1 metric 64000 100 255 1 1500
 network 23.0.0.0
!
router ospf 1
 redistribute eigrp 23 metric 20 subnets
 redistribute igrp 12 metric 20 subnets
 network 2.2.2.2 0.0.0.0 area 2
 network 24.24.24.0 0.0.0.255 area 0
!
router igrp 12
 redistribute ospf 1 metric 64000 100 255 1 1500
 network 12.0.0.0
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
end

R3
hostname R3
!
no ip domain-lookup
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
 ip address 23.23.23.3 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
!
router eigrp 23
 network 3.0.0.0
 network 23.0.0.0
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
end

R4
hostname R4
!
no ip domain-lookup
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.0
 no ip directed-broadcast
 ip ospf network point-to-point
!
interface Ethernet0
 ip address 24.24.24.4 255.255.255.0
 no ip directed-broadcast
!
router ospf 1
 network 4.4.4.4 0.0.0.0 area 1
 network 24.24.24.0 0.0.0.255 area 0
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
end



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 10:32:37 GMT-3