RE: 2509AS

From: paul jin (pauljin@xxxxxxxxx)
Date: Fri Nov 30 2001 - 01:44:12 GMT-3


   
 Yup!
mine is setup the same way. I am using the same type of AS2509-RJ. 4 RAM and
8 Flash

!
version 12.0
service timestamps debug datetime
service timestamps log datetime
no service password-encryption
!
hostname r9-2509
!
enable password
!
ip subnet-zero
ip host r1 2001 111.111.111.111
ip host r2 2002 111.111.111.111
ip host r3 2003 111.111.111.111
ip host r4 2004 111.111.111.111
ip host r5 2005 111.111.111.111
ip host r6 2006 111.111.111.111
ip host r7 2007 111.111.111.111
ip host r8 2008 111.111.111.111
ip host r10 2009 111.111.111.111
clock timezone gmt 0
!
!
!
interface Loopback0
 ip address 111.111.111.111 255.255.255.255
 no ip directed-broadcast
!
interface Ethernet0
 description betty's test config
 ip address 10.10.10.2 255.255.255.0 secondary
 ip address 109.1.15.7 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
 ip address 100.100.100.2 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
!
router ospf 100
 network 10.0.0.0 0.0.0.255 area 0
 network 10.0.0.0 0.255.255.255 area 0
!
router bgp 100
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.10.1
!
banner motd ^C
Unauthorized user will be prosecuted.
Please log off now!!
^C
!
line con 0
 password
 login
 transport input none
line 1 8
 no exec
 transport input all
line aux 0
 no exec
 transport input all
line vty 0 4
 password
 login
!
ntp clock-period 17178680
ntp server 131.216.22.15
end

  DAN DORTON <DHSTS68@dhs.state.il.us> wrote: You can do this even if the IOS d
oesn't recognize the async ports????

>>> "Joe Freeman" 11/29/01 01:47PM >>>
You don't need the remote access feature set to run it as a term server...

configure like this:

line 1 16
session-timeout 10
no exec
transport input all

then you can simply telnet to port 2001 for line 1, up to 2016 for line 16,
using the ip of your loopback or ethernet interfaces...

Joe Freeman, CCNP-VA/CCDP

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
DAN DORTON
Sent: Thursday, November 29, 2001 1:27 PM
To: brian@5g.net; ccielab@groupstudy.com
Subject: RE: 2509AS

Yes I know. This is what I was trying to point out. I needed to use all the
interfaces & still be able to run OSPF.

I am using this AS as my terminal server so I need the async interfaces as
well.

I have redesigned my lab to where I don't need ospf running on this router.

Thanks for the input.

>>> "Brian Dennis"
11/29/01 01:19PM >>>
Dan,
You are running the "Remote Access Server" feature set of IOS. That feature
set doesn't support BGP and OSPF. You should change to something like "IP
Plus" if you want BGP and OSPF. With 8 flash and 4 DRAM you should be able
to run at least IP Plus for 11.2.

As far as the async interfaces goes I don't need them so I didn't configure
them.

Brian Dennis, CCIE #2210 (R&S)(ISP/Dial) CCSI #98640
5G Networks, Inc.
bdennis@5g.net

-----Original Message-----
From: DAN DORTON [mailto:DHSTS68@dhs.state.il.us]
Sent: Thursday, November 29, 2001 11:03 AM
To: brian@5g.net; ccielab@groupstudy.com
Subject: RE: 2509AS

Where is the config for the async interfaces in your router config you
posted?

Here is what I get. Keep in mind that I am only going by what TAC told me.

r4#sh ver
Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-C-L), Version 12.0(9), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2000 by cisco Systems, Inc.
Compiled Mon 24-Jan-00 22:50 by bettyl
Image text-base: 0x0302D4E4, data-base: 0x00001000

ROM: System Bootstrap, Version 11.0(10c)XB1, PLATFORM SPECIFIC RELEASE
SOFTWARE (fc1)
BOOTFLASH: 3000 Bootstrap Software (IGS-BOOT-R), Version 11.0(10c)XB1,
PLATFORM SPECIFIC RELEASE SOF
TWARE (fc1)

r4 uptime is 2 hours, 5 minutes
System restarted by reload
System image file is "flash:c2500-c-l.120-9.bin"

cisco AS2509-RJ (68030) processor (revision I) with 2048K/2048K bytes of
memory.
Processor board ID 12870761, with hardware revision 00000000
Bridging software.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
X.25 software, Version 3.0.0.
TN3270 Emulation software.
1 Ethernet/IEEE 802.3 interface(s)
1 Serial network interface(s)
--More--
02:05:57: %SYS-5-CONFIG_I: Configured from console by console
8 terminal line(s)
32K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read ONLY)

Configuration register is 0x2102

r4#config t
Enter configuration commands, one per line. End with CNTL/Z.
r4(config)#router ?
bgp Border Gateway Protocol (BGP)
egp Exterior Gateway Protocol (EGP)
eigrp Enhanced Interior Gateway Routing Protocol (EIGRP)
igrp Interior Gateway Routing Protocol (IGRP)
isis ISO IS-IS
iso-igrp IGRP for OSI networks
mobile Mobile routes
odr On Demand stub Routes
ospf Open Shortest Path First (OSPF)
rip Routing Information Protocol (RIP)
static Static routes
traffic-engineering Traffic engineered routes

r4(config)#router ospf 1
Unknown routing protocol
r4(config)#router bgp 1
Unknown routing protocol
r4(config)#router rip
r4(config-router)#exit
r4(config)#router eigrp 1
r4(config-router)#exit
r4(config)#router igrp 1
r4(config-router)#exit
r4(config)#end
r4#
02:06:52: %SYS-5-CONFIG_I: Configured from console by console
r4#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r4
!
ip subnet-zero
ip host r8 2008 1.1.1.1
ip host r7 2007 1.1.1.1
ip host r1 2001 1.1.1.1
ip host r6 2006 1.1.1.1
ip host r5 2005 1.1.1.1
ip host r3 2003 1.1.1.1
ip host r9 2002 1.1.1.1
ip host r4 (edit IP)
ip host r2 2004 1.1.1.1
ip domain-name (edit IP)
ip name-server (edit IP)
ip name-server (edit IP)
clock timezone central -6
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
no ip directed-broadcast
!
interface Loopback1
ip address (edit IP)
no ip directed-broadcast
!
interface Ethernet0
ip address (edit IP)
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
!
interface Serial0
ip address (edit IP)
no ip directed-broadcast
encapsulation frame-relay
no ip route-cache
no ip mroute-cache
keepalive 15
frame-relay interface-dlci 405
frame-relay lmi-type ansi
!
interface Async1
description Top Cisco 1604
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
keepalive 10
!
interface Async2
description Cisco 2520
no ip address
no ip directed-broadcast
!
interface Async3
description Bottom Cisco 1604
no ip address
no ip directed-broadcast
!
interface Async4
description Cisco 3600
no ip address
no ip directed-broadcast
!
interface Async5
description Router5
no ip address
no ip directed-broadcast
!
interface Async6
description Router6
no ip address
no ip directed-broadcast
!
interface Async7
no ip address
no ip directed-broadcast
!
interface Async8
no ip address
no ip directed-broadcast
!
interface Async9
no ip address
no ip directed-broadcast
!
no ip classless
(edit IP)
!
!
line con 0
exec-timeout 0 0
logging synchronous
transport input none
line 1 8
exec-timeout 0 0
modem InOut
transport input all
line aux 0
password console
login
modem InOut
transport input all
stopbits 1
flowcontrol hardware
line vty 0 4
exec-timeout 0 0
login
!
end

Got me what the deal is. I am using the remote access server IOS which is
the only one that I have found that will allow the Async ports to function.

I could put the standard 2500 software on & it would probably work, but then
my async ports are not functionable. I need them all to work.

Thanks,
Dan

>>> "Brian Dennis"
11/29/01 12:44PM >>>
The proof is in the pudding.....

AS#sho ver
Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-JS-L), Version 12.0(10), RELEASE SOFTWARE
(fc1)
Copyright (c) 1986-2000 by cisco Systems, Inc.
Compiled Mon 20-Mar-00 22:54 by phanguye
Image text-base: 0x03051DD4, data-base: 0x00001000

ROM: System Bootstrap, Version 11.0(10c), SOFTWARE
BOOTFLASH: 3000 Bootstrap Software (IGS-BOOT-R), Version 11.0(10c), RELEASE
SOFT
WARE (fc1)

AS uptime is 1 week, 1 day, 1 hour, 27 minutes
System restarted by power-on
System image file is "flash:2500-120-10.bin"

cisco 2509 (68030) processor (revision M) with 14336K/2048K bytes of memory.
Processor board ID 20478243, with hardware revision 00000000
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
TN3270 Emulation software.
1 Ethernet/IEEE 802.3 interface(s)
2 Serial network interface(s)
8 terminal line(s)
32K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read ONLY)

Configuration register is 0x2102

AS#conf t
Enter configuration commands, one per line. End with CNTL/Z.
AS(config)#router bgp 1
AS(config-router)#net 10.0.0.0
AS(config-router)#neigh 10.10.10.2 remote-as 1
AS(config-router)#exit
AS(config)#router ospf 1
AS(config-router)#net 172.16.0.0 0.0.255.255 area 0
AS(config-router)#^Z
AS#
1w1d: %SYS-5-CONFIG_I: Configured from console by console
AS#wr t
Building configuration...

Current configuration:
!
version 12.0
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname AS
!
!
ip subnet-zero
!
!
!
interface Ethernet0
ip address 10.10.10.10 255.255.255.0
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
!
interface Serial0
ip address 172.16.1.10 255.255.255.0
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
!
interface Serial1
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
shutdown
!
router ospf 1
network 172.16.0.0 0.0.255.255 area 0
!
router bgp 1
network 10.0.0.0
neighbor 10.10.10.2 remote-as 1
!
ip classless
!
!
!
line con 0
line 1 8
line aux 0
line vty 0 4
login
!
end

AS#

-----Original Message-----
From: DAN DORTON [mailto:DHSTS68@dhs.state.il.us]
Sent: Thursday, November 29, 2001 10:38 AM
To: brian@5g.net; ccielab@groupstudy.com
Subject: RE: 2509AS

This is an 2509 remote access server.

When I try to configure OSPF, or BGP on the router it says unknown routing
protocol.

Although I can configure RIP, IGRP, or EIGRP.

Memory has nothing to do with it.

When I do a router ? under the config it shows OSPF & BGP, but it will not
allow you to configure them.

I repeat TAC says these two protocols are unsupported on this unit.

Thanks,

>>> "Brian Dennis"
11/29/01 12:12PM >>>
Dan,
A 2509 will support BGP and OSPF. I think TAC must not have understand what
you were asking.

Brian Dennis, CCIE #2210 (R&S)(ISP/Dial) CCSI #98640
5G Networks, Inc.
bdennis@5g.net

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
DAN DORTON
Sent: Thursday, November 29, 2001 9:41 AM
To: DAN DORTON; ccielab@groupstudy.com
Subject: Re: 2509AS

Nevermind. TAC answered my question.

Apparently the BGP & OSPF processes are too CPU intensive for that unit &
are unsupported.

Thanks anyways,

>>> "DAN DORTON" 11/29/01 11:13AM >>>
I am having trouble finding an IOS that supports OSPF & BGP routing on my
2509AS.

It only has 8MB flash & 4MB ram.

Am I missing something here? It will use RIP & EIGRP.

Thanks in advance.
Paul Jin, CCNP, CCDA, MCSE+I
Network Engineer
PaulJin@Yahoo.com

---------------------------------
Do You Yahoo!?
Yahoo! GeoCities - quick and easy web site hosting, just $8.95/month.



This archive was generated by hypermail 2.1.4 : Fri Jun 21 2002 - 06:45:27 GMT-3